aboutsummaryrefslogtreecommitdiff
path: root/print/yatex
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-10-05 02:46:12 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-10-05 02:46:12 +0000
commit0621af5b394d7916e38f73837e6f2489f3256511 (patch)
treefaa6703347f8ce9d960e230d5958948a4acf8852 /print/yatex
parentc6489c802f5393de03d301edc25a123b5996f9d6 (diff)
downloadports-0621af5b394d7916e38f73837e6f2489f3256511.tar.gz
ports-0621af5b394d7916e38f73837e6f2489f3256511.zip
Notes
Diffstat (limited to 'print/yatex')
-rw-r--r--print/yatex/Makefile134
-rw-r--r--print/yatex/files/MESSAGE.tmpl12
-rw-r--r--print/yatex/files/pkg-deinstall.in (renamed from print/yatex/files/DEINSTALL.tmpl)1
-rw-r--r--print/yatex/files/pkg-install.in (renamed from print/yatex/files/INSTALL.tmpl)1
-rw-r--r--print/yatex/files/pkg-message.in10
-rw-r--r--print/yatex/files/yatex-startup.el.in (renamed from print/yatex/files/yatex-startup.el.tmpl)1
-rw-r--r--print/yatex/pkg-descr14
-rw-r--r--print/yatex/pkg-plist.emacs17
-rw-r--r--print/yatex/pkg-plist.mule42
-rw-r--r--print/yatex/pkg-plist.xemacs7
-rw-r--r--print/yatex/pkg-plist.xemacs-mule1
11 files changed, 78 insertions, 162 deletions
diff --git a/print/yatex/Makefile b/print/yatex/Makefile
index 04d35ac015ea..17de7cab6814 100644
--- a/print/yatex/Makefile
+++ b/print/yatex/Makefile
@@ -7,76 +7,89 @@
PORTNAME= yatex
PORTVERSION= 1.73
+PORTREVISION= 1
CATEGORIES?= print elisp
MASTER_SITES= http://www.yatex.org/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
-COMMENT?= Yet Another LaTeX mode and html mode on Emacs (for Emacs{19,20} and XEmacs{19,20})
+COMMENT= Yet Another LaTeX mode and html mode on Emacs
-PKGINSTALL= ${WRKDIR}/INSTALL
-PKGDEINSTALL= ${WRKDIR}/DEINSTALL
-PKGMESSAGE= ${WRKDIR}/MESSAGE
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+DESCR= ${PKGDIR}/pkg-descr
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+SUB_FILES= pkg-install pkg-deinstall pkg-message yatex-startup.el
+SUB_LIST= TARGETNAME=${TARGETNAME} \
+ VERSION=${PORTVERSION} \
+ BASENAME=${BASENAME} \
+ CAT=${CAT} \
+ CP=${CP} \
+ ECHO=${ECHO_CMD} \
+ GREP=${GREP} \
+ RM=${RM} \
+ SED=${SED} \
+ TOUCH=${TOUCH} \
+ DO_NADA=${DO_NADA} \
+ INFODIR=${INFODIR} \
+ ELISPDIR=${ELISPDIR} \
+ INFOFILES=${INFOFILES} \
+ INFONODES="${INFONODES}" \
+ INFONODEEXPS="${INFONODEEXPS}" \
+ DIRSECTION="${DIRSECTION}" \
+ EMACS_NAME=${EMACS_NAME}
USE_EMACS= yes
-EMACS_PORT_NAME?=emacs21
EMACS_NO_RUN_DEPENDS=YES
-.if (${EMACS_PORT_NAME} != xemacs21-mule)
-EMACS_NO_BUILD_DEPENDS=YES
-.endif
+EMACS_MASTERDIR_PKGFILES=YES
+EMACS_PACKAGESDIR=${EMACS_LIBDIR}/site-packages
-VERSION= ${PORTVERSION}
TARGETNAME= YaTeX
DIRSECTION= The Emacs editor and associated tools
-EMACS_PACKAGESDIR=${EMACS_LIBDIR}/site-packages
+
# Note that 'INFODIR' is defined in bsd.info.mk
+
+.include <bsd.port.pre.mk>
+
.if (${EMACS_PORT_NAME} == xemacs21)
+EMACS_NO_BUILD_DEPENDS= YES
INFODIR= ${PREFIX}/${EMACS_PACKAGESDIR}/info
ELISPDIR= ${PREFIX}/${EMACS_PACKAGESDIR}/lisp
HELPDIR= ${PREFIX}/${EMACS_LIBDIR}/site-lisp
PLIST= ${PKGDIR}/pkg-plist.xemacs
MANIFEST= MANIFEST.yatex
+HELP= help/YATEXHLP.eng
+INFOFILES= yatexe:yahtmle
+INFONODES= YaTeX:yahtml
+INFONODEEXPS= Yet Another tex-mode for Emacs.:Yet Another HTML mode.
.elif (${EMACS_PORT_NAME} == xemacs21-mule)
INFODIR= ${PREFIX}/${EMACS_PACKAGESDIR}/info
ELISPDIR= ${PREFIX}/${EMACS_PACKAGESDIR}/lisp
HELPDIR= ${PREFIX}/${EMACS_LIBDIR}/site-lisp
PLIST= ${PKGDIR}/pkg-plist.xemacs-mule
MANIFEST= MANIFEST.yatex
-.elif (${EMACS_PORT_NAME} == mule)
-INFODIR= ${PREFIX}/info
-PLIST= ${PKGDIR}/pkg-plist.mule
-ELISPDIR= ${PREFIX}/${EMACS_LIBDIR}/site-lisp
-HELPDIR= ${ELISPDIR}
+HELP= help/YATEXHLP.jp help/YATEXHLP.eng
+PORTDOCS= 00readme readme.meadow.j yatex.new yatexj.tex yatex.ref \
+ yahtmlj.tex htmlqa yatexadd.doc yatexgen.doc qanda
+INFOFILES= yatexj:yatexe:yahtmlj:yahtmle
+INFONODES= YaTeX-jp:YaTeX:yahtml-jp:yahtml
+INFONODEEXPS= Yet Another tex-mode for Emacs. (Japanese):Yet Another tex-mode for Emacs.:Yet Another HTML mode. (Japanese):Yet Another HTML mode.
.else
+EMACS_NO_BUILD_DEPENDS= YES
INFODIR= ${PREFIX}/info
PLIST= ${PKGDIR}/pkg-plist.emacs
ELISPDIR= ${PREFIX}/${EMACS_LIBDIR}/site-lisp
HELPDIR= ${ELISPDIR}
-.endif
-PORTSDOCDIR= ${PREFIX}/share/doc/yatex
-.if (${EMACS_PORT_NAME} == xemacs21)
-DOCS=
-HELP= help/YATEXHLP.eng
-INFOFILES= yatexe:yahtmle
-INFONODES= YaTeX:yahtml
-INFONODEEXPS= Yet Another tex-mode for Emacs.:Yet Another HTML mode.
-.else
-DOCS= 00readme readme.meadow.j yatex.new
HELP= help/YATEXHLP.jp help/YATEXHLP.eng
-DOCSRC= docs/yatexj.tex \
- docs/yatex.ref \
- docs/yahtmlj.tex docs/htmlqa \
- docs/yatexadd.doc docs/yatexgen.doc \
- docs/qanda
+PORTDOCS= 00readme readme.meadow.j yatex.new yatexj.tex yatex.ref \
+ yahtmlj.tex htmlqa yatexadd.doc yatexgen.doc qanda
INFOFILES= yatexj:yatexe:yahtmlj:yahtmle
INFONODES= YaTeX-jp:YaTeX:yahtml-jp:yahtml
INFONODEEXPS= Yet Another tex-mode for Emacs. (Japanese):Yet Another tex-mode for Emacs.:Yet Another HTML mode. (Japanese):Yet Another HTML mode.
.endif
-DOCSRC+= docs/yatexe.tex \
- docs/htmlqa.eng docs/yahtmle.tex \
- docs/yatexref.eng \
- docs/qanda.eng
+
+PORTDOCS+= yatexe.tex htmlqa.eng yahtmle.tex yatexref.eng qanda.eng
EL_FILES= comment.el yatex.el yatexadd.el yatexgen.el \
yatexenv.el yatexlib.el \
yatexmth.el yatexhks.el yatexhlp.el yatexprc.el \
@@ -84,28 +97,7 @@ EL_FILES= comment.el yatex.el yatexadd.el yatexgen.el \
yatex19.el
do-build:
- for file in yatex-startup.el INSTALL DEINSTALL MESSAGE; do \
- ${SED} -e 's,%%TARGETNAME%%,${TARGETNAME},g' \
- -e 's,%%VERSION%%,${VERSION},g' \
- -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%BASENAME%%,${BASENAME},g' \
- -e 's,%%CAT%%,${CAT},g' \
- -e 's,%%CP%%,${CP},g' \
- -e 's,%%ECHO%%,${ECHO_CMD},g' \
- -e 's,%%GREP%%,${GREP},g' \
- -e 's,%%RM%%,${RM},g' \
- -e 's,%%SED%%,${SED},g' \
- -e 's,%%TOUCH%%,${TOUCH},g' \
- -e 's,%%DO_NADA%%,${DO_NADA},g' \
- -e 's,%%INFODIR%%,${INFODIR},g' \
- -e 's,%%ELISPDIR%%,${ELISPDIR},g' \
- -e 's,%%INFOFILES%%,${INFOFILES},g' \
- -e 's,%%INFONODES%%,${INFONODES},g' \
- -e 's,%%INFONODEEXPS%%,${INFONODEEXPS},g' \
- -e 's,%%DIRSECTION%%,${DIRSECTION},g' \
- -e 's,%%EMACS_NAME%%,${EMACS_NAME},g' \
- < ${FILESDIR}/$${file}.tmpl > ${WRKDIR}/$${file}; \
- done
+ @${DO_NADA}
# For XEmacs, yatexj (a Japanese info file) should be remade.
.if (${EMACS_PORT_NAME} == xemacs21-mule)
(cd ${WRKSRC}/docs; \
@@ -115,26 +107,24 @@ do-build:
.endif
do-install:
- cd ${WRKSRC}; \
- ${MKDIR} ${ELISPDIR}/yatex; \
- ${MKDIR} ${HELPDIR} ${INFODIR}; \
- ${INSTALL_DATA} ${EL_FILES} ${ELISPDIR}/yatex; \
- ${INSTALL_DATA} ${HELP} ${HELPDIR}; \
+ ${MKDIR} ${ELISPDIR}/yatex
+ ${MKDIR} ${HELPDIR} ${INFODIR}
${MKDIR} ${INFODIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${EL_FILES} ${ELISPDIR}/yatex && \
+ ${INSTALL_DATA} ${HELP} ${HELPDIR}
.if (${EMACS_PORT_NAME} == xemacs21) || (${EMACS_PORT_NAME} == xemacs21-mule)
- cd ${WRKSRC}; \
- for file in `${ECHO_CMD} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
- ${INSTALL_DATA} ${WRKSRC}/docs/$${file} ${INFODIR}/$${file}.info; \
+ for F in ${INFOFILES:S,:, ,g}; do \
+ ${INSTALL_DATA} ${WRKSRC}/docs/$${F} ${INFODIR}/$${F}.info; \
done
.else
- cd ${WRKSRC}; \
- for file in `${ECHO_CMD} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
- ${INSTALL_DATA} ${WRKSRC}/docs/$${file} ${INFODIR}; \
- done
+ cd ${WRKSRC}/docs && \
+ ${INSTALL_DATA} ${INFOFILES:S,:, ,g} ${INFODIR}
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PORTSDOCDIR}
- cd ${WRKSRC}; ${INSTALL_DATA} ${DOCS} ${DOCSRC} ${PORTSDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${WRKSRC}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
post-install:
@@ -143,7 +133,6 @@ post-install:
INFOFILES="${INFOFILES}" \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${INSTALL_DATA} ${WRKDIR}/yatex-startup.el ${ELISPDIR}
- @${CAT} ${PKGMESSAGE}
.if (${EMACS_PORT_NAME} == xemacs21) || (${EMACS_PORT_NAME} == xemacs21-mule)
${RM} -f ${WRKDIR}/${MANIFEST}
${CAT} ${PLIST} | ${GREP} -e "^${EMACS_LIBDIR}" | \
@@ -152,5 +141,6 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${MANIFEST} \
${PREFIX}/${EMACS_LIBDIR}/site-packages/pkginfo/
.endif
+ @${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/print/yatex/files/MESSAGE.tmpl b/print/yatex/files/MESSAGE.tmpl
deleted file mode 100644
index 38e568bcc3d9..000000000000
--- a/print/yatex/files/MESSAGE.tmpl
+++ /dev/null
@@ -1,12 +0,0 @@
-######################################################################
-To use YaTeX, add the next line into your .emacs;
-
- (require 'yatex-startup)
-
-where yatex-startup.el is in %%ELISPDIR%%.
-Please check the setup file because it has a lot of examples.
-To get more information, see the info file of YaTeX;
-
-Installation::
-Customizations => Lisp variables::
-######################################################################
diff --git a/print/yatex/files/DEINSTALL.tmpl b/print/yatex/files/pkg-deinstall.in
index a5fb17959c23..274fa86f185f 100644
--- a/print/yatex/files/DEINSTALL.tmpl
+++ b/print/yatex/files/pkg-deinstall.in
@@ -1,4 +1,5 @@
#!/bin/sh
+# $FreeBSD$
pkgname=$1
diff --git a/print/yatex/files/INSTALL.tmpl b/print/yatex/files/pkg-install.in
index 1a7b39c38195..db93039678c3 100644
--- a/print/yatex/files/INSTALL.tmpl
+++ b/print/yatex/files/pkg-install.in
@@ -1,4 +1,5 @@
#!/bin/sh
+# $FreeBSD$
pkgname=$1
diff --git a/print/yatex/files/pkg-message.in b/print/yatex/files/pkg-message.in
new file mode 100644
index 000000000000..239f1ad754df
--- /dev/null
+++ b/print/yatex/files/pkg-message.in
@@ -0,0 +1,10 @@
+To use YaTeX, add the next line into your .emacs:
+
+ (require 'yatex-startup)
+
+where yatex-startup.el is in %%ELISPDIR%%. Please check the setup
+file because it has a lot of examples. To get more information, see
+the info file of YaTeX:
+
+Installation::
+Customizations => Lisp variables::
diff --git a/print/yatex/files/yatex-startup.el.tmpl b/print/yatex/files/yatex-startup.el.in
index 0495a1ddae28..6aee4a066d3f 100644
--- a/print/yatex/files/yatex-startup.el.tmpl
+++ b/print/yatex/files/yatex-startup.el.in
@@ -1,5 +1,6 @@
;; a startup elisp for YaTeX
;; -- S. Taoka <taoka@FreeBSD.org>
+;; $FreeBSD$
;;;;;;;;;;; %%TARGETNAME%% (Ver.%%VERSION%%) ;;;;;;;;;;;
diff --git a/print/yatex/pkg-descr b/print/yatex/pkg-descr
index 160e6e0ea209..b97efa98b46e 100644
--- a/print/yatex/pkg-descr
+++ b/print/yatex/pkg-descr
@@ -1,24 +1,10 @@
-[[About YaTeX]]
YaTeX automates typesetting and previewing of LaTeX and enables
completing input of LaTeX mark-up command such as `\begin{}'..`\end{}'.
-
YaTeX also supports Demacs which runs on MS-DOS(386), Mule (Multi
Language Enhancement to GNU Emacs), and latex on DOS.
-To use YaTeX, add the next line into your ~/.emacs;
-
-(require 'yatex-startup)
-
-To get more setup information, see the info file of YaTeX;
-Installation::
-Customizations => Lisp variables::
-
-[[About yahtml]]
Yahtml is a brand new package for writing HTML files with Emacs. It is
very far from html-mode, html-helper-mode or other existing HTML modes.
It is a good successor of YaTeX in HTML world.
-- S. Taoka
-taoka@FreeBSD.org
-
WWW: http://www.yatex.org/
diff --git a/print/yatex/pkg-plist.emacs b/print/yatex/pkg-plist.emacs
index 4365328ff06d..f9f87cf93a9a 100644
--- a/print/yatex/pkg-plist.emacs
+++ b/print/yatex/pkg-plist.emacs
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
share/emacs/site-lisp/yatex/comment.el
share/emacs/site-lisp/yatex/yahtml.el
share/emacs/site-lisp/yatex/yatex.el
@@ -21,20 +22,4 @@ info/yahtmle
info/yahtmlj
info/yatexe
info/yatexj
-share/doc/yatex/00readme
-share/doc/yatex/htmlqa
-share/doc/yatex/htmlqa.eng
-share/doc/yatex/qanda
-share/doc/yatex/qanda.eng
-share/doc/yatex/readme.meadow.j
-share/doc/yatex/yahtmle.tex
-share/doc/yatex/yahtmlj.tex
-share/doc/yatex/yatex.new
-share/doc/yatex/yatex.ref
-share/doc/yatex/yatexadd.doc
-share/doc/yatex/yatexe.tex
-share/doc/yatex/yatexgen.doc
-share/doc/yatex/yatexj.tex
-share/doc/yatex/yatexref.eng
@dirrm share/emacs/site-lisp/yatex
-@dirrm share/doc/yatex
diff --git a/print/yatex/pkg-plist.mule b/print/yatex/pkg-plist.mule
deleted file mode 100644
index 752eeba7fd19..000000000000
--- a/print/yatex/pkg-plist.mule
+++ /dev/null
@@ -1,42 +0,0 @@
-share/mule/site-lisp/yatex/comment.el
-share/mule/site-lisp/yatex/yahtml.el
-share/mule/site-lisp/yatex/yatex.el
-share/mule/site-lisp/yatex/yatex19.el
-share/mule/site-lisp/yatex/yatexadd.el
-share/mule/site-lisp/yatex/yatexenv.el
-share/mule/site-lisp/yatex/yatexgen.el
-share/mule/site-lisp/yatex/yatexhie.el
-share/mule/site-lisp/yatex/yatexhks.el
-share/mule/site-lisp/yatex/yatexhlp.el
-share/mule/site-lisp/yatex/yatexlib.el
-share/mule/site-lisp/yatex/yatexm-o.el
-share/mule/site-lisp/yatex/yatexmth.el
-share/mule/site-lisp/yatex/yatexprc.el
-share/mule/site-lisp/yatex/yatexsec.el
-share/mule/site-lisp/yatex/yatexpkg.el
-share/mule/site-lisp/yatex-startup.el
-share/mule/site-lisp/YATEXHLP.jp
-share/mule/site-lisp/YATEXHLP.eng
-info/yahtmle
-info/yahtmlj
-info/yatexe
-info/yatexj
-share/doc/yatex/00readme
-share/doc/yatex/htmlqa
-share/doc/yatex/htmlqa.eng
-share/doc/yatex/qanda
-share/doc/yatex/qanda.eng
-share/doc/yatex/readme.meadow.j
-share/doc/yatex/yahtmle.tex
-share/doc/yatex/yahtmlj.tex
-share/doc/yatex/yatex.new
-share/doc/yatex/yatex.ref
-share/doc/yatex/yatexadd.doc
-share/doc/yatex/yatexe.tex
-share/doc/yatex/yatexgen.doc
-share/doc/yatex/yatexj.tex
-share/doc/yatex/yatexref.eng
-@dirrm share/mule/site-lisp/yatex
-@dirrmtry share/mule/site-lisp
-@dirrmtry share/mule
-@dirrm share/doc/yatex
diff --git a/print/yatex/pkg-plist.xemacs b/print/yatex/pkg-plist.xemacs
index cb4cdd2684df..63e4f415f7d4 100644
--- a/print/yatex/pkg-plist.xemacs
+++ b/print/yatex/pkg-plist.xemacs
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
lib/xemacs/site-packages/lisp/yatex/comment.el
lib/xemacs/site-packages/lisp/yatex/yahtml.el
lib/xemacs/site-packages/lisp/yatex/yatex.el
@@ -19,11 +20,6 @@ lib/xemacs/site-packages/pkginfo/MANIFEST.yatex
lib/xemacs/site-packages/info/yahtmle.info
lib/xemacs/site-packages/info/yatexe.info
lib/xemacs/site-lisp/YATEXHLP.eng
-share/doc/yatex/htmlqa.eng
-share/doc/yatex/qanda.eng
-share/doc/yatex/yahtmle.tex
-share/doc/yatex/yatexe.tex
-share/doc/yatex/yatexref.eng
@dirrm lib/xemacs/site-packages/lisp/yatex
@dirrmtry lib/xemacs/site-lisp
@dirrmtry lib/xemacs/site-packages/lisp
@@ -31,4 +27,3 @@ share/doc/yatex/yatexref.eng
@dirrmtry lib/xemacs/site-packages/pkginfo
@dirrmtry lib/xemacs/site-packages
@dirrmtry lib/xemacs
-@dirrm share/doc/yatex
diff --git a/print/yatex/pkg-plist.xemacs-mule b/print/yatex/pkg-plist.xemacs-mule
index e052b6b406df..824947bcf7bd 100644
--- a/print/yatex/pkg-plist.xemacs-mule
+++ b/print/yatex/pkg-plist.xemacs-mule
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
lib/xemacs/site-packages/lisp/yatex/comment.el
lib/xemacs/site-packages/lisp/yatex/yahtml.el
lib/xemacs/site-packages/lisp/yatex/yatex.el