aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-06-25 14:39:22 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-06-25 14:39:22 +0000
commita85854b8a7a697f7f24f8451824cfcdedc1c8dde (patch)
tree650d274367101347f2b350959a3a0d257b04d054 /print
parentdb2c514e2c1b4edf76803952066e594d973966fe (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/pecl-panda/Makefile34
-rw-r--r--print/pecl-panda/distinfo2
-rw-r--r--print/pecl-panda/files/patch-config.m410
-rw-r--r--print/pecl-panda/pkg-descr6
-rw-r--r--print/pecl-panda/pkg-message8
-rw-r--r--print/pecl-panda/pkg-plist2
7 files changed, 63 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 4b431a70a2cd..16d3eeaf634c 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -160,6 +160,7 @@
SUBDIR += pdflib-perl
SUBDIR += pdftk
SUBDIR += pdq
+ SUBDIR += pecl-panda
SUBDIR += pecl-pdflib
SUBDIR += perlftlib
SUBDIR += pfbtopfa
diff --git a/print/pecl-panda/Makefile b/print/pecl-panda/Makefile
new file mode 100644
index 000000000000..4fa03b137d00
--- /dev/null
+++ b/print/pecl-panda/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pecl-panda
+# Date created: 25 Jun 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= panda
+PORTVERSION= 0.1.0
+CATEGORIES= print pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension to create PDF documents
+
+LIB_DEPENDS= panda.0:${PORTSDIR}/print/panda
+
+USE_PHP= yes
+USE_PHPIZE= yes
+
+CONFIGURE_ARGS= --with-panda=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/modules/panda.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/pecl-panda/distinfo b/print/pecl-panda/distinfo
new file mode 100644
index 000000000000..055358af57a0
--- /dev/null
+++ b/print/pecl-panda/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/panda-0.1.0.tgz) = a445526024946f67bd510330f9bbcf2a
+SIZE (PECL/panda-0.1.0.tgz) = 12435
diff --git a/print/pecl-panda/files/patch-config.m4 b/print/pecl-panda/files/patch-config.m4
new file mode 100644
index 000000000000..6075793b97a9
--- /dev/null
+++ b/print/pecl-panda/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig Fri Jun 25 16:26:35 2004
++++ config.m4 Fri Jun 25 16:27:13 2004
+@@ -30,6 +30,7 @@
+ PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
+ [
+ PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $PANDA_DIR/lib, PANDA_SHARED_LIBADD)
++ PHP_ADD_INCLUDE($PANDA_DIR/include)
+ AC_DEFINE(HAVE_PANDALIB,1,[ ])
+ ],[
+ AC_MSG_ERROR([wrong panda lib version or lib not found])
diff --git a/print/pecl-panda/pkg-descr b/print/pecl-panda/pkg-descr
new file mode 100644
index 000000000000..fb2d13afc555
--- /dev/null
+++ b/print/pecl-panda/pkg-descr
@@ -0,0 +1,6 @@
+Panda is a free PDF library that can be used to create PDF documents.
+
+WWW: http://pecl.php.net/package/panda/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/print/pecl-panda/pkg-message b/print/pecl-panda/pkg-message
new file mode 100644
index 000000000000..e531d3bdf0b2
--- /dev/null
+++ b/print/pecl-panda/pkg-message
@@ -0,0 +1,8 @@
+*****************************************************************************
+
+To automatically load the installed extension add the following line to
+your php.ini configuration file:
+
+extension="panda.so"
+
+*****************************************************************************
diff --git a/print/pecl-panda/pkg-plist b/print/pecl-panda/pkg-plist
new file mode 100644
index 000000000000..57f7243c6695
--- /dev/null
+++ b/print/pecl-panda/pkg-plist
@@ -0,0 +1,2 @@
+lib/php/%%PHP_EXT_DIR%%/panda.so
+@unexec rmdir %D/lib/php/%%PHP_EXT_DIR%% 2> /dev/null || true