aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-05-22 15:24:59 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-05-22 15:24:59 +0000
commitb2142a500a18ff57cda6b26c27f0b91e0b9bb808 (patch)
treeb8ed0fd39cc9284d41e885cf824c67f1da4003f9 /print
parentfae853b154ab0dbbcc8e76bc8345ffadc0b86f9c (diff)
Add a patch for cjk unicode.
PR: ports/97559 Submitted by: Aho K.F. Li <thinker@branda.dot.to>
Notes
Notes: svn path=/head/; revision=163101
Diffstat (limited to 'print')
-rw-r--r--print/py-freetype/Makefile1
-rw-r--r--print/py-freetype/files/patch-freetype_wrap.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/print/py-freetype/Makefile b/print/py-freetype/Makefile
index 9e75de356f11..20608c2c7127 100644
--- a/print/py-freetype/Makefile
+++ b/print/py-freetype/Makefile
@@ -7,6 +7,7 @@
PORTNAME= py-freetype
PORTVERSION= 0.65
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= http://starship.python.net/crew/kernr/source/
DISTNAME= PyFT-${PORTVERSION}
diff --git a/print/py-freetype/files/patch-freetype_wrap.c b/print/py-freetype/files/patch-freetype_wrap.c
new file mode 100644
index 000000000000..e7ad40d990f9
--- /dev/null
+++ b/print/py-freetype/files/patch-freetype_wrap.c
@@ -0,0 +1,11 @@
+--- freetype_wrap.c.orig Mon May 22 23:21:55 2006
++++ freetype_wrap.c Mon May 22 23:22:11 2006
+@@ -3410,7 +3410,7 @@
+ PyObject * _argo0 = 0;
+
+ self = self;
+- if(!PyArg_ParseTuple(args,"Oh:TT_Char_Index",&_argo0,&_arg1))
++ if(!PyArg_ParseTuple(args,"OH:TT_Char_Index",&_argo0,&_arg1))
+ return NULL;
+ if (_argo0) {
+ if (_argo0 == Py_None) { _arg0 = NULL; }