aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /print
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/ggv/Makefile8
-rw-r--r--print/ggv/files/patch-src_Makefile.in11
-rw-r--r--print/ggv/pkg-plist1
-rw-r--r--print/gnome-cups-manager/Makefile5
-rw-r--r--print/photoprint/Makefile17
-rw-r--r--print/xfce4-print/Makefile9
6 files changed, 22 insertions, 29 deletions
diff --git a/print/ggv/Makefile b/print/ggv/Makefile
index cf92590fe7e4..5a519bd39985 100644
--- a/print/ggv/Makefile
+++ b/print/ggv/Makefile
@@ -14,13 +14,17 @@ COMMENT= GNOME 2 ghostscript viewer
INSTALLS_OMF= yes
USE_GNOME= gnomeprefix intlhack libgnomeui
-USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:bzip2
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ tar:bzip2
USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lm
INSTALL_TARGET= install-strip
GCONF_SCHEMAS= ggv.schemas
+post-patch:
+ @${REINPLACE_CMD} '/^LIBS =/s/=.*/= @LIBS@/' ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>
diff --git a/print/ggv/files/patch-src_Makefile.in b/print/ggv/files/patch-src_Makefile.in
deleted file mode 100644
index 76847cf3e9b2..000000000000
--- a/print/ggv/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Sun Dec 5 18:19:25 2004
-+++ src/Makefile.in Sun Dec 5 18:20:13 2004
-@@ -142,7 +142,7 @@
-
- SUBDIRS = recent-files stock cursors
-
--INCLUDES = -I$(top_srcdir)/recent-files -DG_LOG_DOMAIN=\"GGV\" -DGNOMELOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" -DGNOMEICONDIR=\""${prefix}/${DATADIRNAME}/pixmaps"\" -DDATADIR=\""$(datadir)"\" $(GGV_CFLAGS) $(GGV_DEPRECATED_CFLAGS)
-+INCLUDES = -I$(top_srcdir)/recent-files -DG_LOG_DOMAIN=\"GGV\" -DGNOMELOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" -DGNOMEICONDIR=\""${datadir}/pixmaps"\" -DDATADIR=\""$(datadir)"\" $(GGV_CFLAGS) $(GGV_DEPRECATED_CFLAGS)
-
-
- bin_PROGRAMS = ggv
diff --git a/print/ggv/pkg-plist b/print/ggv/pkg-plist
index de58dd02a8d7..3d3fe17ede2d 100644
--- a/print/ggv/pkg-plist
+++ b/print/ggv/pkg-plist
@@ -148,7 +148,6 @@ share/locale/zh_TW/LC_MESSAGES/ggv.mo
@dirrm share/gnome/help/ggv/C/figures
@dirrm share/gnome/help/ggv/C
@dirrm share/gnome/help/ggv
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
@dirrmtry share/locale/rw/LC_MESSAGES
diff --git a/print/gnome-cups-manager/Makefile b/print/gnome-cups-manager/Makefile
index c5cd794f488d..7145e7f231fc 100644
--- a/print/gnome-cups-manager/Makefile
+++ b/print/gnome-cups-manager/Makefile
@@ -19,11 +19,12 @@ RUN_DEPENDS= gnomesu:${PORTSDIR}/security/libgnomesu
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix intlhack libgnomeprintui libgnomeui
USE_LDCONFIG= yes
+USE_XORG= x11
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D_IPP_PRIVATE_STRUCTURES
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
post-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|' \
@@ -31,6 +32,8 @@ post-patch:
> ${WRKSRC}/gnome-cups-manager.desktop
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-D.*_DISABLE_DEPRECATED||g'
+ @${REINPLACE_CMD} '/^gnome_cups_icon_LDADD =/s/$$/ -lX11/' \
+ ${WRKSRC}/gnome-cups-manager/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/libgnomecups/gnome-cups-ui-driver.c
@${REINPLACE_CMD} -e 's|glib/gmacros.h>|glib.h>|g' \
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index 39657ad6b5cc..2462ac35f663 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -12,24 +12,21 @@ COMMENT= Utility to print multiple images per sheet
LICENSE= GPLv2
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libgdk_pixbuf-2.0.so:${PORTSDIR}/graphics/gdk-pixbuf2 \
libgutenprint.so:${PORTSDIR}/print/gutenprint \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
liblcms.so:${PORTSDIR}/graphics/lcms \
libnetpbm.so:${PORTSDIR}/graphics/netpbm \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libpng15.so:${PORTSDIR}/graphics/png \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext pkgconfig
-USE_GNOME= pango
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
- xfixes xi xinerama xrandr xrender
+USES= desktop-file-utils gettext libtool pkgconfig
+USE_GNOME= gdkpixbuf2 gtk20
+USE_XORG= x11
INSTALLS_ICONS= yes
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lX11
post-patch:
@${REINPLACE_CMD} -e 's|glib/gstrfuncs.h|glib.h|g' \
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index 4a00f9378e18..061999e84b0d 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -32,7 +32,7 @@ OPTIONS_SINGLE_PRINTMETHOD= LPR CUPS
LETTER_DESC= Use letter paper format instead of A4
LPR_DESC= LPR printing system support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+=--enable-cups
@@ -58,7 +58,8 @@ CONFIGURE_ARGS+=--disable-letter
.endif
post-patch:
- @${REINPLACE_CMD} -e 's/@LDFLAGS@/& -Wl,-E/' ${WRKSRC}/xfprint/Makefile.in \
- ${WRKSRC}/xfprint-manager/Makefile.in
+ @${REINPLACE_CMD} '/_LDADD =/s/=/= -lX11/' \
+ ${WRKSRC}/xfprint/Makefile.in \
+ ${WRKSRC}/xfprint-manager/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>