aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /print
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/libgnomeprint/Makefile24
-rw-r--r--print/libgnomeprint/distinfo4
-rw-r--r--print/libgnomeprint/pkg-plist26
3 files changed, 40 insertions, 14 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 2cc5717e6710..a7f58f3a5c9b 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -3,14 +3,14 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/print/libgnomeprint/Makefile,v 1.54 2005/09/26 21:07:03 marcus Exp $
#
PORTNAME= libgnomeprint
-PORTVERSION= 2.10.3
-PORTREVISION= 1
+PORTVERSION= 2.12.1
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,14 +19,15 @@ COMMENT= Gnome print support library
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
popt.0:${PORTSDIR}/devel/popt
+USE_BISON= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier glib20 pango libxml2 \
- libartlgpl2
+ libartlgpl2 ltverhack
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -35,11 +36,7 @@ PLIST_SUB= VERSION=${PORTVERSION} \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libcups.so)
-WITH_CUPS= yes
-.endif
-
-.if defined(WITH_CUPS) && !defined(WITHOUT_CUPS)
+.if defined(WITH_CUPS) || exists(${LOCALBASE}/lib/libcups.so)
CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= gnomecups-1.0:${PORTSDIR}/print/libgnomecups
PLIST_SUB+= CUPS:=""
@@ -48,6 +45,13 @@ CONFIGURE_ARGS+= --without-cups
PLIST_SUB+= CUPS:="@comment "
.endif
+pre-everything::
+.if !defined(WITH_CUPS)
+ @${ECHO_MSG} " Enable cups support by defining"
+ @${ECHO_MSG} " WITH_CUPS"
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc[.]h>|<stdlib.h>|'
diff --git a/print/libgnomeprint/distinfo b/print/libgnomeprint/distinfo
index 8d58d7c70ad5..0bd143323a41 100644
--- a/print/libgnomeprint/distinfo
+++ b/print/libgnomeprint/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libgnomeprint-2.10.3.tar.bz2) = 9052dc919ad038b1a9e4d5301148588e
-SIZE (gnome2/libgnomeprint-2.10.3.tar.bz2) = 727745
+MD5 (gnome2/libgnomeprint-2.12.1.tar.bz2) = ea729d4968fe2169c84efb12ace5f6cc
+SIZE (gnome2/libgnomeprint-2.12.1.tar.bz2) = 787980
diff --git a/print/libgnomeprint/pkg-plist b/print/libgnomeprint/pkg-plist
index bc5a6fc5e733..783bea79666b 100644
--- a/print/libgnomeprint/pkg-plist
+++ b/print/libgnomeprint/pkg-plist
@@ -2,11 +2,12 @@ etc/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-font-face.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-font.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-glyphlist.h
-include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-pango.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-pgl.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-config.h
+include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-filter.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-job.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-meta.h
+include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-pango.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-paper.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-transport.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/gnome-print-unit.h
@@ -18,6 +19,7 @@ include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-font-private.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-fontmap.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-glyphlist-private.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-print-config-private.h
+include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-print-path.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gnome-print-private.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gp-gc-private.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gpa-config.h
@@ -35,8 +37,17 @@ include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gpa-state.h
include/libgnomeprint-%%LIBVERSION%%/libgnomeprint/private/gpa-utils.h
lib/libgnomeprint-2-2.a
lib/libgnomeprint-2-2.so
-lib/libgnomeprint-2-2.so.1
+lib/libgnomeprint-2-2.so.0
%%CUPS:%%lib/libgnomeprint/%%VERSION%%/modules/libgnomeprintcups.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-clip.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-draft.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-frgba.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-multipage.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-position.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-reorder.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-rotate.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-select.so
+lib/libgnomeprint/%%VERSION%%/modules/filters/libgnomeprint-zoom.so
lib/libgnomeprint/%%VERSION%%/modules/libgnomeprintlpd.so
lib/libgnomeprint/%%VERSION%%/modules/transports/libgnomeprint-custom.so
lib/libgnomeprint/%%VERSION%%/modules/transports/libgnomeprint-file.so
@@ -95,6 +106,7 @@ share/locale/fa/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/fi/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/fr/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ga/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/gl/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/gu/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/he/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/hi/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@@ -123,6 +135,7 @@ share/locale/pt/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/pt_BR/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ro/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ru/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/rw/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/sk/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/sl/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/sq/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@@ -130,13 +143,21 @@ share/locale/sr/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/sr@Latn/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/sv/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ta/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/te/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/th/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/tr/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/uk/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/vi/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/wa/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/xh/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/zh_CN/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/zh_TW/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+@unexec rmdir %D/share/locale/xh/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/xh 2>/dev/null || true
+@unexec rmdir %D/share/locale/te/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/te 2>/dev/null || true
+@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/rw 2>/dev/null || true
@unexec rmdir %D/share/locale/mr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/mr 2>/dev/null || true
@dirrm share/gnome/libgnomeprint/%%VERSION%%/printers/uninstalled
@@ -147,6 +168,7 @@ share/locale/zh_TW/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@dirrm share/gnome/libgnomeprint
@dirrm %%DOCSDIR%%
@dirrm lib/libgnomeprint/%%VERSION%%/modules/transports
+@dirrm lib/libgnomeprint/%%VERSION%%/modules/filters
@dirrm lib/libgnomeprint/%%VERSION%%/modules
@dirrm lib/libgnomeprint/%%VERSION%%
@dirrm lib/libgnomeprint