aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-03 07:51:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-03 07:51:44 +0000
commit62bec1549491479e163ad4121f803d7a286ddacc (patch)
tree12476cadd33c2cb0e7d88811891a757bd5d298f6 /print
parentc107f9dc8e8e6b108dfbad1df0e1f36ef75639b2 (diff)
downloadports-62bec1549491479e163ad4121f803d7a286ddacc.tar.gz
ports-62bec1549491479e163ad4121f803d7a286ddacc.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/pdftk/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index e1c92a189bc1..7f8a44ef6191 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -18,17 +18,13 @@ COMMENT= A simple tool for doing everyday things with PDF documents
# gcj/libgcj don't exist on these platforms
NOT_FOR_ARCHS= amd64 ia64 sparc64
-BROKEN= "Broken dependency"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
# Get gcc version suffix without the dot in USE_GCC
CSUFF= ${USE_GCC:S/.//}
# needs gcj
BUILD_DEPENDS= gcj${CSUFF}:${PORTSDIR}/lang/gcc${CSUFF}
-USE_GCC= 3.4
+USE_GCC= 4.1
USE_GMAKE= yes
USE_ICONV= yes
USE_REINPLACE= yes
@@ -44,7 +40,22 @@ PLIST_FILES= bin/pdftk
post-extract:
@${REINPLACE_CMD} -e "s|TOOLPATH=|TOOLPATH=${LOCALBASE}/bin/|g" ${WRKSRC}/Makefile.Generic
@${REINPLACE_CMD} -e "s|VERSUFF=|VERSUFF=${CSUFF}|g" ${WRKSRC}/Makefile.Generic
- @${REINPLACE_CMD} -e "s|CXXFLAGS= -lgcj|CXXFLAGS= -lgcj ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -liconv -lz|g" ${WRKSRC}/Makefile.Generic
+
+#2005-10-29 - mjoyner@vbservices.net/mjoyner@ewc.edu
+#as shipped, pdftk compiles fine with 3.4 gcj, as we currently only have 4.1 gcj available,
+#fix things so that it will compile. (compile tested on 5.4-STABLE)
+#
+#The resulting binary from using the 4.1 compiler suite has *NOT* been regression tested!
+#Based on info found via Google USENET Search: Adam McDougall, Gerald Pfeifer
+#
+
+ @${REINPLACE_CMD} -e "s|GCJFLAGS=|GCJFLAGS= -L${LOCALBASE}/lib|g" ${WRKSRC}/Makefile.Generic
+ @${REINPLACE_CMD} -e "s|CXXFLAGS= -lgcj|CXXFLAGS= -lgcj ${PTHREAD_CFLAGS} ${PTHREAD_LIBS} -liconv -lz -L${LOCALBASE}/lib|g" \
+ ${WRKSRC}/Makefile.Generic
+ @${REINPLACE_CMD} -e "s|//SID import com.lowagie.text.ImgRaw;|import com.lowagie.text.ImgRaw;|g" \
+ ${WRKSRC}/../java_libs/com/lowagie/text/pdf/codec/PngImage.java
+ @${REINPLACE_CMD} -e "s|^..java_libs_root./gnu/gcj/convert/convert.a|# x-nay the convert.a|g" ${WRKSRC}/Makefile.Base
+ @${REINPLACE_CMD} -e "s|^..java_libs_root./gnu_local/java/security/security.a .|$$\(java_libs_root\)/gnu_local/java/security/security.a|g" ${WRKSRC}/Makefile.Base
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin