aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:22:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:22:42 +0000
commite8a23cc114acb95ebd13b4992c989e292d6169a5 (patch)
treea9201b25e842c21d19dfb3d4f41e9e18cd13a99b /print
parentee82650afa54c8bf01c3e28496093aefa74def57 (diff)
downloadports-e8a23cc114acb95ebd13b4992c989e292d6169a5.tar.gz
ports-e8a23cc114acb95ebd13b4992c989e292d6169a5.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-csquotes/Makefile67
-rw-r--r--print/latex-csquotes/distinfo3
-rw-r--r--print/latex-csquotes/pkg-descr3
4 files changed, 74 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index be4800ac57f3..8a230e815137 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -144,6 +144,7 @@
SUBDIR += latex-caption
SUBDIR += latex-circ
SUBDIR += latex-cjk
+ SUBDIR += latex-csquotes
SUBDIR += latex-etoolbox
SUBDIR += latex-feynmf
SUBDIR += latex-keystroke
diff --git a/print/latex-csquotes/Makefile b/print/latex-csquotes/Makefile
new file mode 100644
index 000000000000..a3ddfdb74266
--- /dev/null
+++ b/print/latex-csquotes/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: latex-csquotes
+# Date created: 31 Aug 2008
+# Whom: vj562001@yahoo.de
+#
+# $FreeBSD$
+
+PORTNAME= csquotes
+PORTVERSION= 4.2
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib
+PKGNAMEPREFIX= latex-
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= vj562001@yahoo.de
+COMMENT= Context sensitive quotation facilities
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal \
+ ${LOCALBASE}/${TEXMFLOCAL}/tex/latex/etoolbox/etoolbox.sty:${PORTSDIR}/print/latex-etoolbox
+
+USE_ZIP= YES
+NO_BUILD= YES
+PLIST= ${WRKDIR}/pkg-plist
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/latex
+
+CLASSNAME= ${PORTNAME}
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${CLASSNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+CLASS_FILES= csquotes.sty csquotes.def csquotes.cfg
+DOC_FILES= LICENSE README csquotes.pdf tutorial.tex
+
+WRKSRC= ${WRKDIR}/${CLASSNAME}
+
+pre-install:
+ (for F in ${CLASS_FILES}; do \
+ ${ECHO_CMD} "${CLASSDIR}/$${F}"; \
+ done;) > ${PLIST}
+ ${ECHO_CMD} "@dirrm ${CLASSDIR}" >> ${PLIST}
+.if !defined(NOPORTDOCS)
+ (for F in ${DOC_FILES}; do \
+ ${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" ) >> ${PLIST}
+.endif
+ ${ECHO_CMD} "@exec ${MKTEXLSR}" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${MKTEXLSR}" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-csquotes/distinfo b/print/latex-csquotes/distinfo
new file mode 100644
index 000000000000..67ae81d70739
--- /dev/null
+++ b/print/latex-csquotes/distinfo
@@ -0,0 +1,3 @@
+MD5 (csquotes.zip) = e4a9c29218210f003d23d789776d360d
+SHA256 (csquotes.zip) = b563ed0753ba55cda10558fd5320fd2224ecf57f78e84fc042584907fbeecaef
+SIZE (csquotes.zip) = 281505
diff --git a/print/latex-csquotes/pkg-descr b/print/latex-csquotes/pkg-descr
new file mode 100644
index 000000000000..093e074d049f
--- /dev/null
+++ b/print/latex-csquotes/pkg-descr
@@ -0,0 +1,3 @@
+A LaTeX package, which provides facilities for inline and display quotations.
+
+WWW: http://www.ctan.org/tex-archive/help/Catalogue/entries/csquotes.html