aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /print
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/acroread/Makefile14
-rw-r--r--print/acroread7/Makefile11
-rw-r--r--print/bjfiltercom/Makefile6
3 files changed, 16 insertions, 15 deletions
diff --git a/print/acroread/Makefile b/print/acroread/Makefile
index d715e2560ff7..0cd5439b1e6c 100644
--- a/print/acroread/Makefile
+++ b/print/acroread/Makefile
@@ -7,12 +7,11 @@
PORTNAME= acroread
PORTVERSION= 5.10
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= print linux
MASTER_SITES= http://download.adobe.com/pub/adobe/acrobatreader/unix/5.x/ \
ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/5.x/
-.include <bsd.port.pre.mk>
DISTNAME= linux-5010
DIST_SUBDIR= acroread
RESTRICTED= "Must fill out redistribution form at http://www.adobe.com/products/acrobat/distribute.html"
@@ -20,19 +19,20 @@ RESTRICTED= "Must fill out redistribution form at http://www.adobe.com/products/
MAINTAINER= trevor@FreeBSD.org
COMMENT= View, distribute and print PDF documents
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
CONFLICTS= acroread7
ONLY_FOR_ARCHS= amd64 i386
USE_REINPLACE= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_BUILD= yes
-REINPLACE_ARGS= -i '' -E
-NO_FILTER_SHLIBS= yes
-
PLIST_SUB= "ARCHDIR=intellinux"
WRKSRC= ${WRKDIR}/installers
+.include <bsd.port.pre.mk>
+
+REINPLACE_ARGS= -i '' -E
+
do-install:
@${MKDIR} ${PREFIX}/Acrobat5
@ReadInstallDir=${PREFIX}/Acrobat5 ${WRKSRC}/INSTALL
diff --git a/print/acroread7/Makefile b/print/acroread7/Makefile
index 373069c45227..15a51dc0e059 100644
--- a/print/acroread7/Makefile
+++ b/print/acroread7/Makefile
@@ -21,20 +21,18 @@ COMMENT= View, distribute and print PDF documents
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango \
- ${LINUXBASE}/usr/X11R6/lib/libXext.so.6:${PORTSDIR}/x11/linux-XFree86-libs
+ ${LINUXBASE}/usr/lib/libpango-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango
CONFLICTS= acroread
ONLY_FOR_ARCHS= amd64 i386
USE_REINPLACE= yes
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_XLIB= yes # This should be USE_X_PREFIX, doesn't work yet.
NO_BUILD= yes
REINPLACE_ARGS= -i '' -E
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
PLIST= ${WRKDIR}/plist
-PREFIX= ${LINUXBASE}
+PREFIX?= ${LINUXBASE} # have a look at the USE_XLIB comment
pre-install:
@kldstat -v | ${GREP} -E 'linux(aout|elf)' >/dev/null ||\
@@ -57,6 +55,7 @@ do-install:
--nodeps --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} || ${TRUE}
# disable the PPKLite plugin as it requires an LDAP share lib
${CHMOD} 0 ${PREFIX}/usr/local/Adobe/Acrobat7.0/Reader/intellinux/plug_ins/PPKLite.api
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
post-install:
@${REINPLACE_CMD} 's:Linux:FreeBSD|Linux:g' \
diff --git a/print/bjfiltercom/Makefile b/print/bjfiltercom/Makefile
index d85be59ac1ee..b14a47207634 100644
--- a/print/bjfiltercom/Makefile
+++ b/print/bjfiltercom/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= bjfiltercom
PORTVERSION?= 1.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print linux
MASTER_SITES= ftp://download.canon.jp/pub/driver/bj/linux/
DISTFILES= ${RPMFILE}
@@ -43,7 +43,7 @@ PLIST= ${.CURDIR}/pkg-plist
DESCR= ${.CURDIR}/pkg-descr
MD5_FILE= ${.CURDIR}/distinfo
ONLY_FOR_ARCHS= i386
-NO_FILTER_SHLIBS= yes
+USE_LINUX= yes
NO_MTREE= yes
RPMREVISION= 1
.if defined(SLAVE_PORT)
@@ -76,6 +76,8 @@ do-build:
-e 's,%%PREFIX%%,${PREFIX},g' \
${FILESDIR}/setup > ${WRKDIR}/setup.freebsd
+# XXX: this is missing "${BRANDELF} -t Linux <executables>"
+
do-install:
${MKDIR} ${LINUXBASE}/usr/lib/bjlib
${INSTALL_DATA} ${WRKDIR}/usr/lib/bjlib/* ${LINUXBASE}/usr/lib/bjlib