aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-12-12 15:42:12 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-12-12 15:42:12 +0000
commit96286aa69dc09effa45e2ecaf0f539bced00a8c9 (patch)
tree282f4318b134bf39ae482512bf67ea0b47367a9b /print
parentb4a2be37168bf09f15ebc5b0fec74ddfe68476de (diff)
downloadports-96286aa69dc09effa45e2ecaf0f539bced00a8c9.tar.gz
ports-96286aa69dc09effa45e2ecaf0f539bced00a8c9.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-freetype/Makefile55
-rw-r--r--print/py-freetype/distinfo3
-rw-r--r--print/py-freetype/files/Makefile.pre.in304
-rw-r--r--print/py-freetype/files/patch-Setup.w3210
-rw-r--r--print/py-freetype/files/patch-freetype_wrap.c11
-rw-r--r--print/py-freetype/pkg-descr5
-rw-r--r--print/py-freetype/pkg-plist10
8 files changed, 0 insertions, 399 deletions
diff --git a/print/Makefile b/print/Makefile
index 27eab6685fcf..687d57b2be80 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -266,7 +266,6 @@
SUBDIR += psutils-letter
SUBDIR += pup
SUBDIR += py-fonttools
- SUBDIR += py-freetype
SUBDIR += py-pyscript
SUBDIR += py-reportlab
SUBDIR += py-rtf
diff --git a/print/py-freetype/Makefile b/print/py-freetype/Makefile
deleted file mode 100644
index 768f4d269296..000000000000
--- a/print/py-freetype/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: py-freetype
-# Date created: 3 February 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= py-freetype
-PORTVERSION= 0.65
-PORTREVISION= 1
-CATEGORIES= print python
-MASTER_SITES= http://starship.python.net/crew/kernr/source/
-DISTNAME= PyFT-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A Python wrapping of the FreeType 1.2 fonts rendering engine
-
-DEPRECATED= Project has disappeared and is no longer fetchable
-EXPIRATION_DATE=2006-12-09
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
-USE_FREETYPE= yes
-USE_PYTHON= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} >= 220
-MAKEFILE_PREIN= ${FILESDIR}/Makefile.pre.in
-.else
-MAKEFILE_PREIN= ${LOCALBASE}/lib/${PYTHON_VERSION}/config/Makefile.pre.in
-.endif
-
-pre-configure:
-.if ${PYTHON_REL} >= 230
- ${SED} -e 's,@DEFS@,,g' ${MAKEFILE_PREIN} > ${WRKSRC}/Makefile.pre.in
-.else
- ${LN} -sf ${MAKEFILE_PREIN} ${WRKSRC}/
-.endif
- ${LN} -sf ${WRKSRC}/Setup.w32 ${WRKSRC}/Setup.in
- ${RM} -f ${WRKSRC}/Setup
-
-do-configure:
- cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
-
-post-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
-
-post-install:
- cd ${WRKSRC} && \
- ${INSTALL_DATA} *.py *.pyc *.pyo \
- ${PREFIX}/lib/${PYTHON_VERSION}/site-packages
-
-.include <bsd.port.post.mk>
diff --git a/print/py-freetype/distinfo b/print/py-freetype/distinfo
deleted file mode 100644
index 3dd6671fef92..000000000000
--- a/print/py-freetype/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (PyFT-0.65.tar.gz) = 3f922a0370948b50d8dfd44866b01c70
-SHA256 (PyFT-0.65.tar.gz) = 74ea206104edbe4d65718abb7b25f434e94a54de827136cf89448543967b5a78
-SIZE (PyFT-0.65.tar.gz) = 109405
diff --git a/print/py-freetype/files/Makefile.pre.in b/print/py-freetype/files/Makefile.pre.in
deleted file mode 100644
index 2d14294054a0..000000000000
--- a/print/py-freetype/files/Makefile.pre.in
+++ /dev/null
@@ -1,304 +0,0 @@
-# Universal Unix Makefile for Python extensions
-# =============================================
-
-# Short Instructions
-# ------------------
-
-# 1. Build and install Python (1.5 or newer).
-# 2. "make -f Makefile.pre.in boot"
-# 3. "make"
-# You should now have a shared library.
-
-# Long Instructions
-# -----------------
-
-# Build *and install* the basic Python 1.5 distribution. See the
-# Python README for instructions. (This version of Makefile.pre.in
-# only withs with Python 1.5, alpha 3 or newer.)
-
-# Create a file Setup.in for your extension. This file follows the
-# format of the Modules/Setup.dist file; see the instructions there.
-# For a simple module called "spam" on file "spammodule.c", it can
-# contain a single line:
-# spam spammodule.c
-# You can build as many modules as you want in the same directory --
-# just have a separate line for each of them in the Setup.in file.
-
-# If you want to build your extension as a shared library, insert a
-# line containing just the string
-# *shared*
-# at the top of your Setup.in file.
-
-# Note that the build process copies Setup.in to Setup, and then works
-# with Setup. It doesn't overwrite Setup when Setup.in is changed, so
-# while you're in the process of debugging your Setup.in file, you may
-# want to edit Setup instead, and copy it back to Setup.in later.
-# (All this is done so you can distribute your extension easily and
-# someone else can select the modules they actually want to build by
-# commenting out lines in the Setup file, without editing the
-# original. Editing Setup is also used to specify nonstandard
-# locations for include or library files.)
-
-# Copy this file (Misc/Makefile.pre.in) to the directory containing
-# your extension.
-
-# Run "make -f Makefile.pre.in boot". This creates Makefile
-# (producing Makefile.pre and sedscript as intermediate files) and
-# config.c, incorporating the values for sys.prefix, sys.exec_prefix
-# and sys.version from the installed Python binary. For this to work,
-# the python binary must be on your path. If this fails, try
-# make -f Makefile.pre.in Makefile VERSION=1.5 installdir=<prefix>
-# where <prefix> is the prefix used to install Python for installdir
-# (and possibly similar for exec_installdir=<exec_prefix>).
-
-# Note: "make boot" implies "make clobber" -- it assumes that when you
-# bootstrap you may have changed platforms so it removes all previous
-# output files.
-
-# If you are building your extension as a shared library (your
-# Setup.in file starts with *shared*), run "make" or "make sharedmods"
-# to build the shared library files. If you are building a statically
-# linked Python binary (the only solution of your platform doesn't
-# support shared libraries, and sometimes handy if you want to
-# distribute or install the resulting Python binary), run "make
-# python".
-
-# Note: Each time you edit Makefile.pre.in or Setup, you must run
-# "make Makefile" before running "make".
-
-# Hint: if you want to use VPATH, you can start in an empty
-# subdirectory and say (e.g.):
-# make -f ../Makefile.pre.in boot srcdir=.. VPATH=..
-
-
-# === Bootstrap variables (edited through "make boot") ===
-
-# The prefix used by "make inclinstall libainstall" of core python
-installdir= /usr/local
-
-# The exec_prefix used by the same
-exec_installdir=$(installdir)
-
-# Source directory and VPATH in case you want to use VPATH.
-# (You will have to edit these two lines yourself -- there is no
-# automatic support as the Makefile is not generated by
-# config.status.)
-srcdir= .
-VPATH= .
-
-# === Variables that you may want to customize (rarely) ===
-
-# (Static) build target
-TARGET= python
-
-# Installed python binary (used only by boot target)
-PYTHON= python
-
-# Add more -I and -D options here
-CFLAGS= $(OPT) -I$(INCLUDEPY) -I$(EXECINCLUDEPY) $(DEFS)
-
-# These two variables can be set in Setup to merge extensions.
-# See example[23].
-BASELIB=
-BASESETUP=
-
-# === Variables set by makesetup ===
-
-MODOBJS= _MODOBJS_
-MODLIBS= _MODLIBS_
-
-# === Definitions added by makesetup ===
-
-# === Variables from configure (through sedscript) ===
-
-VERSION= @VERSION@
-CC= @CC@
-LINKCC= @LINKCC@
-SGI_ABI= @SGI_ABI@
-OPT= @OPT@
-LDFLAGS= @LDFLAGS@
-LDLAST= @LDLAST@
-DEFS= @DEFS@
-LIBS= @LIBS@
-LIBM= @LIBM@
-LIBC= @LIBC@
-RANLIB= @RANLIB@
-MACHDEP= @MACHDEP@
-SO= @SO@
-LDSHARED= @LDSHARED@
-CCSHARED= @CCSHARED@
-LINKFORSHARED= @LINKFORSHARED@
-CXX= @CXX@
-
-# Install prefix for architecture-independent files
-prefix= /usr/local
-
-# Install prefix for architecture-dependent files
-exec_prefix= $(prefix)
-
-# Uncomment the following two lines for AIX
-#LINKCC= $(LIBPL)/makexp_aix $(LIBPL)/python.exp "" $(LIBRARY); $(PURIFY) $(CC)
-#LDSHARED= $(LIBPL)/ld_so_aix $(CC) -bI:$(LIBPL)/python.exp
-
-# === Fixed definitions ===
-
-# Shell used by make (some versions default to the login shell, which is bad)
-SHELL= /bin/sh
-
-# Expanded directories
-BINDIR= $(exec_installdir)/bin
-LIBDIR= $(exec_prefix)/lib
-MANDIR= $(installdir)/man
-INCLUDEDIR= $(installdir)/include
-SCRIPTDIR= $(prefix)/lib
-
-# Detailed destination directories
-BINLIBDEST= $(LIBDIR)/python$(VERSION)
-LIBDEST= $(SCRIPTDIR)/python$(VERSION)
-INCLUDEPY= $(INCLUDEDIR)/python$(VERSION)
-EXECINCLUDEPY= $(exec_installdir)/include/python$(VERSION)
-LIBP= $(exec_installdir)/lib/python$(VERSION)
-DESTSHARED= $(BINLIBDEST)/site-packages
-
-LIBPL= $(LIBP)/config
-
-PYTHONLIBS= $(LIBPL)/libpython$(VERSION).a
-
-MAKESETUP= $(LIBPL)/makesetup
-MAKEFILE= $(LIBPL)/Makefile
-CONFIGC= $(LIBPL)/config.c
-CONFIGCIN= $(LIBPL)/config.c.in
-SETUP= $(LIBPL)/Setup.config $(LIBPL)/Setup.local $(LIBPL)/Setup
-
-SYSLIBS= $(LIBM) $(LIBC)
-
-ADDOBJS= $(LIBPL)/python.o config.o
-
-# Portable install script (configure doesn't always guess right)
-INSTALL= $(LIBPL)/install-sh -c
-# Shared libraries must be installed with executable mode on some systems;
-# rather than figuring out exactly which, we always give them executable mode.
-# Also, making them read-only seems to be a good idea...
-INSTALL_SHARED= ${INSTALL} -m 555
-
-# === Fixed rules ===
-
-# Default target. This builds shared libraries only
-default: sharedmods
-
-# Build everything
-all: static sharedmods
-
-# Build shared libraries from our extension modules
-sharedmods: $(SHAREDMODS)
-
-# Build a static Python binary containing our extension modules
-static: $(TARGET)
-$(TARGET): $(ADDOBJS) lib.a $(PYTHONLIBS) Makefile $(BASELIB)
- $(LINKCC) $(LDFLAGS) $(LINKFORSHARED) \
- $(ADDOBJS) lib.a $(PYTHONLIBS) \
- $(LINKPATH) $(BASELIB) $(MODLIBS) $(LIBS) $(SYSLIBS) \
- -o $(TARGET) $(LDLAST)
-
-install: sharedmods
- if test ! -d $(DESTSHARED) ; then \
- mkdir $(DESTSHARED) ; else true ; fi
- -for i in X $(SHAREDMODS); do \
- if test $$i != X; \
- then $(INSTALL_SHARED) $$i $(DESTSHARED)/$$i; \
- fi; \
- done
-
-# Build the library containing our extension modules
-lib.a: $(MODOBJS)
- -rm -f lib.a
- ar cr lib.a $(MODOBJS)
- -$(RANLIB) lib.a
-
-# This runs makesetup *twice* to use the BASESETUP definition from Setup
-config.c Makefile: Makefile.pre Setup $(BASESETUP) $(MAKESETUP)
- $(MAKESETUP) \
- -m Makefile.pre -c $(CONFIGCIN) Setup -n $(BASESETUP) $(SETUP)
- $(MAKE) -f Makefile do-it-again
-
-# Internal target to run makesetup for the second time
-do-it-again:
- $(MAKESETUP) \
- -m Makefile.pre -c $(CONFIGCIN) Setup -n $(BASESETUP) $(SETUP)
-
-# Make config.o from the config.c created by makesetup
-config.o: config.c
- $(CC) $(CFLAGS) -c config.c
-
-# Setup is copied from Setup.in *only* if it doesn't yet exist
-Setup:
- cp $(srcdir)/Setup.in Setup
-
-# Make the intermediate Makefile.pre from Makefile.pre.in
-Makefile.pre: Makefile.pre.in sedscript
- sed -f sedscript $(srcdir)/Makefile.pre.in >Makefile.pre
-
-# Shortcuts to make the sed arguments on one line
-P=prefix
-E=exec_prefix
-H=Generated automatically from Makefile.pre.in by sedscript.
-L=LINKFORSHARED
-
-# Make the sed script used to create Makefile.pre from Makefile.pre.in
-sedscript: $(MAKEFILE)
- sed -n \
- -e '1s/.*/1i\\/p' \
- -e '2s%.*%# $H%p' \
- -e '/^VERSION=/s/^VERSION=[ ]*\(.*\)/s%@VERSION[@]%\1%/p' \
- -e '/^CC=/s/^CC=[ ]*\(.*\)/s%@CC[@]%\1%/p' \
- -e '/^CXX=/s/^CXX=[ ]*\(.*\)/s%@CXX[@]%\1%/p' \
- -e '/^LINKCC=/s/^LINKCC=[ ]*\(.*\)/s%@LINKCC[@]%\1%/p' \
- -e '/^OPT=/s/^OPT=[ ]*\(.*\)/s%@OPT[@]%\1%/p' \
- -e '/^LDFLAGS=/s/^LDFLAGS=[ ]*\(.*\)/s%@LDFLAGS[@]%\1%/p' \
- -e '/^LDLAST=/s/^LDLAST=[ ]*\(.*\)/s%@LDLAST[@]%\1%/p' \
- -e '/^DEFS=/s/^DEFS=[ ]*\(.*\)/s%@DEFS[@]%\1%/p' \
- -e '/^LIBS=/s/^LIBS=[ ]*\(.*\)/s%@LIBS[@]%\1%/p' \
- -e '/^LIBM=/s/^LIBM=[ ]*\(.*\)/s%@LIBM[@]%\1%/p' \
- -e '/^LIBC=/s/^LIBC=[ ]*\(.*\)/s%@LIBC[@]%\1%/p' \
- -e '/^RANLIB=/s/^RANLIB=[ ]*\(.*\)/s%@RANLIB[@]%\1%/p' \
- -e '/^MACHDEP=/s/^MACHDEP=[ ]*\(.*\)/s%@MACHDEP[@]%\1%/p' \
- -e '/^SO=/s/^SO=[ ]*\(.*\)/s%@SO[@]%\1%/p' \
- -e '/^LDSHARED=/s/^LDSHARED=[ ]*\(.*\)/s%@LDSHARED[@]%\1%/p' \
- -e '/^CCSHARED=/s/^CCSHARED=[ ]*\(.*\)/s%@CCSHARED[@]%\1%/p' \
- -e '/^SGI_ABI=/s/^SGI_ABI=[ ]*\(.*\)/s%@SGI_ABI[@]%\1%/p' \
- -e '/^$L=/s/^$L=[ ]*\(.*\)/s%@$L[@]%\1%/p' \
- -e '/^$P=/s/^$P=\(.*\)/s%^$P=.*%$P=\1%/p' \
- -e '/^$E=/s/^$E=\(.*\)/s%^$E=.*%$E=\1%/p' \
- $(MAKEFILE) >sedscript
- echo "/^installdir=/s%=.*%= $(installdir)%" >>sedscript
- echo "/^exec_installdir=/s%=.*%=$(exec_installdir)%" >>sedscript
- echo "/^srcdir=/s%=.*%= $(srcdir)%" >>sedscript
- echo "/^VPATH=/s%=.*%= $(VPATH)%" >>sedscript
- echo "/^LINKPATH=/s%=.*%= $(LINKPATH)%" >>sedscript
- echo "/^BASELIB=/s%=.*%= $(BASELIB)%" >>sedscript
- echo "/^BASESETUP=/s%=.*%= $(BASESETUP)%" >>sedscript
-
-# Bootstrap target
-boot: clobber
- VERSION=`$(PYTHON) -c "import sys; print sys.version[:3]"`; \
- installdir=`$(PYTHON) -c "import sys; print sys.prefix"`; \
- exec_installdir=`$(PYTHON) -c "import sys; print sys.exec_prefix"`; \
- $(MAKE) -f $(srcdir)/Makefile.pre.in VPATH=$(VPATH) srcdir=$(srcdir) \
- VERSION=$$VERSION \
- installdir=$$installdir \
- exec_installdir=$$exec_installdir \
- Makefile
-
-# Handy target to remove intermediate files and backups
-clean:
- -rm -f *.o *~
-
-# Handy target to remove everything that is easily regenerated
-clobber: clean
- -rm -f *.a tags TAGS config.c Makefile.pre $(TARGET) sedscript
- -rm -f *.so *.sl so_locations
-
-
-# Handy target to remove everything you don't want to distribute
-distclean: clobber
- -rm -f Makefile Setup
diff --git a/print/py-freetype/files/patch-Setup.w32 b/print/py-freetype/files/patch-Setup.w32
deleted file mode 100644
index dc2126f30f9f..000000000000
--- a/print/py-freetype/files/patch-Setup.w32
+++ /dev/null
@@ -1,10 +0,0 @@
-
-$FreeBSD$
-
---- Setup.w32.orig Thu Aug 19 23:41:30 1999
-+++ Setup.w32 Sat Feb 3 01:49:45 2001
-@@ -1,2 +1,3 @@
- #[MGW32]swig_options.extend(['-shadow', '-docstring'])
--freetypec freetype_wrap.c -I../../lib -I../../lib/extend -L../../lib -lttf.dll
-+*shared*
-+freetypec freetype_wrap.c -I${LOCALBASE}/include/freetype1/freetype -L${LOCALBASE}/lib -lttf
diff --git a/print/py-freetype/files/patch-freetype_wrap.c b/print/py-freetype/files/patch-freetype_wrap.c
deleted file mode 100644
index e7ad40d990f9..000000000000
--- a/print/py-freetype/files/patch-freetype_wrap.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- freetype_wrap.c.orig Mon May 22 23:21:55 2006
-+++ freetype_wrap.c Mon May 22 23:22:11 2006
-@@ -3410,7 +3410,7 @@
- PyObject * _argo0 = 0;
-
- self = self;
-- if(!PyArg_ParseTuple(args,"Oh:TT_Char_Index",&_argo0,&_arg1))
-+ if(!PyArg_ParseTuple(args,"OH:TT_Char_Index",&_argo0,&_arg1))
- return NULL;
- if (_argo0) {
- if (_argo0 == Py_None) { _arg0 = NULL; }
diff --git a/print/py-freetype/pkg-descr b/print/py-freetype/pkg-descr
deleted file mode 100644
index f61cff2f3b55..000000000000
--- a/print/py-freetype/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-A Python wrapping of the FreeType 1.2 rendering engine for TrueType fonts.
-Most of this is a direct and nearly exhaustive translation of the FreeType
-API. A few of the functions have been given more "Pythonic" wrappings for
-convenience. There are also a couple of _de_novo_ convenience functions to
-access certain bits of data.
diff --git a/print/py-freetype/pkg-plist b/print/py-freetype/pkg-plist
deleted file mode 100644
index fa44af6382ae..000000000000
--- a/print/py-freetype/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-%%PYTHON_SITELIBDIR%%/PyFT.py
-%%PYTHON_SITELIBDIR%%/PyFT.pyc
-%%PYTHON_SITELIBDIR%%/PyFT.pyo
-%%PYTHON_SITELIBDIR%%/freetype.py
-%%PYTHON_SITELIBDIR%%/freetype.pyc
-%%PYTHON_SITELIBDIR%%/freetype.pyo
-%%PYTHON_SITELIBDIR%%/freetype_inc.py
-%%PYTHON_SITELIBDIR%%/freetype_inc.pyc
-%%PYTHON_SITELIBDIR%%/freetype_inc.pyo
-%%PYTHON_SITELIBDIR%%/freetypecmodule.so