aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-24 09:48:54 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-24 09:48:54 +0000
commite93bcce3765679f81ac05e56190f14674f4f19cb (patch)
treea9fc040b5e7bc1fadfea0c3d418af3603469c60a /print
parent1781e5c1aae222bc1c8e7e79923561a9cfb56a24 (diff)
downloadports-e93bcce3765679f81ac05e56190f14674f4f19cb.tar.gz
ports-e93bcce3765679f81ac05e56190f14674f4f19cb.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-pgf/Makefile64
-rw-r--r--print/latex-pgf/distinfo1
-rw-r--r--print/latex-pgf/pkg-descr8
-rw-r--r--print/latex-pgf/pkg-plist27
5 files changed, 101 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 3f8e48916a2d..70d4ec3a27f1 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -92,6 +92,7 @@
SUBDIR += kcdlabel
SUBDIR += kover
SUBDIR += latex
+ SUBDIR += latex-pgf
SUBDIR += latex2rtf
SUBDIR += latex2slides
SUBDIR += lgrind
diff --git a/print/latex-pgf/Makefile b/print/latex-pgf/Makefile
new file mode 100644
index 000000000000..5d1a12c54fcf
--- /dev/null
+++ b/print/latex-pgf/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: latex-pgf
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-pgf
+PORTVERSION= 0.50
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= latex-beamer
+DISTNAME= ${PORTNAME:S/^latex-//}-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for TeX Portable Graphic Format
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= YES
+PLIST_SUB= TEXMF=${TEXMF} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMF= share/texmf
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMF}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= pgf.sty
+CLASS_FILES+= pgfarrows.sty
+CLASS_FILES+= pgfautomata.sty
+CLASS_FILES+= pgfheaps.sty
+CLASS_FILES+= pgfnodes.sty
+CLASS_FILES+= pgfshade.sty
+CLASS_FILES+= xxcolor.sty
+
+DOC_FILES= AUTHORS
+DOC_FILES+= ChangeLog
+DOC_FILES+= FILES
+DOC_FILES+= INSTALL
+DOC_FILES+= README
+DOC_FILES+= TODO
+DOC_FILES+= apple.jpg
+DOC_FILES+= apple.mask.jpg
+DOC_FILES+= pgfuserguide.pdf
+DOC_FILES+= pgfuserguide.tex
+DOC_FILES+= tu-logo.25.eps
+DOC_FILES+= tu-logo.25.jpg
+DOC_FILES+= tu-logo.eps
+DOC_FILES+= tu-logo.jpg
+DOC_FILES+= tu-logo.mask.jpg
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-pgf/distinfo b/print/latex-pgf/distinfo
new file mode 100644
index 000000000000..4dff2a904c7e
--- /dev/null
+++ b/print/latex-pgf/distinfo
@@ -0,0 +1 @@
+MD5 (pgf-0.50.tar.gz) = e4c500b277814d25a712e32491f41760
diff --git a/print/latex-pgf/pkg-descr b/print/latex-pgf/pkg-descr
new file mode 100644
index 000000000000..70cc1452f576
--- /dev/null
+++ b/print/latex-pgf/pkg-descr
@@ -0,0 +1,8 @@
+pgf stands for `portable graphics format'. It is a TeX macro package
+that allows you to create graphics in your TeX documents using a special
+pgfpicture environment and special macros for drawing lines, curves,
+rectangles, and many other kind of graphic objects.
+Its usage closely resembles the pstricks package or the normal picture
+environment of LaTeX.
+
+WWW: http://latex-beamer.sourceforge.net/
diff --git a/print/latex-pgf/pkg-plist b/print/latex-pgf/pkg-plist
new file mode 100644
index 000000000000..907df3f2ae22
--- /dev/null
+++ b/print/latex-pgf/pkg-plist
@@ -0,0 +1,27 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FILES
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/apple.jpg
+%%PORTDOCS%%%%DOCSDIR%%/apple.mask.jpg
+%%PORTDOCS%%%%DOCSDIR%%/pgfuserguide.pdf
+%%PORTDOCS%%%%DOCSDIR%%/pgfuserguide.tex
+%%PORTDOCS%%%%DOCSDIR%%/tu-logo.25.eps
+%%PORTDOCS%%%%DOCSDIR%%/tu-logo.25.jpg
+%%PORTDOCS%%%%DOCSDIR%%/tu-logo.eps
+%%PORTDOCS%%%%DOCSDIR%%/tu-logo.jpg
+%%PORTDOCS%%%%DOCSDIR%%/tu-logo.mask.jpg
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/pgf.sty
+%%CLASSDIR%%/pgfarrows.sty
+%%CLASSDIR%%/pgfautomata.sty
+%%CLASSDIR%%/pgfheaps.sty
+%%CLASSDIR%%/pgfnodes.sty
+%%CLASSDIR%%/pgfshade.sty
+%%CLASSDIR%%/xxcolor.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%