aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-03-18 06:08:22 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-03-18 06:08:22 +0000
commit40495e83009fc313c736dd6eb1cd47e469973a6c (patch)
tree2f728f83291e0e373c10991dae27a5294c5f7581 /print
parent5b597dddbdac29bb63e34ea02437e00532375152 (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/scribus/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 6b71f33725a9..355129b94b5c 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -13,6 +13,9 @@ COMMENT= Comprehensive desktop publishing program
LICENSE= GPLv2+
+BROKEN_armv6= fails to build: scribus.cpp:6711:36: assigning to 'double *' from incompatible type 'qreal *'
+BROKEN_armv7= fails to build: scribus.cpp:6711:36: assigning to 'double *' from incompatible type 'qreal *'
+
LIB_DEPENDS= liblcms.so:graphics/lcms \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
@@ -27,10 +30,10 @@ LIB_DEPENDS= liblcms.so:graphics/lcms \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
-USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
-USE_GNOME= libartlgpl2 libxml2
USES= cmake:outsource desktop-file-utils ghostscript:run jpeg \
pkgconfig python:2.7 shared-mime-info tar:xz
+USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
+USE_GNOME= libartlgpl2 libxml2
USE_LDCONFIG= yes
CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit