aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-27 20:37:29 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-27 20:37:29 +0000
commita5d29f083bcbd93aa90ece82beb23fa897aa2bd5 (patch)
tree1b20d9d1e5dff367307432a12cc37d1e0cda0f1d /print
parentf864e09734314e3942645b00b9eb59e8f86fda8b (diff)
downloadports-a5d29f083bcbd93aa90ece82beb23fa897aa2bd5.tar.gz
ports-a5d29f083bcbd93aa90ece82beb23fa897aa2bd5.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/frescobaldi/Makefile37
-rw-r--r--print/frescobaldi/distinfo3
-rw-r--r--print/frescobaldi/pkg-descr5
4 files changed, 46 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 21f8c8e1df8c..80ba098e1879 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -60,6 +60,7 @@
SUBDIR += fpdf
SUBDIR += freetype
SUBDIR += freetype2
+ SUBDIR += frescobaldi
SUBDIR += ft2demos
SUBDIR += ghostscript7-base
SUBDIR += ghostscript7-commfont
diff --git a/print/frescobaldi/Makefile b/print/frescobaldi/Makefile
new file mode 100644
index 000000000000..becc7a7f3f18
--- /dev/null
+++ b/print/frescobaldi/Makefile
@@ -0,0 +1,37 @@
+# Created by: martin.dieringer@gmx.de
+# $FreeBSD$
+
+PORTNAME= frescobaldi
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0.0
+CATEGORIES= print kde
+
+MAINTAINER= m.ne@gmx.net
+COMMENT= Music score editor for lilypond
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-poppler-qt5>=0:graphics/py-python-poppler-qt5@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-ly>=0:print/py-python-ly@${PY_FLAVOR}
+
+USES= gettext pyqt:5 python:3.4+ qmake qt:5 desktop-file-utils
+USE_PYQT= network printsupport sip svg webkit webkitwidgets widgets
+USE_PYTHON= distutils autoplist noflavors
+USE_GITHUB= yes
+GH_ACCOUNT= wbsoft
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= LILYPOND
+
+LILYPOND_DESC= Use unstable LilyPond (lilypond-devel)
+
+LILYPOND_RUN_DEPENDS= lilypond:print/lilypond-devel
+LILYPOND_RUN_DEPENDS_OFF= lilypond:print/lilypond
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|'share/man/man1'|'man/man1'|' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/print/frescobaldi/distinfo b/print/frescobaldi/distinfo
new file mode 100644
index 000000000000..edb3f20b7886
--- /dev/null
+++ b/print/frescobaldi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544957099
+SHA256 (wbsoft-frescobaldi-v3.0.0_GH0.tar.gz) = 70b169e520c57bc03bb593f8f7b9586c7f6d21a7eb3015a94a71e9d52bab58e1
+SIZE (wbsoft-frescobaldi-v3.0.0_GH0.tar.gz) = 8387944
diff --git a/print/frescobaldi/pkg-descr b/print/frescobaldi/pkg-descr
new file mode 100644
index 000000000000..c016bbcdae2e
--- /dev/null
+++ b/print/frescobaldi/pkg-descr
@@ -0,0 +1,5 @@
+Frescobaldi is a LilyPond sheet music text editor for KDE4. It aims to be
+powerful, yet lightweight and easy to use. Frescobaldi is Free Software,
+available under the GNU General Public License (version 2 or later).
+
+WWW: http://www.frescobaldi.org/