aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-14 09:31:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-14 09:31:45 +0000
commita7f7f65a82517e2b694e6265a087b68541947c8f (patch)
tree2469236b5c1c0e0ea1ce2af8ab7c0c45206de5f0 /print
parent6f6e427ff3d26c3f06796ebeaeb2b492d72e7632 (diff)
downloadports-a7f7f65a82517e2b694e6265a087b68541947c8f.tar.gz
ports-a7f7f65a82517e2b694e6265a087b68541947c8f.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile3
-rw-r--r--print/cups-base/files/patch-str344816
2 files changed, 17 insertions, 2 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index f680b7cf3eb6..fc421c9e8312 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cups
PORTVERSION= 1.4.2
DISTVERSIONSUFFIX= -source
-PORTREVISION= 1
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
@@ -84,7 +84,6 @@ USE_LDCONFIG= yes
PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.image
.else
-PORTREVISION= 2
CUPS_SUFFIX= -base
LIB_DEPENDS+= cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client \
cupsimage.2:${PORTSDIR}/${PKGCATEGORY}/cups-image
diff --git a/print/cups-base/files/patch-str3448 b/print/cups-base/files/patch-str3448
new file mode 100644
index 000000000000..97fdd98d9b82
--- /dev/null
+++ b/print/cups-base/files/patch-str3448
@@ -0,0 +1,16 @@
+diff -up cups-1.4.2/cups/dest.c.str3448 cups-1.4.2/cups/dest.c
+--- cups/dest.c.str3448 2009-08-28 23:54:34.000000000 +0100
++++ cups/dest.c 2009-12-10 18:15:50.910079549 +0000
+@@ -145,6 +145,12 @@ cupsAddDest(const char *name, /* I -
+
+ dest = cups_add_dest(name, instance, &num_dests, dests);
+
++ /*
++ * Find the base dest again now the array has been realloc'd.
++ */
++
++ parent = cupsGetDest(name, NULL, num_dests, *dests);
++
+ if (instance && parent && parent->num_options > 0)
+ {
+ /*