aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2008-07-26 18:39:26 +0000
committerMichael Johnson <ahze@FreeBSD.org>2008-07-26 18:39:26 +0000
commitf3a7c1088b10040c86480b4f096412f813b099a8 (patch)
tree8ed5189d4423a95906fb4bcd745c9cc4f0e3995b /print
parent830dcb5aeb28362d1d7b26b09ce58abe596d2b29 (diff)
downloadports-f3a7c1088b10040c86480b4f096412f813b099a8.tar.gz
ports-f3a7c1088b10040c86480b4f096412f813b099a8.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/system-config-printer/Makefile5
-rw-r--r--print/system-config-printer/distinfo6
-rw-r--r--print/system-config-printer/files/patch-cupshelpers_cupshelpers.py (renamed from print/system-config-printer/files/patch-cupshelpers.py)18
-rw-r--r--print/system-config-printer/files/patch-system-config-printer.py34
-rw-r--r--print/system-config-printer/files/patch-troubleshoot_CheckUSBPermissions.py11
-rw-r--r--print/system-config-printer/pkg-plist17
6 files changed, 54 insertions, 37 deletions
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 7c55ecbe1cf9..a48b057a4a4b 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= system-config-printer
-PORTVERSION= 0.9.93
-PORTREVISION= 1
+PORTVERSION= 1.0.4
CATEGORIES= print gnome
-MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/
+MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}.x/
MAINTAINER= gnome@FreeBSD.org
COMMENT= CUPS configuration Gtk+2.0 GUI
diff --git a/print/system-config-printer/distinfo b/print/system-config-printer/distinfo
index 03ca5a178092..7bd541146681 100644
--- a/print/system-config-printer/distinfo
+++ b/print/system-config-printer/distinfo
@@ -1,3 +1,3 @@
-MD5 (system-config-printer-0.9.93.tar.bz2) = b97deae648bc1c5825874d250a9c140c
-SHA256 (system-config-printer-0.9.93.tar.bz2) = dc14b3709ac671e9aaa1fa726895661352b0f36555ed73ba3eb44d91d6d63257
-SIZE (system-config-printer-0.9.93.tar.bz2) = 686166
+MD5 (system-config-printer-1.0.4.tar.bz2) = 5f63211606efd0913b14dfaf4de9403d
+SHA256 (system-config-printer-1.0.4.tar.bz2) = bcbc098527be78ebedf908bfc0166cb65c1ad11f87c6db239fad148ccbaf35c9
+SIZE (system-config-printer-1.0.4.tar.bz2) = 716270
diff --git a/print/system-config-printer/files/patch-cupshelpers.py b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
index b1b006330a8d..53e62fba18ff 100644
--- a/print/system-config-printer/files/patch-cupshelpers.py
+++ b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
@@ -1,15 +1,15 @@
---- cupshelpers.py.orig 2008-03-20 11:49:54.000000000 -0400
-+++ cupshelpers.py 2008-03-20 11:51:06.000000000 -0400
-@@ -19,7 +19,7 @@
- ## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+--- cupshelpers/cupshelpers.py.orig 2008-07-09 06:23:44.000000000 -0500
++++ cupshelpers/cupshelpers.py 2008-07-26 13:33:50.596144479 -0500
+@@ -20,7 +20,7 @@
import cups, pprint, os, tempfile, re
--from rhpl.translate import _, N_
-+from gettext import gettext as _
import locale
+-from . import _debugprint
++# from . import _debugprint
- def debugprint(x):
-@@ -456,7 +456,7 @@
+ class Printer:
+ _flags_blacklist = ["options", "local"]
+@@ -699,7 +699,7 @@
# First, a local function. How to check that something exists
# in a path:
@@ -18,7 +18,7 @@
# Strip out foomatic '%'-style place-holders.
p = name.find ('%')
if p != -1:
-@@ -551,7 +551,7 @@
+@@ -794,7 +794,7 @@
continue
exepath = pathcheck (exe,
diff --git a/print/system-config-printer/files/patch-system-config-printer.py b/print/system-config-printer/files/patch-system-config-printer.py
index 0c545351c11e..2d8528a7b4f3 100644
--- a/print/system-config-printer/files/patch-system-config-printer.py
+++ b/print/system-config-printer/files/patch-system-config-printer.py
@@ -1,24 +1,24 @@
---- system-config-printer.py.orig 2008-05-23 04:57:31.000000000 -0700
-+++ system-config-printer.py 2008-05-26 23:25:11.159502896 -0700
-@@ -3098,7 +3098,7 @@
+--- system-config-printer.py.orig 2008-07-10 10:31:58.000000000 -0500
++++ system-config-printer.py 2008-07-26 13:26:03.412705522 -0500
+@@ -3389,7 +3389,7 @@
# Try to get make and model via SNMP
if host:
os.environ["HOST"] = host
-- cmd = '/usr/lib/cups/backend/snmp "${HOST}" 2>/dev/null'
-+ cmd = '%%LOCALBASE%%/libexec/cups/backend/snmp "${HOST}" 2>/dev/null'
+- cmd = '/usr/lib/cups/backend/snmp "${HOST}"'
++ cmd = '%%LOCALBASE%%/lib/cups/backend/snmp "${HOST}"'
debugprint (host + ": " + cmd)
- p = os.popen(cmd, 'r')
- output = p.read ().strip ()
-@@ -4370,7 +4370,7 @@
- os.environ["PPD"] = filename
- # We want this to be in the current natural language,
- # so we intentionally don't set LC_ALL=C here.
-- p = os.popen ('/usr/bin/cupstestppd -rvv "$PPD"', 'r')
-+ p = os.popen ('%%LOCALBASE%%/bin/cupstestppd -rvv "$PPD"', 'r')
- output = p.readlines ()
- p.close ()
- err += reduce (lambda x, y: x + y, output)
-@@ -4655,7 +4655,7 @@
+ stdout = None
+ try:
+@@ -4693,7 +4693,7 @@
+ try:
+ # We want this to be in the current natural language,
+ # so we intentionally don't set LC_ALL=C here.
+- p = subprocess.Popen (['/usr/bin/cupstestppd',
++ p = subprocess.Popen (['%%LOCALBASE%%/bin/cupstestppd',
+ '-rvv', filename],
+ stdin=file("/dev/null"),
+ stdout=subprocess.PIPE,
+@@ -4984,7 +4984,7 @@
(pkgs, exes) = cupshelpers.missingPackagesAndExecutables (ppd)
if len (pkgs) > 0 or len (exes) > 0:
# We didn't find a necessary executable. Complain.
diff --git a/print/system-config-printer/files/patch-troubleshoot_CheckUSBPermissions.py b/print/system-config-printer/files/patch-troubleshoot_CheckUSBPermissions.py
new file mode 100644
index 000000000000..8fc60a7609eb
--- /dev/null
+++ b/print/system-config-printer/files/patch-troubleshoot_CheckUSBPermissions.py
@@ -0,0 +1,11 @@
+--- troubleshoot/CheckUSBPermissions.py.orig 2008-07-26 13:36:20.440361271 -0500
++++ troubleshoot/CheckUSBPermissions.py 2008-07-26 13:36:36.255172372 -0500
+@@ -51,7 +51,7 @@
+ if not os.access (LSUSB, os.X_OK):
+ return False
+
+- GETFACL = "/usr/bin/getfacl"
++ GETFACL = "/bin/getfacl"
+ if not os.access (GETFACL, os.X_OK):
+ return False
+
diff --git a/print/system-config-printer/pkg-plist b/print/system-config-printer/pkg-plist
index 6869c8cae57a..1b0a16f06eb7 100644
--- a/print/system-config-printer/pkg-plist
+++ b/print/system-config-printer/pkg-plist
@@ -3,6 +3,15 @@ bin/system-config-printer
bin/system-config-printer-applet
etc/dbus-1/system.d/newprinternotification.conf
etc/xdg/autostart/redhat-print-applet.desktop
+%%PYTHON_SITELIBDIR%%/cupshelpers-1.0-py2.5.egg-info
+%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.pyc
share/applications/redhat-manage-print-jobs.desktop
share/applications/redhat-my-default-printer.desktop
share/applications/redhat-system-config-printer.desktop
@@ -71,7 +80,6 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/authconn.py
%%DATADIR%%/config.py
%%DATADIR%%/contextmenu.py
-%%DATADIR%%/cupshelpers.py
%%DATADIR%%/debug.py
%%DATADIR%%/errordialogs.py
%%DATADIR%%/gtk_label_autowrap.py
@@ -80,10 +88,8 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/jobviewer.py
%%DATADIR%%/monitor.py
%%DATADIR%%/my-default-printer.py
-%%DATADIR%%/openprinting.py
%%DATADIR%%/options.py
%%DATADIR%%/optionwidgets.py
-%%DATADIR%%/ppds.py
%%DATADIR%%/probe_printer.py
%%DATADIR%%/pysmb.py
%%DATADIR%%/smburi.py
@@ -94,6 +100,7 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/troubleshoot/CheckNetworkServerSanity.py
%%DATADIR%%/troubleshoot/CheckPPDSanity.py
%%DATADIR%%/troubleshoot/CheckPrinterSanity.py
+%%DATADIR%%/troubleshoot/CheckUSBPermissions.py
%%DATADIR%%/troubleshoot/ChooseNetworkPrinter.py
%%DATADIR%%/troubleshoot/ChoosePrinter.py
%%DATADIR%%/troubleshoot/DeviceListed.py
@@ -113,6 +120,7 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/troubleshoot/Welcome.py
%%DATADIR%%/troubleshoot/__init__.py
%%DATADIR%%/troubleshoot/base.py
+%%DATADIR%%/userdefault.py
@dirrm %%DATADIR%%/troubleshoot
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
@@ -135,5 +143,4 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
@dirrmtry share/applications
-@dirrm etc/xdg/autostart
-@dirrm etc/xdg
+@dirrm %%PYTHON_SITELIBDIR%%/cupshelpers