aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-08 18:18:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-08 18:18:08 +0000
commit1a8b9f9881a539865e0ccc87dae1886b2cfb9552 (patch)
treed74b4530f61ee612196f2fb0cb916884e833db45 /print
parent87f8b2e2dd831d333cf42c781b805177b21f4278 (diff)
downloadports-1a8b9f9881a539865e0ccc87dae1886b2cfb9552.tar.gz
ports-1a8b9f9881a539865e0ccc87dae1886b2cfb9552.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/openprinting/Makefile52
-rw-r--r--print/openprinting/files/patch-freebsd246
2 files changed, 19 insertions, 279 deletions
diff --git a/print/openprinting/Makefile b/print/openprinting/Makefile
index 0ec97312b9a1..37f59623d171 100644
--- a/print/openprinting/Makefile
+++ b/print/openprinting/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openprinting
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=\
@@ -16,26 +16,15 @@ COMMENT= Sun's implementation of the OpenPrinting API (PAPI)
WRKSRC= ${WRKDIR}/papi-${PORTVERSION}_beta
-USE_BZIP2= yes
-USES= gettext iconv gmake
-
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/libexec
-
+USES= gettext gmake iconv libtool tar:bzip2
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
-USE_AUTOTOOLS= aclocal autoconf autoheader automake libtool
-ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS+= -a -c
-
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lintl
-# Really disable building static libraries; the package does not use
-# its own libtool, and we have to tell it to stop.
-# Static libraries are not very useful in this package.
-MAKE_ARGS= LIBTOOL="${LIBTOOL} --tag=disable-static"
-
# TODO: Get mod_ipp to actually work; Sun's example seems to be broken
# under both Apache 1.3/2.0, this could be a papi issue; does not build
# w/Apache 2.2.
@@ -58,7 +47,7 @@ CONFIGURE_ARGS+=--without-apache
.endif
.if defined(WITH_PSM_CUPS)
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
CONFIGURE_ARGS+=--with-cups=${LOCALBASE}
.else
CONFIGURE_ARGS+=--without-cups
@@ -76,38 +65,35 @@ PLIST_FILES+=\
include/ipp-listener.h \
lib/libpapi-common.so \
lib/libpapi-common.so.0 \
- lib/libpapi-common.la \
+ lib/libpapi-common.so.0.0.0 \
lib/libpapi.so \
lib/libpapi.so.0 \
- lib/libpapi.la \
+ lib/libpapi.so.0.0.0 \
lib/libipp-core.so \
lib/libipp-core.so.0 \
- lib/libipp-core.la \
+ lib/libipp-core.so.0.0.0 \
lib/libipp-listener.so \
lib/libipp-listener.so.0 \
- lib/libipp-listener.la \
+ lib/libipp-listener.so.0.0.0 \
libexec/psm-lpd.so \
- libexec/psm-lpd.la \
libexec/psm-ipp.so \
- libexec/psm-ipp.la \
libexec/lpd-port \
man/man5/psm-ipp.5.gz
.if defined(WITH_PSM_CUPS)
-PLIST_FILES+=\
- libexec/psm-cups.so \
- libexec/psm-cups.la
+PLIST_FILES+= libexec/psm-cups.so
.endif
.if defined(WITH_MOD_IPP)
-PLIST_FILES+=\
- lib/mod_ipp.so \
- lib/mod_ipp.la
+PLIST_FILES+= lib/mod_ipp.so
.endif
-.include <bsd.port.pre.mk>
-
-pre-configure:
- cd ${WRKSRC}; ./autogen.sh
+post-patch:
+ @${REINPLACE_CMD} '/^LIBS =/s,$$, ../libpapi-common/libpapi-common.la @LIBS@,' \
+ ${WRKSRC}/source/bsd-sysv-commands/Makefile.in \
+ ${WRKSRC}/source/examples/Makefile.in
+ @${REINPLACE_CMD} -e 's/-ldl//' -e 's/-lnsl//' \
+ ${WRKSRC}/source/libpapi-cups/Makefile.in \
+ ${WRKSRC}/source/libpapi-dynamic/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/openprinting/files/patch-freebsd b/print/openprinting/files/patch-freebsd
index 9cb98d1945c4..2563a6ce494b 100644
--- a/print/openprinting/files/patch-freebsd
+++ b/print/openprinting/files/patch-freebsd
@@ -1,96 +1,3 @@
-Files /home/bms/x/y/papi-1.0_beta.orig/.acinclude.m4.swp and ./.acinclude.m4.swp differ
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/acinclude.m4 ./acinclude.m4
---- /home/bms/x/y/papi-1.0_beta.orig/acinclude.m4 2005-09-21 17:59:13.000000000 +0100
-+++ ./acinclude.m4 2010-02-06 20:06:09.000000000 +0000
-@@ -41,3 +41,19 @@
- fi
- AM_CONDITIONAL(HAVE_CUPS, [ test x$CUPS_PREFIX != x ])
- ])
-+
-+dnl
-+dnl Check if we should build examples.
-+dnl
-+AC_DEFUN([AC_CHECK_EXAMPLES], [
-+AC_ARG_ENABLE(examples, [ --enable-examples build with examples [default=no]], enable_examples=yes, enable_examples=no)
-+AM_CONDITIONAL(ENABLE_EXAMPLES, [ test x$enable_examples != xno ])
-+])
-+
-+dnl
-+dnl Check if we should BSD/SYSV lpr commands.
-+dnl
-+AC_DEFUN([AC_CHECK_BSD_SYSV_COMMANDS], [
-+AC_ARG_ENABLE(bsd-sysv-commands, [ --enable-bsd-sysv-commands build with BSD/SYSV commands [default=no]], enable_bsd_sysv_commands=yes, enable_bsd_sysv_commands=no)
-+AM_CONDITIONAL(ENABLE_BSD_SYSV_COMMANDS, [ test x$enable_bsd_sysv_commands != xno ])
-+])
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/configure.in ./configure.in
---- /home/bms/x/y/papi-1.0_beta.orig/configure.in 2006-03-12 06:15:33.000000000 +0000
-+++ ./configure.in 2010-02-06 20:05:07.000000000 +0000
-@@ -115,6 +115,12 @@
- AC_MSG_RESULT([Default IPP server: $DEFAULT_IPP_SERVER])
- AC_SUBST(DEFAULT_IPP_SERVER)
-
-+dnl»····check if we should build and install examples.
-+AC_CHECK_EXAMPLES
-+
-+dnl»····check if we should build and install BSD/SYSV lpr commands.
-+AC_CHECK_BSD_SYSV_COMMANDS
-+
- dnl which linker flags do we use for inclusion of mapfiles.
- os=`uname -s`
- AM_CONDITIONAL(LINUX, [ test x$os = xLinux ] )
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/docs/man/Makefile.am ./docs/man/Makefile.am
---- /home/bms/x/y/papi-1.0_beta.orig/docs/man/Makefile.am 2006-03-12 06:30:42.000000000 +0000
-+++ ./docs/man/Makefile.am 2010-02-06 20:18:41.000000000 +0000
-@@ -5,16 +5,21 @@
- # $Id: Makefile.am,v 1.5 2006/03/12 06:30:42 njacobs Exp $
- #
-
--man_MANS_in = lpq.1b.in lpr.1b.in lprm.1b.in lpc.1b.in
-+man_MANS_in =
-+if ENABLE_BSD_SYSV_COMMANDS
-+man_MANS_in += lpq.1b.in lpr.1b.in lprm.1b.in lpc.1b.in
- man_MANS_in += lpstat.1.in lp.1.in cancel.1.in enable.1.in disable.1.in
- man_MANS_in += lpmove.1m.in accept.1m.in reject.1m.in
-+endif
- man_MANS_in += psm-ipp.5.in
-
-
- man_MANS=$(man_MANS_in:%.in=%)
-+if ENABLE_BSD_SYSV_COMMANDS
- man_MANS += lpq.1b lpr.1b lprm.1b lpc.1b
- man_MANS += lpstat.1 lp.1 cancel.1 enable.1 disable.1
- man_MANS += lpmove.1m accept.1m reject.1m
-+endif
- man_MANS += psm-ipp.5
-
- SUFFIXES = .in
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/Makefile.am ./source/Makefile.am
---- /home/bms/x/y/papi-1.0_beta.orig/source/Makefile.am 2005-09-21 18:13:17.000000000 +0100
-+++ ./source/Makefile.am 2010-02-06 20:05:59.000000000 +0000
-@@ -13,6 +13,14 @@
- CUPS_MODULE= libpapi-cups
- endif
-
-+if ENABLE_EXAMPLES
-+EXAMPLES= examples
-+endif
-+
-+if ENABLE_BSD_SYSV_COMMANDS
-+BSD_SYSV_COMMANDS= bsd-sysv-commands
-+endif
-+
- AUTOMAKE_OPTIONS=foreign
- SUBDIRS= libpapi-common \
- libpapi-dynamic \
-@@ -21,6 +29,6 @@
- libpapi-ipp \
- $(CUPS_MODULE) \
- libipp-listener \
-- bsd-sysv-commands \
-+ $(BSD_SYSV_COMANDS) \
- $(APACHE_MODULE) \
-- examples
-+ $(EXAMPLES)
diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/bsd-sysv-commands/common.c ./source/bsd-sysv-commands/common.c
--- /home/bms/x/y/papi-1.0_beta.orig/source/bsd-sysv-commands/common.c 2006-02-15 21:24:20.000000000 +0000
+++ ./source/bsd-sysv-commands/common.c 2010-01-31 13:40:22.000000000 +0000
@@ -233,127 +140,6 @@ diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/attribute.c ./s
#include <papi.h>
static void papiAttributeFree(papi_attribute_t *attribute);
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/config.h.in ./source/libpapi-common/config.h.in
---- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/config.h.in 2006-03-12 06:17:13.000000000 +0000
-+++ ./source/libpapi-common/config.h.in 2010-02-06 20:05:40.000000000 +0000
-@@ -84,6 +84,10 @@
- /* Define to 1 if you have the <unistd.h> header file. */
- #undef HAVE_UNISTD_H
-
-+/* Define to the sub-directory in which libtool stores uninstalled libraries.
-+ */
-+#undef LT_OBJDIR
-+
- /* Name of package */
- #undef PACKAGE
-
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/config.h.in~ ./source/libpapi-common/config.h.in~
---- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/config.h.in~ 1970-01-01 01:00:00.000000000 +0100
-+++ ./source/libpapi-common/config.h.in~ 2010-02-06 20:05:12.000000000 +0000
-@@ -0,0 +1,103 @@
-+/* source/libpapi-common/config.h.in. Generated from configure.in by autoheader. */
-+
-+/* Define to 1 if you have the `dlopen' function. */
-+#undef HAVE_DLOPEN
-+
-+/* Define to 1 if you have the `dlsym' function. */
-+#undef HAVE_DLSYM
-+
-+/* Define to 1 if you have the `fprintf' function. */
-+#undef HAVE_FPRINTF
-+
-+/* define if you have getipnodbyname */
-+#undef HAVE_GETIPNODEBYNAME
-+
-+/* Define to 1 if you have the `getpassphrase' function. */
-+#undef HAVE_GETPASSPHRASE
-+
-+/* Define to 1 if you have the `gettext' function. */
-+#undef HAVE_GETTEXT
-+
-+/* Define to 1 if you have the <inttypes.h> header file. */
-+#undef HAVE_INTTYPES_H
-+
-+/* Define to 1 if you have the `is_system_labeled' function. */
-+#undef HAVE_IS_SYSTEM_LABELED
-+
-+/* Define to 1 if you have the `localtime' function. */
-+#undef HAVE_LOCALTIME
-+
-+/* Define to 1 if you have the <memory.h> header file. */
-+#undef HAVE_MEMORY_H
-+
-+/* Define to 1 if you have the <priv.h> header file. */
-+#undef HAVE_PRIV_H
-+
-+/* define if you have rresvport_af */
-+#undef HAVE_RRESVPORT_AF
-+
-+/* Define to 1 if you have the `snprintf' function. */
-+#undef HAVE_SNPRINTF
-+
-+/* Define to 1 if you have the <stdarg.h> header file. */
-+#undef HAVE_STDARG_H
-+
-+/* Define to 1 if you have the <stdint.h> header file. */
-+#undef HAVE_STDINT_H
-+
-+/* Define to 1 if you have the <stdlib.h> header file. */
-+#undef HAVE_STDLIB_H
-+
-+/* Define to 1 if you have the `strcmp' function. */
-+#undef HAVE_STRCMP
-+
-+/* Define to 1 if you have the `strdup' function. */
-+#undef HAVE_STRDUP
-+
-+/* Define to 1 if you have the `strerror' function. */
-+#undef HAVE_STRERROR
-+
-+/* Define to 1 if you have the `strftime' function. */
-+#undef HAVE_STRFTIME
-+
-+/* Define to 1 if you have the <strings.h> header file. */
-+#undef HAVE_STRINGS_H
-+
-+/* Define to 1 if you have the <string.h> header file. */
-+#undef HAVE_STRING_H
-+
-+/* Define to 1 if you have the `strlcat' function. */
-+#undef HAVE_STRLCAT
-+
-+/* Define to 1 if you have the `strlcpy' function. */
-+#undef HAVE_STRLCPY
-+
-+/* Define to 1 if you have the <sys/stat.h> header file. */
-+#undef HAVE_SYS_STAT_H
-+
-+/* Define to 1 if you have the <sys/types.h> header file. */
-+#undef HAVE_SYS_TYPES_H
-+
-+/* Define to 1 if you have the <unistd.h> header file. */
-+#undef HAVE_UNISTD_H
-+
-+/* Define to the address where bug reports for this package should be sent. */
-+#undef PACKAGE_BUGREPORT
-+
-+/* Define to the full name of this package. */
-+#undef PACKAGE_NAME
-+
-+/* Define to the full name and version of this package. */
-+#undef PACKAGE_STRING
-+
-+/* Define to the one symbol short name of this package. */
-+#undef PACKAGE_TARNAME
-+
-+/* Define to the version of this package. */
-+#undef PACKAGE_VERSION
-+
-+/* Define to 1 if you have the ANSI C header files. */
-+#undef STDC_HEADERS
-+
-+/* Define to empty if `const' does not conform to ANSI C. */
-+#undef const
diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/library.c ./source/libpapi-common/library.c
--- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/library.c 2005-10-31 18:56:45.000000000 +0000
+++ ./source/libpapi-common/library.c 2010-01-31 13:10:49.000000000 +0000
@@ -448,38 +234,6 @@ diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-common/uri.c ./source/
}
}
} else { /* scheme:scheme_part */
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-cups/Makefile.am ./source/libpapi-cups/Makefile.am
---- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-cups/Makefile.am 2005-10-31 18:56:45.000000000 +0000
-+++ ./source/libpapi-cups/Makefile.am 2010-02-06 19:22:15.000000000 +0000
-@@ -8,7 +8,7 @@
-
- lib_LTLIBRARIES = psm-cups.la
-
--psm_cups_la_LIBADD = -ldl -L@CUPS_PREFIX@/lib -lcups
-+psm_cups_la_LIBADD = -L@CUPS_PREFIX@/lib -lcups
- psm_cups_la_LDFLAGS = -module -avoid-version
-
- psm_cupsincludedir = $(includedir)
-diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-dynamic/Makefile.am ./source/libpapi-dynamic/Makefile.am
---- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-dynamic/Makefile.am 2006-03-12 06:15:09.000000000 +0000
-+++ ./source/libpapi-dynamic/Makefile.am 2010-02-06 19:22:30.000000000 +0000
-@@ -8,7 +8,7 @@
-
- lib_LTLIBRARIES = libpapi.la
-
--libpapi_la_LIBADD = ../libpapi-common/libpapi-common.la -ldl
-+libpapi_la_LIBADD = ../libpapi-common/libpapi-common.la
- libpapi_la_LDFLAGS = @MAPFLAGS@
-
- libpapiincludedir = $(includedir)
-@@ -23,7 +23,6 @@
- libpapi_la_SOURCES += nss/nss-emulation.c nss/nss-files.c nss/nss-printcap.c \
- nss/nss-nis.c
- AM_CPPFLAGS += -I./nss -DNSS_EMULATION
--libpapi_la_LIBADD += -lnsl
- libpapi_la_LDFLAGS += @MAPFLAGS@-emulation
- endif
-
diff -uNr /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-dynamic/nss/nss-emulation.h ./source/libpapi-dynamic/nss/nss-emulation.h
--- /home/bms/x/y/papi-1.0_beta.orig/source/libpapi-dynamic/nss/nss-emulation.h 2005-02-26 06:58:42.000000000 +0000
+++ ./source/libpapi-dynamic/nss/nss-emulation.h 2010-01-31 13:14:18.000000000 +0000