aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2014-05-26 20:31:28 +0000
committerHiroki Sato <hrs@FreeBSD.org>2014-05-26 20:31:28 +0000
commita6f1e190e5905d714593b5e8cb0407dbf5a18c3b (patch)
tree805ac7f99889fb4d04ebfc878fe2ac2dc81613b2 /print
parent2a58569cb27a86a893c58467146bf2906f18936d (diff)
downloadports-a6f1e190e5905d714593b5e8cb0407dbf5a18c3b.tar.gz
ports-a6f1e190e5905d714593b5e8cb0407dbf5a18c3b.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/cups-fxlinuxprint/Makefile24
-rw-r--r--print/cups-fxlinuxprint/distinfo2
-rw-r--r--print/cups-fxlinuxprint/files/patch-Makefile.in15
-rw-r--r--print/cups-fxlinuxprint/files/patch-fxlinuxprint.c20
-rw-r--r--print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd58
-rw-r--r--print/cups-fxlinuxprint/pkg-descr12
-rw-r--r--print/cups-fxlinuxprint/pkg-plist12
8 files changed, 144 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index e8fff19f83b2..cfd7400ab1ac 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -33,6 +33,7 @@
SUBDIR += cups-client
SUBDIR += cups-cloud-print
SUBDIR += cups-filters
+ SUBDIR += cups-fxlinuxprint
SUBDIR += cups-image
SUBDIR += cups-pdf
SUBDIR += cups-pk-helper
diff --git a/print/cups-fxlinuxprint/Makefile b/print/cups-fxlinuxprint/Makefile
new file mode 100644
index 000000000000..6f22e934b8b9
--- /dev/null
+++ b/print/cups-fxlinuxprint/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= fxlinuxprint
+PORTVERSION= 1.0.1
+CATEGORIES= print
+MASTER_SITES= ftp://download.fujixerox.co.jp/pub/exe/apeosport/c4300series/
+PKGNAMEPREFIX= cups-
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Fuji Xerox Printer Driver
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+
+USES= dos2unix
+DOS2UNIX_FILES= fxlinuxprint.ppd
+USE_GHOSTSCRIPT_RUN=yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/print/cups-fxlinuxprint/distinfo b/print/cups-fxlinuxprint/distinfo
new file mode 100644
index 000000000000..deced8cc0232
--- /dev/null
+++ b/print/cups-fxlinuxprint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fxlinuxprint-src-1.0.1.tar.gz) = 369ec48a0f5817a60f63c75b192ccb1d8c8cf30b1d4a16a74a4133242961e515
+SIZE (fxlinuxprint-src-1.0.1.tar.gz) = 85455
diff --git a/print/cups-fxlinuxprint/files/patch-Makefile.in b/print/cups-fxlinuxprint/files/patch-Makefile.in
new file mode 100644
index 000000000000..ec11a72d8ee0
--- /dev/null
+++ b/print/cups-fxlinuxprint/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2014-05-09 10:00:10.000000000 +0900
++++ Makefile.in 2014-05-09 10:07:35.000000000 +0900
+@@ -166,9 +166,9 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-cupsfilterdir = /usr/lib/cups/filter
+-cupsppddir = /usr/share/cups/model/FujiXerox/en
+-cupsmimedir = /etc/cups
++cupsfilterdir = @libexecdir@/cups/filter
++cupsppddir = @datadir@/cups/model/FujiXerox/en
++cupsmimedir = @sysconfdir@/cups
+ EXTRA_DIST = fxlinuxprint.ppd mimefx.types mimefx.convs
+ cupsppd_DATA = fxlinuxprint.ppd
+ cupsmime_DATA = mimefx.types mimefx.convs
diff --git a/print/cups-fxlinuxprint/files/patch-fxlinuxprint.c b/print/cups-fxlinuxprint/files/patch-fxlinuxprint.c
new file mode 100644
index 000000000000..4085eef4a74e
--- /dev/null
+++ b/print/cups-fxlinuxprint/files/patch-fxlinuxprint.c
@@ -0,0 +1,20 @@
+--- fxlinuxprint.c.orig 2006-03-06 15:19:54.000000000 +0900
++++ fxlinuxprint.c 2014-05-09 10:28:36.000000000 +0900
+@@ -24,7 +24,7 @@
+ #include <fcntl.h>
+ #define __USE_XOPEN_EXTENDED
+ #include <signal.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <unistd.h>
+ #include <cups/cups.h>
+ #include <cups/ppd.h>
+@@ -517,7 +517,7 @@
+ if (opt->job_type == JOB_SECURITY) {
+ strcat (pjl, PJLSetHoldType);
+ if (opt->hold_key[0] != 0x00) {
+- if (Decode (opt->hold_key, decode_buff, &decode_len)) {
++ if (Decode ((unsigned char *)opt->hold_key, (unsigned char *)decode_buff, &decode_len)) {
+ decode_buff[decode_len] = 0;
+ } else {
+ strcpy (decode_buff, opt->hold_key);
diff --git a/print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd b/print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd
new file mode 100644
index 000000000000..f1d9cab2269e
--- /dev/null
+++ b/print/cups-fxlinuxprint/files/patch-fxlinuxprint.ppd
@@ -0,0 +1,58 @@
+--- fxlinuxprint.ppd.orig 2014-05-09 10:50:03.000000000 +0900
++++ fxlinuxprint.ppd 2014-05-09 10:51:32.000000000 +0900
+@@ -24,15 +24,15 @@
+ *LanguageEncoding: ISOLatin1
+ *PCFileName: "FXLINUXPRINT.PPD"
+ *Manufacturer: "FX"
+-*Product: "FX Printer Driver for Linux"
++*Product: "(FX Printer Driver)"
+ *cupsVersion: 1.1
+ *cupsManualCopies: True
+ *cupsModelNumber: 2
+ *cupsFilter: "application/vnd.cups-pdfprintfx 0 pdftopjlfx"
+ *cupsFilter: "application/vnd.cups-postscript 0 pstopdffx"
+-*ShortNickName: "FX Printer Driver for Linux"
+-*ModelName: "FX Printer Driver for Linux"
+-*NickName: "FX Printer Driver for Linux"
++*ShortNickName: "FX Printer Driver"
++*ModelName: "FX Printer Driver"
++*NickName: "FX Printer Driver"
+ *PSVersion: "(3010.000) 550"
+ *PSVersion: "(3010.000) 651"
+ *PSVersion: "(3010.000) 652"
+@@ -73,7 +73,7 @@
+ *PageSize B5/B5 (182 x 257mm): "<</PageSize[516 729]/ImagingBBox null>>setpagedevice"
+ *PageSize Letter/Letter (8.5 x 11"): "<</PageSize[612 792]/ImagingBBox null>>setpagedevice"
+ *PageSize Legal/Legal (8.5 x 14"): "<</PageSize[612 1008]/ImagingBBox null>>setpagedevice"
+-*PageSize Ledger/Ledger (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
++*PageSize Tabloid/Tabloid (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
+ *CloseUI: *PageSize
+
+ *OpenUI *PageRegion: PickOne
+@@ -86,7 +86,7 @@
+ *PageRegion B5/B5 (182 x 257mm): "<</PageSize[516 729]/ImagingBBox null>>setpagedevice"
+ *PageRegion Letter/Letter (8.5 x 11"): "<</PageSize[612 792]/ImagingBBox null>>setpagedevice"
+ *PageRegion Legal/Legal (8.5 x 14"): "<</PageSize[612 1008]/ImagingBBox null>>setpagedevice"
+-*PageRegion Ledger/Ledger (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
++*PageRegion Tabloid/Tabloid (11 x 17"): "<</PageSize[792 1224]/ImagingBBox null>>setpagedevice"
+ *CloseUI: *PageRegion
+
+ *DefaultImageableArea: A4
+@@ -97,7 +97,7 @@
+ *ImageableArea A5/A5 (148 x 210mm): "11.62 11.62 407.91 583.65 "
+ *ImageableArea B5/B5 (182 x 257mm): "11.62 11.62 504.28 716.88 "
+ *ImageableArea Legal/Legal (8.5 x 14"): "11.62 11.62 600.38 996.38 "
+-*ImageableArea Ledger/Ledger (11 x 17"): "11.62 11.62 780.38 1212.38 "
++*ImageableArea Tabloid/Tabloid (11 x 17"): "11.62 11.62 780.38 1212.38 "
+
+ *DefaultPaperDimension: A4
+ *PaperDimension Letter/Letter (8.5 x 11"): "612 792"
+@@ -107,7 +107,7 @@
+ *PaperDimension A5/A5 (148 x 210mm): "419 595"
+ *PaperDimension B5/B5 (182 x 257mm): "516 729"
+ *PaperDimension Legal/Legal (8.5 x 14"): "612 1008"
+-*PaperDimension Ledger/Ledger (11 x 17"): "792 1224"
++*PaperDimension Tabloid/Tabloid (11 x 17"): "792 1224"
+
+ *OpenUI *FXOutputMode/Print Mode: PickOne
+ *OrderDependency: 10.0 AnySetup *FXOutputMode
diff --git a/print/cups-fxlinuxprint/pkg-descr b/print/cups-fxlinuxprint/pkg-descr
new file mode 100644
index 000000000000..842b2b9cc1a3
--- /dev/null
+++ b/print/cups-fxlinuxprint/pkg-descr
@@ -0,0 +1,12 @@
+CUPS filter and PPD file for the following Fuji Xerox printers:
+
+- ApeosPort-II C7500 / C6500 / C5400
+- DocuCentre-II C7500 / C6500 / C5400
+- ApeosPort-II C4300 / C3300 / C2200
+- DocuCentre-II C4300 / C3300 / C2200
+- ApeosPort-II 7000 / 6000 / 5000
+- DocuCentre-II 7000 / 6000 / 5000
+- ApeosPort-II 4000 / 3000
+- DocuCentre-II 4000 / 3000
+
+WWW: http://www.fujixerox.co.jp/download/apeosport/download/c4300series/linux_module.html
diff --git a/print/cups-fxlinuxprint/pkg-plist b/print/cups-fxlinuxprint/pkg-plist
new file mode 100644
index 000000000000..b2fd1dc5278c
--- /dev/null
+++ b/print/cups-fxlinuxprint/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+etc/cups/mimefx.convs
+etc/cups/mimefx.types
+libexec/cups/filter/pdftopdffx
+libexec/cups/filter/pdftopjlfx
+libexec/cups/filter/pstopdffx
+share/cups/model/FujiXerox/en/fxlinuxprint.ppd
+@dirrmtry share/cups/model/FujiXerox/en
+@dirrmtry share/cups/model/FujiXerox
+@dirrmtry share/cups/model
+@dirrmtry share/cups
+@dirrmtry etc/cups