aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-08-13 13:14:29 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-08-13 13:14:29 +0000
commite188034a3028aa734dfd1d34d760bd8c1b37db45 (patch)
tree0360e0c91086192f123fd725c8e2b63de0ce4f7f /print
parent194434eff5a7196c8d97acc98786406265e36f6b (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/p5-Font-FreeType/Makefile25
-rw-r--r--print/p5-Font-FreeType/distinfo2
-rw-r--r--print/p5-Font-FreeType/files/patch-FreeType.xs48
-rw-r--r--print/p5-Font-FreeType/files/patch-Makefile.PL13
-rw-r--r--print/p5-Font-FreeType/pkg-descr8
-rw-r--r--print/p5-Font-FreeType/pkg-plist10
7 files changed, 107 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 3f5b36aa5fda..2a7bb9549925 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -197,6 +197,7 @@
SUBDIR += nl-acroread8
SUBDIR += no-acroread8
SUBDIR += openprinting
+ SUBDIR += p5-Font-FreeType
SUBDIR += p5-Net-Printer
SUBDIR += p5-PDF-Template
SUBDIR += p5-PDFLib
diff --git a/print/p5-Font-FreeType/Makefile b/print/p5-Font-FreeType/Makefile
new file mode 100644
index 000000000000..3ea18c298ae3
--- /dev/null
+++ b/print/p5-Font-FreeType/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Font::FreeType
+# Date created: 12 Aug 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Font-FreeType
+PORTVERSION= 0.03
+CATEGORIES= print perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to read font files and render glyphs using FreeType2
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+PERL_CONFIGURE= yes
+
+MAN3= Font::FreeType.3 \
+ Font::FreeType::Face.3 \
+ Font::FreeType::Glyph.3
+
+.include <bsd.port.mk>
diff --git a/print/p5-Font-FreeType/distinfo b/print/p5-Font-FreeType/distinfo
new file mode 100644
index 000000000000..d5387b5c872d
--- /dev/null
+++ b/print/p5-Font-FreeType/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Font-FreeType-0.03.tar.gz) = c07eab16bb4d16ba61fd0a3376a8f76980245aef443d1ea193ec5446d1127d5f
+SIZE (Font-FreeType-0.03.tar.gz) = 95275
diff --git a/print/p5-Font-FreeType/files/patch-FreeType.xs b/print/p5-Font-FreeType/files/patch-FreeType.xs
new file mode 100644
index 000000000000..c3a9fee694d2
--- /dev/null
+++ b/print/p5-Font-FreeType/files/patch-FreeType.xs
@@ -0,0 +1,48 @@
+--- FreeType.xs.orig 2004-09-12 05:50:44.000000000 +0900
++++ FreeType.xs 2011-08-13 20:42:27.482201061 +0900
+@@ -226,7 +226,7 @@
+ #define QEFFT2_CALL_TIDY FREETMPS; LEAVE;
+
+ static int
+-handle_move_to (FT_Vector *to, void *data)
++handle_move_to (const FT_Vector *to, void *data)
+ {
+ struct QefFT2_Outline_Decompose_Extra_ *extra = data;
+ double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
+@@ -243,7 +243,7 @@
+ }
+
+ static int
+-handle_line_to (FT_Vector *to, void *data)
++handle_line_to (const FT_Vector *to, void *data)
+ {
+ struct QefFT2_Outline_Decompose_Extra_ *extra = data;
+ double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
+@@ -260,7 +260,7 @@
+ }
+
+ static int
+-handle_conic_to (FT_Vector *control, FT_Vector *to, void *data)
++handle_conic_to (const FT_Vector *control, const FT_Vector *to, void *data)
+ {
+ struct QefFT2_Outline_Decompose_Extra_ *extra = data;
+ double x = QEFFT2_NUM(to->x), y = QEFFT2_NUM(to->y);
+@@ -292,7 +292,7 @@
+ }
+
+ static int
+-handle_cubic_to (FT_Vector *control1, FT_Vector *control2, FT_Vector *to,
++handle_cubic_to (const FT_Vector *control1, const FT_Vector *control2, const FT_Vector *to,
+ void *data)
+ {
+ struct QefFT2_Outline_Decompose_Extra_ *extra = data;
+@@ -805,7 +805,8 @@
+ char_code = FT_Get_First_Char(face, &glyph_idx);
+ while (glyph_idx) {
+ if (glyph_idx == glyph->index) {
+- RETVAL = newSVuv((UV) glyph->char_code = char_code);
++ glyph->char_code = char_code;
++ RETVAL = newSVuv((UV) glyph->char_code);
+ break;
+ }
+ char_code = FT_Get_Next_Char(face, char_code, &glyph_idx);
diff --git a/print/p5-Font-FreeType/files/patch-Makefile.PL b/print/p5-Font-FreeType/files/patch-Makefile.PL
new file mode 100644
index 000000000000..39665842b204
--- /dev/null
+++ b/print/p5-Font-FreeType/files/patch-Makefile.PL
@@ -0,0 +1,13 @@
+--- Makefile.PL.bak 2004-09-10 09:43:29.000000000 +0900
++++ Makefile.PL 2011-08-13 21:01:55.896033332 +0900
+@@ -5,8 +5,8 @@
+ NAME => 'Font::FreeType',
+ AUTHOR => 'Geoff Richards <qef@laxan.com>',
+ VERSION_FROM => 'lib/Font/FreeType.pm',
+- LIBS => [ '-lfreetype' ],
+- INC => '-I/usr/include/freetype2',
++ LIBS => `pkg-config --libs freetype2`,
++ INC => `pkg-config --cflags freetype2`,
+ NO_META => 1,
+ );
+
diff --git a/print/p5-Font-FreeType/pkg-descr b/print/p5-Font-FreeType/pkg-descr
new file mode 100644
index 000000000000..48dcd0d550fa
--- /dev/null
+++ b/print/p5-Font-FreeType/pkg-descr
@@ -0,0 +1,8 @@
+This module allows Perl programs to conveniently read information from
+font files. All the font access is done through the FreeType2 library,
+which supports many formats. It can render images of characters with
+high-quality hinting and antialiasing, extract metrics information,
+and extract the outlines of characters in scalable formats like
+TrueType.
+
+WWW: http://search.cpan.org/dist/Font-FreeType/
diff --git a/print/p5-Font-FreeType/pkg-plist b/print/p5-Font-FreeType/pkg-plist
new file mode 100644
index 000000000000..13daebe47391
--- /dev/null
+++ b/print/p5-Font-FreeType/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Font/FreeType.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Font/FreeType/Face.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Font/FreeType/Glyph.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Font/FreeType/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Font/FreeType/FreeType.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Font/FreeType/FreeType.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Font/FreeType
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Font
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Font/FreeType
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Font