aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1999-05-23 16:16:30 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1999-05-23 16:16:30 +0000
commit653af1a830593dbfa807489ec9eafc90d7f3384e (patch)
tree5f40ca76d350aa336e77b46efe6b5b9920862ae0 /print
parent32f9d199779e55b90783dabf77feb18f2e22d841 (diff)
downloadports-653af1a830593dbfa807489ec9eafc90d7f3384e.tar.gz
ports-653af1a830593dbfa807489ec9eafc90d7f3384e.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/apsfilter/Makefile34
-rw-r--r--print/apsfilter/distinfo2
-rw-r--r--print/apsfilter/pkg-descr8
-rw-r--r--print/apsfilter/pkg-plist6
-rw-r--r--print/apsfilter6/Makefile34
-rw-r--r--print/apsfilter6/distinfo2
-rw-r--r--print/apsfilter6/pkg-descr8
-rw-r--r--print/apsfilter6/pkg-plist6
8 files changed, 70 insertions, 30 deletions
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 3011bcaf9ed1..1b0b59791656 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -3,24 +3,46 @@
# Date created: Tue Nov 14 18:29:48 MET 1995
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.24 1999/02/28 15:32:05 andreas Exp $
+# $Id: Makefile,v 1.25 1999/03/01 16:17:38 andreas Exp $
#
-DISTNAME= apsfilter-5.0.1
+DISTNAME= apsfilter-5.1.0
CATEGORIES= print
MASTER_SITES= http://www.FreeBSD.ORG/~andreas/download/
MAINTAINER= andreas@FreeBSD.ORG
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5 \
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
html2ps:${PORTSDIR}/print/html2ps \
transfig:${PORTSDIR}/print/transfig \
cjpeg:${PORTSDIR}/graphics/jpeg \
anytopnm:${PORTSDIR}/graphics/netpbm \
- bunzip2:${PORTSDIR}/archivers/bzip2
+ bunzip2:${PORTSDIR}/archivers/bzip2 \
+ recode:${PORTSDIR}/converters/recode \
+ a2ps:${PORTSDIR}/print/a2ps-letter
-NO_PACKAGE= "Too many questions"
-IS_INTERACTIVE= yes
+USE_BZIP2= yes
WRKSRC= ${WRKDIR}/apsfilter
+# make a2ps port happy in this early stage
+.if defined(BATCH)
+ @${SETENV} PAPERSIZE=a4
+.endif
+.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
+.BEGIN:
+ @${ECHO}
+ @${ECHO} "PAPERSIZE incorrect value: ${PAPERSIZE}."
+ @${ECHO}
+ @${ECHO} "Must specify PAPERSIZE as one of a4, letter, or letterdj."
+ @${ECHO} "letterdj allows a slightly larger margins for DeskJets."
+ @${FALSE}
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/apsfilter/filter
+ @touch ${PREFIX}/apsfilter/filter/.keep_me
+ @${ECHO} ">>>>> Post installation task: <<<<<"
+ @${ECHO} "Printer installation:"
+ @${ECHO} " cd ${PREFIX}/apsfilter; ./SETUP"
+
.include <bsd.port.mk>
diff --git a/print/apsfilter/distinfo b/print/apsfilter/distinfo
index c56e55da4e37..4c222aaaddea 100644
--- a/print/apsfilter/distinfo
+++ b/print/apsfilter/distinfo
@@ -1 +1 @@
-MD5 (apsfilter-5.0.1.tar.gz) = 2645c9868ee53428da6b0973749c3b79
+MD5 (apsfilter-5.1.0.tar.bz2) = b8f11794bd116f3e9ba187aa44a4f7ad
diff --git a/print/apsfilter/pkg-descr b/print/apsfilter/pkg-descr
index 0c6642fb7379..0cd68976ef02 100644
--- a/print/apsfilter/pkg-descr
+++ b/print/apsfilter/pkg-descr
@@ -1,7 +1,5 @@
Have fun using apsfilter by typing:
-
lpr ascii.Z test.gif picture.tiff TeX.dvi.gz webpage.html docu.pdf
-
That's what apsfilter is designed for ;-)
apsfilter is a magic printfilter, that saves you the work to a) look for
@@ -14,10 +12,12 @@ printcap entries and creates printcap entries for one or more of
your local printers.
New features:
+ - supports different printer resolutions (if manually configured), i.e.
+ lpr -P{low,med,high} test.ps
- supports LPRng as printer scheduler
- supports ghostscript5.x uniprint driver
- writes the first 8k of a print job to /tmp for file type
recognition, so file(1) doesn't need to be able to read from
a pipe (stdin) and rewindstadin isn't needed anymore for dvips.
-
-Have fun ! Andreas Klemm <andreas@klemm.gtn.com> Febr 1999
+Send me a postcard if you like it ! Have fun !
+ Andreas Klemm <andreas@klemm.gtn.com> Mai 1999
diff --git a/print/apsfilter/pkg-plist b/print/apsfilter/pkg-plist
index 37653359d456..3db161c588d0 100644
--- a/print/apsfilter/pkg-plist
+++ b/print/apsfilter/pkg-plist
@@ -1,16 +1,14 @@
apsfilter/SETUP
-apsfilter/SETUP.cfg
-apsfilter/bin/a2ps
apsfilter/bin/apsfilter
apsfilter/bin/setup_dvips.sh
+apsfilter/filter/.keep_me
apsfilter/global/GLOBAL.sh
-apsfilter/global/filters_found
apsfilter/setup/README
apsfilter/setup/compile
apsfilter/setup/devices.txt
apsfilter/setup/filtersetup
apsfilter/setup/mksymlinks
-apsfilter/setup/tiger.ps
+apsfilter/setup/test.ps
apsfilter/template/README
apsfilter/template/apsfilterrc
share/doc/apsfilter/FAQ
diff --git a/print/apsfilter6/Makefile b/print/apsfilter6/Makefile
index 3011bcaf9ed1..1b0b59791656 100644
--- a/print/apsfilter6/Makefile
+++ b/print/apsfilter6/Makefile
@@ -3,24 +3,46 @@
# Date created: Tue Nov 14 18:29:48 MET 1995
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.24 1999/02/28 15:32:05 andreas Exp $
+# $Id: Makefile,v 1.25 1999/03/01 16:17:38 andreas Exp $
#
-DISTNAME= apsfilter-5.0.1
+DISTNAME= apsfilter-5.1.0
CATEGORIES= print
MASTER_SITES= http://www.FreeBSD.ORG/~andreas/download/
MAINTAINER= andreas@FreeBSD.ORG
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5 \
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
html2ps:${PORTSDIR}/print/html2ps \
transfig:${PORTSDIR}/print/transfig \
cjpeg:${PORTSDIR}/graphics/jpeg \
anytopnm:${PORTSDIR}/graphics/netpbm \
- bunzip2:${PORTSDIR}/archivers/bzip2
+ bunzip2:${PORTSDIR}/archivers/bzip2 \
+ recode:${PORTSDIR}/converters/recode \
+ a2ps:${PORTSDIR}/print/a2ps-letter
-NO_PACKAGE= "Too many questions"
-IS_INTERACTIVE= yes
+USE_BZIP2= yes
WRKSRC= ${WRKDIR}/apsfilter
+# make a2ps port happy in this early stage
+.if defined(BATCH)
+ @${SETENV} PAPERSIZE=a4
+.endif
+.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
+.BEGIN:
+ @${ECHO}
+ @${ECHO} "PAPERSIZE incorrect value: ${PAPERSIZE}."
+ @${ECHO}
+ @${ECHO} "Must specify PAPERSIZE as one of a4, letter, or letterdj."
+ @${ECHO} "letterdj allows a slightly larger margins for DeskJets."
+ @${FALSE}
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/apsfilter/filter
+ @touch ${PREFIX}/apsfilter/filter/.keep_me
+ @${ECHO} ">>>>> Post installation task: <<<<<"
+ @${ECHO} "Printer installation:"
+ @${ECHO} " cd ${PREFIX}/apsfilter; ./SETUP"
+
.include <bsd.port.mk>
diff --git a/print/apsfilter6/distinfo b/print/apsfilter6/distinfo
index c56e55da4e37..4c222aaaddea 100644
--- a/print/apsfilter6/distinfo
+++ b/print/apsfilter6/distinfo
@@ -1 +1 @@
-MD5 (apsfilter-5.0.1.tar.gz) = 2645c9868ee53428da6b0973749c3b79
+MD5 (apsfilter-5.1.0.tar.bz2) = b8f11794bd116f3e9ba187aa44a4f7ad
diff --git a/print/apsfilter6/pkg-descr b/print/apsfilter6/pkg-descr
index 0c6642fb7379..0cd68976ef02 100644
--- a/print/apsfilter6/pkg-descr
+++ b/print/apsfilter6/pkg-descr
@@ -1,7 +1,5 @@
Have fun using apsfilter by typing:
-
lpr ascii.Z test.gif picture.tiff TeX.dvi.gz webpage.html docu.pdf
-
That's what apsfilter is designed for ;-)
apsfilter is a magic printfilter, that saves you the work to a) look for
@@ -14,10 +12,12 @@ printcap entries and creates printcap entries for one or more of
your local printers.
New features:
+ - supports different printer resolutions (if manually configured), i.e.
+ lpr -P{low,med,high} test.ps
- supports LPRng as printer scheduler
- supports ghostscript5.x uniprint driver
- writes the first 8k of a print job to /tmp for file type
recognition, so file(1) doesn't need to be able to read from
a pipe (stdin) and rewindstadin isn't needed anymore for dvips.
-
-Have fun ! Andreas Klemm <andreas@klemm.gtn.com> Febr 1999
+Send me a postcard if you like it ! Have fun !
+ Andreas Klemm <andreas@klemm.gtn.com> Mai 1999
diff --git a/print/apsfilter6/pkg-plist b/print/apsfilter6/pkg-plist
index 37653359d456..3db161c588d0 100644
--- a/print/apsfilter6/pkg-plist
+++ b/print/apsfilter6/pkg-plist
@@ -1,16 +1,14 @@
apsfilter/SETUP
-apsfilter/SETUP.cfg
-apsfilter/bin/a2ps
apsfilter/bin/apsfilter
apsfilter/bin/setup_dvips.sh
+apsfilter/filter/.keep_me
apsfilter/global/GLOBAL.sh
-apsfilter/global/filters_found
apsfilter/setup/README
apsfilter/setup/compile
apsfilter/setup/devices.txt
apsfilter/setup/filtersetup
apsfilter/setup/mksymlinks
-apsfilter/setup/tiger.ps
+apsfilter/setup/test.ps
apsfilter/template/README
apsfilter/template/apsfilterrc
share/doc/apsfilter/FAQ