aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-02-19 09:45:12 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-02-19 09:45:12 +0000
commitca1dfc7551f89e60a6546fdda5c4e0d5d34b5f08 (patch)
tree85a361cbccc984551b8312aa169dab5267e0a20d /print
parent6d825805a5d2bfc72ba6b91fc7b8ec3d2c7a5b4a (diff)
downloadports-ca1dfc7551f89e60a6546fdda5c4e0d5d34b5f08.tar.gz
ports-ca1dfc7551f89e60a6546fdda5c4e0d5d34b5f08.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/texinfo/Makefile7
-rw-r--r--print/texinfo/distinfo4
-rw-r--r--print/texinfo/files/patch-doc::Makefile.in24
-rw-r--r--print/texinfo/files/patch-install-info_install-info.c20
-rw-r--r--print/texinfo/pkg-plist39
5 files changed, 61 insertions, 33 deletions
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index 2dd487e4d809..a16286da4bbc 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= texinfo
-PORTVERSION= 4.13.20130118
+PORTVERSION= 5.0.20130217
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.stack.nl/pub/users/johans/texinfo/${PORTVERSION:E}/
@@ -19,18 +19,19 @@ BUILD_DEPENDS+= help2man:${PORTSDIR}/misc/help2man
FETCH_ARGS= -Ap
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_XZ= yes
INSTALL_TARGET= install install-tex
PKGDEINSTALL= ${PKGINSTALL}
MAKE_JOBS_SAFE= yes
+PORTDATA= *
MAKE_ARGS= TEXMF=${PREFIX}/${TEXMF}
-CONFIGURE_ARGS= --without-included-gettext
CPPFLAGS+= -I${LOCALBASE}/lib
LDFLAGS+= -L${LOCALBASE}/lib -lintl
INFO= ${PORTNAME} info-stnd info
MAN1= info.1 infokey.1 install-info.1 makeinfo.1 texi2dvi.1 \
- texi2pdf.1 pdftexi2dvi.1 texindex.1
+ texi2pdf.1 pdftexi2dvi.1 pod2texi.1 texi2any.1 texindex.1
MAN5= info.5 texinfo.5
TEXMF= share/texmf
diff --git a/print/texinfo/distinfo b/print/texinfo/distinfo
index e5035aeafb1a..e11fe436dff0 100644
--- a/print/texinfo/distinfo
+++ b/print/texinfo/distinfo
@@ -1,5 +1,5 @@
-SHA256 (texinfo-4.13.tar.gz) = 1303e91a1c752b69a32666a407e9fbdd6e936def4b09bc7de30f416301530d68
-SIZE (texinfo-4.13.tar.gz) = 2751071
+SHA256 (texinfo-5.0.tar.xz) = 8ade50b9bd846448e00c89eda1e0f8f51e49b13017c8379991eebd04917164dc
+SIZE (texinfo-5.0.tar.xz) = 3782636
SHA256 (htmlxref.cnf) = a2dddbfbefc3664e60b648ca248242dd0556b6f041214ad3ebf2afb3378009ae
SIZE (htmlxref.cnf) = 18905
SHA256 (texinfo.tex) = 081a132fe3ddff623b55ea9719a7da9677f81e67a02a39bbd21c575bafdc830c
diff --git a/print/texinfo/files/patch-doc::Makefile.in b/print/texinfo/files/patch-doc::Makefile.in
index 51ea73b2db43..2a719a6e8ad9 100644
--- a/print/texinfo/files/patch-doc::Makefile.in
+++ b/print/texinfo/files/patch-doc::Makefile.in
@@ -1,29 +1,29 @@
---- doc/Makefile.in.orig 2011-02-03 19:34:53.000000000 +0000
-+++ doc/Makefile.in 2011-02-03 19:35:33.000000000 +0000
-@@ -121,7 +121,7 @@
- CONFIG_CLEAN_FILES =
- SOURCES =
- DIST_SOURCES =
+--- doc/Makefile.in.orig 2013-02-16 18:23:15.000000000 +0100
++++ doc/Makefile.in 2013-02-19 09:15:24.000000000 +0100
+@@ -209,7 +209,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@
+ am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
+ am__v_texidevnull_0 = > /dev/null
+ am__v_texidevnull_1 =
-INFO_DEPS = texinfo info-stnd.info info.info
+INFO_DEPS = texinfo.info info-stnd.info info.info
TEXINFO_TEX = $(top_srcdir)/build-aux/texinfo.tex
am__TEXINFO_TEX_DIR = $(top_srcdir)/build-aux
DVIS = texinfo.dvi info-stnd.dvi info.dvi
-@@ -436,7 +436,7 @@
+@@ -1002,7 +1002,7 @@ SUBDIRS = tp_api
# Put texinfo.txi first because that's the most important.
info_TEXINFOS = texinfo.txi info-stnd.texi info.texi
-DISTCLEANFILES = texinfo texinfo-* info*.info*
+DISTCLEANFILES = texinfo.info texinfo-* info*.info*
- man_MANS = info.1 infokey.1 install-info.1 makeinfo.1 texindex.1 \
- info.5 texinfo.5 texi2dvi.1 texi2pdf.1 pdftexi2dvi.1
-@@ -526,7 +526,7 @@
- $(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
+ # Use the programs built in our distribution, taking account of possible
+ # cross-compiling.
+@@ -1090,7 +1090,7 @@ $(ACLOCAL_M4): $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+ $(am__aclocal_m4_deps):
-texinfo: texinfo.txi $(srcdir)/version.texi
+texinfo.info: texinfo.txi $(srcdir)/version.texi
- restore=: && backupdir="$(am__leading_dot)am$$$$" && \
+ $(AM_V_MAKEINFO)restore=: && backupdir="$(am__leading_dot)am$$$$" && \
rm -rf $$backupdir && mkdir $$backupdir && \
if ($(MAKEINFO) --version) >/dev/null 2>&1; then \
diff --git a/print/texinfo/files/patch-install-info_install-info.c b/print/texinfo/files/patch-install-info_install-info.c
index ebf7784c227f..c9252d8193ad 100644
--- a/print/texinfo/files/patch-install-info_install-info.c
+++ b/print/texinfo/files/patch-install-info_install-info.c
@@ -1,6 +1,6 @@
---- install-info/install-info.c.orig 2011-02-03 21:48:38.000000000 +0000
-+++ install-info/install-info.c 2011-02-03 21:56:15.000000000 +0000
-@@ -25,6 +25,7 @@
+--- install-info/install-info.c.orig 2013-01-07 00:18:56.000000000 +0100
++++ install-info/install-info.c 2013-02-19 09:15:24.000000000 +0100
+@@ -26,6 +26,7 @@
#define TAB_WIDTH 8
static char *progname = "install-info";
@@ -8,7 +8,7 @@
struct spec_entry;
struct spec_section;
-@@ -145,6 +146,8 @@
+@@ -146,6 +147,8 @@ struct option longopts[] =
{ "calign", required_argument, NULL, 'C'},
{ "debug", no_argument, NULL, 'g' },
{ "delete", no_argument, NULL, 'r' },
@@ -17,7 +17,7 @@
{ "dir-file", required_argument, NULL, 'd' },
{ "entry", required_argument, NULL, 'e' },
{ "name", required_argument, NULL, 't' },
-@@ -515,6 +518,10 @@
+@@ -543,6 +546,10 @@ Options:\n\
--debug report what is being done.\n\
--delete delete existing entries for INFO-FILE from DIR-FILE;\n\
don't insert any new entries.\n\
@@ -28,7 +28,7 @@
--description=TEXT the description of the entry is TEXT; used with\n\
the --name option to become synonymous with the\n\
--entry option.\n\
-@@ -1814,6 +1821,8 @@
+@@ -1857,6 +1864,8 @@ main (int argc, char *argv[])
struct spec_entry *entries_to_add = NULL;
struct spec_entry *entries_to_add_from_file = NULL;
int n_entries_to_add = 0;
@@ -37,7 +37,7 @@
/* Record the old text of the dir file, as plain characters,
as lines, and as nodes. */
-@@ -1998,6 +2007,7 @@
+@@ -2041,6 +2050,7 @@ main (int argc, char *argv[])
}
break;
@@ -45,7 +45,7 @@
case 'e':
{
struct spec_entry *next
-@@ -2012,12 +2022,18 @@
+@@ -2055,12 +2065,18 @@ main (int argc, char *argv[])
next->text_len = olen;
next->entry_sections = NULL;
next->entry_sections_tail = NULL;
@@ -67,7 +67,7 @@
}
break;
-@@ -2084,6 +2100,10 @@
+@@ -2127,6 +2143,10 @@ main (int argc, char *argv[])
}
break;
@@ -78,7 +78,7 @@
case 's':
{
struct spec_section *next
-@@ -2273,7 +2293,7 @@
+@@ -2315,7 +2335,7 @@ There is NO WARRANTY, to the extent perm
{
input_sections = (struct spec_section *)
xmalloc (sizeof (struct spec_section));
diff --git a/print/texinfo/pkg-plist b/print/texinfo/pkg-plist
index af28e4c05026..9f074db836ef 100644
--- a/print/texinfo/pkg-plist
+++ b/print/texinfo/pkg-plist
@@ -2,45 +2,61 @@ bin/info
bin/infokey
bin/install-info
bin/makeinfo
+bin/pdftexi2dvi
+bin/pod2texi
+bin/texi2any
bin/texi2dvi
bin/texi2pdf
bin/texindex
-bin/pdftexi2dvi
%%NLS%%share/locale/cs/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/da/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/de.us-ascii/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/de/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/de_AT/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/eo/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/texinfo_document.mo
+%%NLS%%share/locale/es.us-ascii/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/es/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/fr.us-ascii/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/fr/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/he/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/hr/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/hu/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/texinfo_document.mo
+%%NLS%%share/locale/id/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/it/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/it/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/ja/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/nb/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/nl/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/texinfo_document.mo
+%%NLS%%share/locale/no.us-ascii/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/pl/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/texinfo_document.mo
+%%NLS%%share/locale/pt.us-ascii/LC_MESSAGES/texinfo_document.mo
+%%NLS%%share/locale/pt_BR.us-ascii/LC_MESSAGES/texinfo_document.mo
%%NLS%%share/locale/ro/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/ru/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/rw/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/sv/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/tr/LC_MESSAGES/texinfo.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/vi/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/texinfo.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/texinfo.mo
-%%DATADIR%%/htmlxref.cnf
-%%DATADIR%%/texinfo.cat
-%%DATADIR%%/texinfo.dtd
-%%DATADIR%%/texinfo.xsl
%%TEXMF%%/tex/texinfo/texinfo.tex
%%TEXMF%%/tex/texinfo/txi-cs.tex
%%TEXMF%%/tex/texinfo/txi-de.tex
%%TEXMF%%/tex/texinfo/txi-en.tex
%%TEXMF%%/tex/texinfo/txi-es.tex
%%TEXMF%%/tex/texinfo/txi-fr.tex
+%%TEXMF%%/tex/texinfo/txi-hu.tex
+%%TEXMF%%/tex/texinfo/txi-is.tex
%%TEXMF%%/tex/texinfo/txi-it.tex
%%TEXMF%%/tex/texinfo/txi-nb.tex
%%TEXMF%%/tex/texinfo/txi-nl.tex
+%%TEXMF%%/tex/texinfo/txi-nn.tex
%%TEXMF%%/tex/texinfo/txi-pl.tex
%%TEXMF%%/tex/texinfo/txi-pt.tex
%%TEXMF%%/tex/texinfo/txi-ru.tex
@@ -50,9 +66,20 @@ bin/pdftexi2dvi
%%TEXMF%%/tex/generic/epsf/epsf.tex
%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/rw
+%%NLS%%@dirrmtry share/locale/de.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de.us-ascii
+%%NLS%%@dirrmtry share/locale/es.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es.us-ascii
+%%NLS%%@dirrmtry share/locale/fr.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fr.us-ascii
+%%NLS%%@dirrmtry share/locale/no.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/no.us-ascii
+%%NLS%%@dirrmtry share/locale/pt.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt.us-ascii
+%%NLS%%@dirrmtry share/locale/pt_BR.us-ascii/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt_BR.us-ascii
@dirrmtry %%TEXMF%%/tex/generic/epsf
@dirrmtry %%TEXMF%%/tex/generic
@dirrm %%TEXMF%%/tex/texinfo
@dirrmtry %%TEXMF%%/tex
@dirrmtry %%TEXMF%%
-@dirrm %%DATADIR%%