aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-11-15 19:47:39 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-11-15 19:47:39 +0000
commit8283258585cdd12014a3b755e49dbbb769dc0edc (patch)
treee6283d2296153b4d013a5309de89eb5227acb6db /print
parent46def6eeb55bd10834ec52259fdef66151523d04 (diff)
downloadports-8283258585cdd12014a3b755e49dbbb769dc0edc.tar.gz
ports-8283258585cdd12014a3b755e49dbbb769dc0edc.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/ruby-gnomeprint/Makefile46
-rw-r--r--print/ruby-gnomeprint/pkg-descr3
-rw-r--r--print/ruby-gnomeprint/pkg-plist12
4 files changed, 62 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 7cc3e24b9fa7..40c0e9aff60f 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -234,6 +234,7 @@
SUBDIR += rprint
SUBDIR += rtf2latex
SUBDIR += ruby-clibpdf
+ SUBDIR += ruby-gnomeprint
SUBDIR += ruby-panda
SUBDIR += ruby-pdflib
SUBDIR += scribus
diff --git a/print/ruby-gnomeprint/Makefile b/print/ruby-gnomeprint/Makefile
new file mode 100644
index 000000000000..f75fcf999343
--- /dev/null
+++ b/print/ruby-gnomeprint/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: Ruby/GnomePrint
+# Date created: 15 November 2004
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomeprint
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= print ruby gnome
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= Ruby binding for libgnomeprint
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2 \
+ ${RUBY_SITEARCHLIBDIR}/libart2.so:${PORTSDIR}/graphics/ruby-libart2 \
+ ${RUBY_SITEARCHLIBDIR}/pango.so:${PORTSDIR}/x11-toolkits/ruby-pango
+
+USE_RUBY= yes
+USE_GNOME= libgnomeprint
+USE_RUBY_EXTCONF= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/gnomeprint
+INSTALL_TARGET= site-install
+
+DOCS= COPYING.LIB ChangeLog README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
+ @${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/ruby-gnomeprint/pkg-descr b/print/ruby-gnomeprint/pkg-descr
new file mode 100644
index 000000000000..1473e3ba569a
--- /dev/null
+++ b/print/ruby-gnomeprint/pkg-descr
@@ -0,0 +1,3 @@
+Ruby/GnomePrint is a Ruby binding of libgnomeprint.
+
+WWW: http://ruby-gnome2.sourceforge.jp/
diff --git a/print/ruby-gnomeprint/pkg-plist b/print/ruby-gnomeprint/pkg-plist
new file mode 100644
index 000000000000..a15f05f88d70
--- /dev/null
+++ b/print/ruby-gnomeprint/pkg-plist
@@ -0,0 +1,12 @@
+%%RUBY_SITEARCHLIBDIR%%/gnomeprint2.so
+%%RUBY_SITELIBDIR%%/gnomeprint2.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ruby-gnome2-logo.png
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/run-test.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_context.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_return_code.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/to_file.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/COPYING.LIB
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%