aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-01 19:23:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-01 19:23:45 +0000
commit35beb41626b96830c5c059bbef88964baf4436d9 (patch)
treec7b3f8308d5734599a8da2117ff8e59811b140d8 /print
parent32cc6ea8aa3cb068f6cedd1fab94b4062d927ebc (diff)
downloadports-35beb41626b96830c5c059bbef88964baf4436d9.tar.gz
ports-35beb41626b96830c5c059bbef88964baf4436d9.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 701066b8637b..60caf7b60e5b 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cups
PORTVERSION= 1.4.2
DISTVERSIONSUFFIX= -source
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
@@ -35,7 +35,8 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-docdir=${DOCSDIR} \
--with-icondir=${PREFIX}/share/icons \
--with-menudir=${DESKTOPDIR} \
- --with-domainsocket=${CUPS_SOCKET}
+ --with-domainsocket=${CUPS_SOCKET} \
+ --enable-ssl
OPTIONS?= GNUTLS "Build with GNUTLS library" on \
PHP "Build PHP support" off \
@@ -98,8 +99,10 @@ PLIST_SUB+= OVERWRITE="@comment "
.endif
.if !defined(WITHOUT_GNUTLS)
-CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
+CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
+CONFIGURE_ENV+= PKGCONFIG="${LOCALBASE}/bin/pkg-config"
LIB_DEPENDS+= gnutls-openssl.40:${PORTSDIR}/security/gnutls
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.else
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
.include "${PORTSDIR}/Mk/bsd.openssl.mk"