aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2020-06-24 10:22:14 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2020-06-24 10:22:14 +0000
commit579b2e1c6b5d8889ec2f4323d7b5a83e2eb5b238 (patch)
tree88607e9c3d961ee3242a86e195eae636c88f10ef /print
parent97bc1c72cf62adf26a1b597c62e319a572a7a98f (diff)
downloadports-579b2e1c6b5d8889ec2f4323d7b5a83e2eb5b238.tar.gz
ports-579b2e1c6b5d8889ec2f4323d7b5a83e2eb5b238.zip
Update to 2.3.3.
Notes
Notes: svn path=/head/; revision=540023
Diffstat (limited to 'print')
-rw-r--r--print/cups/Makefile10
-rw-r--r--print/cups/distinfo6
-rw-r--r--print/cups/files/patch-backend_socket.c12
-rw-r--r--print/cups/files/patch-configure10
-rw-r--r--print/cups/files/patch-cups-config.in11
-rw-r--r--print/cups/files/patch-cups-getifaddrs-internal.h10
-rw-r--r--print/cups/files/patch-scheduler_client.c13
-rw-r--r--print/cups/pkg-plist104
8 files changed, 80 insertions, 96 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
index 99f8b7f3bfd1..9f7dc7861223 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -2,17 +2,15 @@
# $FreeBSD$
PORTNAME= cups
-PORTVERSION= 2.2.13
+PORTVERSION= 2.3.3
DISTVERSIONPREFIX=v
CATEGORIES= print
MAINTAINER= tijl@FreeBSD.org
COMMENT= Common UNIX Printing System
-LICENSE= GPLv2 LGPL20
-LICENSE_COMB= multi
-LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE.txt
-LICENSE_FILE_LGPL20= ${WRKSRC}/LICENSE.txt
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS= LPRng-[0-9]*
@@ -103,7 +101,7 @@ post-patch:
's|http://www.cups.org|https://www.cups.org|g' {} +
@${REINPLACE_CMD} '/stripopt=/s/-x//' ${WRKSRC}/install-sh
@${REINPLACE_CMD} 's|/etc/cups|${LOCALBASE}/etc/cups|g' \
- ${WRKSRC}/man/*.man*
+ ${WRKSRC}/man/*.[1-9]
@${REINPLACE_CMD} -e 's|\.default|.sample|'\
${WRKSRC}/cgi-bin/admin.c\
${WRKSRC}/conf/Makefile
diff --git a/print/cups/distinfo b/print/cups/distinfo
index ab1d3b7d6658..c4c7696c33c0 100644
--- a/print/cups/distinfo
+++ b/print/cups/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583176289
-SHA256 (apple-cups-v2.2.13_GH0.tar.gz) = 153fe8c8c09883a5787b13401692ee22820df9d3324956c58ae8a8192e9b3ad1
-SIZE (apple-cups-v2.2.13_GH0.tar.gz) = 10372757
+TIMESTAMP = 1592051307
+SHA256 (apple-cups-v2.3.3_GH0.tar.gz) = fe298713aad0cbb861de24760f140851122caae9f34d480dbfff0bd9211d961a
+SIZE (apple-cups-v2.3.3_GH0.tar.gz) = 8146552
diff --git a/print/cups/files/patch-backend_socket.c b/print/cups/files/patch-backend_socket.c
index 43da873b41fc..813307896c3b 100644
--- a/print/cups/files/patch-backend_socket.c
+++ b/print/cups/files/patch-backend_socket.c
@@ -1,6 +1,6 @@
---- backend/socket.c.orig 2014-06-09 18:35:32 UTC
+--- backend/socket.c.orig 2020-04-27 18:04:29 UTC
+++ backend/socket.c
-@@ -316,7 +316,6 @@ main(int argc, /* I - Number of comm
+@@ -292,7 +292,6 @@ main(int argc, /* I - Number of command-line argum
*/
fprintf(stderr, "DEBUG: Connecting to %s:%d\n", hostname, port);
@@ -8,7 +8,7 @@
for (delay = 5;;)
{
-@@ -397,7 +396,6 @@ main(int argc, /* I - Number of comm
+@@ -372,7 +371,6 @@ main(int argc, /* I - Number of command-line argum
}
fputs("STATE: -connecting-to-device\n", stderr);
@@ -16,8 +16,8 @@
fprintf(stderr, "DEBUG: Connected to %s:%d...\n",
httpAddrString(&(addr->addr), addrname, sizeof(addrname)),
-@@ -426,7 +424,7 @@ main(int argc, /* I - Number of comm
- 0, backendNetworkSideCB);
+@@ -403,7 +401,7 @@ main(int argc, /* I - Number of command-line argum
+ tbytes = bytes;
if (print_fd != 0 && tbytes >= 0)
- _cupsLangPrintFilter(stderr, "INFO", _("Print file sent."));
@@ -25,7 +25,7 @@
}
fputs("STATE: +cups-waiting-for-job-completed\n", stderr);
-@@ -437,7 +435,7 @@ main(int argc, /* I - Number of comm
+@@ -414,7 +412,7 @@ main(int argc, /* I - Number of command-line argum
* Shutdown the socket and wait for the other end to finish...
*/
diff --git a/print/cups/files/patch-configure b/print/cups/files/patch-configure
index 2ff633527922..331f120f9ce8 100644
--- a/print/cups/files/patch-configure
+++ b/print/cups/files/patch-configure
@@ -1,14 +1,14 @@
---- configure.orig 2018-03-23 03:48:36 UTC
+--- configure.orig 2020-04-27 18:04:29 UTC
+++ configure
-@@ -5827,7 +5827,6 @@ if test "${with_dbusdir+set}" = set; then :
+@@ -5775,7 +5775,6 @@ fi
fi
-
+ LIBS="$SAVELIBS"
-DBUSDIR=""
DBUS_NOTIFIER=""
DBUS_NOTIFIERLIBS=""
-@@ -6688,7 +6687,6 @@ if test "$DSO" != ":"; then
+@@ -6590,7 +6589,6 @@ if test "$DSO" != ":"; then
if test $exec_prefix != /usr; then
DSOFLAGS="-Wl,-R$libdir $DSOFLAGS"
LDFLAGS="$LDFLAGS -Wl,-R$libdir"
@@ -16,7 +16,7 @@
fi
;;
linux* | gnu*)
-@@ -8802,13 +8800,7 @@ fi
+@@ -8560,13 +8558,7 @@ fi
PAMLIBS="-lpam"
fi
diff --git a/print/cups/files/patch-cups-config.in b/print/cups/files/patch-cups-config.in
deleted file mode 100644
index 214a4128e7ac..000000000000
--- a/print/cups/files/patch-cups-config.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- cups-config.in.orig 2013-05-29 11:51:34 UTC
-+++ cups-config.in
-@@ -105,7 +105,7 @@ while test $# -gt 0; do
- ;;
- --libs)
- if test $static = no; then
-- libs="@EXTLINKCUPS@ $LIBS";
-+ libs="@EXTLINKCUPS@";
- if test $image = yes; then
- libs="@EXTLINKCUPSIMAGE@ $libs"
- fi
diff --git a/print/cups/files/patch-cups-getifaddrs-internal.h b/print/cups/files/patch-cups-getifaddrs-internal.h
new file mode 100644
index 000000000000..d40d654d573a
--- /dev/null
+++ b/print/cups/files/patch-cups-getifaddrs-internal.h
@@ -0,0 +1,10 @@
+--- cups/getifaddrs-internal.h.orig 2020-04-27 18:04:29 UTC
++++ cups/getifaddrs-internal.h
+@@ -39,6 +39,7 @@ typedef int socklen_t;
+
+ # ifndef _WIN32
+ # include <net/if.h>
++# include <netinet/in.h>
+ # include <resolv.h>
+ # ifdef HAVE_GETIFADDRS
+ # include <ifaddrs.h>
diff --git a/print/cups/files/patch-scheduler_client.c b/print/cups/files/patch-scheduler_client.c
deleted file mode 100644
index a5b6b0ac848d..000000000000
--- a/print/cups/files/patch-scheduler_client.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- scheduler/client.c.orig 2016-10-03 19:55:40 UTC
-+++ scheduler/client.c
-@@ -3818,8 +3818,8 @@ pipe_command(cupsd_client_t *con, /* I -
- * Then execute the command...
- */
-
-- if (cupsdStartProcess(command, argv, envp, infile, fds[1], CGIPipes[1],
-- -1, -1, root, DefaultProfile, NULL, &pid) < 0)
-+ if (!cupsdStartProcess(command, argv, envp, infile, fds[1], CGIPipes[1],
-+ -1, -1, root, DefaultProfile, NULL, &pid))
- {
- /*
- * Error - can't fork!
diff --git a/print/cups/pkg-plist b/print/cups/pkg-plist
index db724a3a5846..d20d70f87500 100644
--- a/print/cups/pkg-plist
+++ b/print/cups/pkg-plist
@@ -10,8 +10,8 @@
%%OVERWRITE%%@postunexec if test -e /usr/sbin/lpc; then chmod -h 02555 /usr/sbin/lpc; fi
bin/cancel
bin/cups-config
-bin/cupstestdsc
bin/cupstestppd
+bin/ippeveprinter
%%AVAHI%%bin/ippfind
%%IPPTOOL%%bin/ipptool
bin/lp
@@ -51,6 +51,7 @@ lib/libcups.so
lib/libcups.so.2
lib/libcupsimage.so
lib/libcupsimage.so.2
+%%AVAHI%%libexec/cups/backend/dnssd
libexec/cups/backend/http
%%GNUTLS%%libexec/cups/backend/https
libexec/cups/backend/ipp
@@ -59,12 +60,13 @@ libexec/cups/backend/lpd
libexec/cups/backend/snmp
libexec/cups/backend/socket
%%USB%%libexec/cups/backend/usb
-%%AVAHI%%libexec/cups/backend/dnssd
libexec/cups/cgi-bin/admin.cgi
libexec/cups/cgi-bin/classes.cgi
libexec/cups/cgi-bin/help.cgi
libexec/cups/cgi-bin/jobs.cgi
libexec/cups/cgi-bin/printers.cgi
+libexec/cups/command/ippevepcl
+libexec/cups/command/ippeveps
libexec/cups/daemon/cups-deviced
libexec/cups/daemon/cups-driverd
libexec/cups/daemon/cups-exec
@@ -72,7 +74,6 @@ libexec/cups/daemon/cups-lpd
libexec/cups/filter/commandtops
libexec/cups/filter/gziptoany
libexec/cups/filter/pstops
-libexec/cups/filter/rastertodymo
libexec/cups/filter/rastertoepson
libexec/cups/filter/rastertohp
libexec/cups/filter/rastertolabel
@@ -84,9 +85,9 @@ libexec/cups/notifier/mailto
libexec/cups/notifier/rss
man/man1/cancel.1.gz
man/man1/cups-config.1.gz
-man/man1/cupstestdsc.1.gz
-man/man1/cupstestppd.1.gz
man/man1/cups.1.gz
+man/man1/cupstestppd.1.gz
+man/man1/ippeveprinter.1.gz
%%AVAHI%%man/man1/ippfind.1.gz
%%IPPTOOL%%man/man1/ipptool.1.gz
man/man1/lp.1.gz
@@ -115,17 +116,17 @@ man/man5/printers.conf.5.gz
man/man5/subscriptions.conf.5.gz
man/man7/backend.7.gz
man/man7/filter.7.gz
+man/man7/ippevepcl.7.gz
+man/man7/ippeveps.7.gz
man/man7/notifier.7.gz
-man/man8/accept.8.gz
-man/man8/cupsd-helper.8.gz
man/man8/cups-deviced.8.gz
-man/man8/cups-exec.8.gz
man/man8/cups-driverd.8.gz
+man/man8/cups-exec.8.gz
man/man8/cups-lpd.8.gz
man/man8/cups-snmp.8.gz
man/man8/cupsaccept.8.gz
-man/man8/cupsaddsmb.8.gz
man/man8/cupsctl.8.gz
+man/man8/cupsd-helper.8.gz
man/man8/cupsd.8.gz
man/man8/cupsdisable.8.gz
man/man8/cupsenable.8.gz
@@ -135,10 +136,7 @@ man/man8/lpadmin.8.gz
man/man8/lpc.8.gz
man/man8/lpinfo.8.gz
man/man8/lpmove.8.gz
-man/man8/reject.8.gz
-sbin/accept
sbin/cupsaccept
-sbin/cupsaddsmb
sbin/cupsctl
sbin/cupsd
sbin/cupsdisable
@@ -149,7 +147,6 @@ sbin/lpadmin
sbin/lpc
sbin/lpinfo
sbin/lpmove
-sbin/reject
%%X11%%share/applications/cups.desktop
%%DATADIR%%/drv/sample.drv
%%DATADIR%%/examples/color.drv
@@ -163,30 +160,66 @@ sbin/reject
%%DATADIR%%/examples/r300-basic.drv
%%DATADIR%%/examples/r300-colorman.drv
%%DATADIR%%/examples/r300-remote.drv
+%%IPPTOOL%%%%DATADIR%%/ipptool/cancel-current-job.test
%%IPPTOOL%%%%DATADIR%%/ipptool/color.jpg
+%%IPPTOOL%%%%DATADIR%%/ipptool/create-job-format.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/create-job-sheets.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/create-job-timeout.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/create-job.test
%%IPPTOOL%%%%DATADIR%%/ipptool/create-printer-subscription.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/cups-create-local-printer.test
%%IPPTOOL%%%%DATADIR%%/ipptool/document-a4.pdf
%%IPPTOOL%%%%DATADIR%%/ipptool/document-a4.ps
%%IPPTOOL%%%%DATADIR%%/ipptool/document-letter.pdf
%%IPPTOOL%%%%DATADIR%%/ipptool/document-letter.ps
+%%IPPTOOL%%%%DATADIR%%/ipptool/fax-job.test
%%IPPTOOL%%%%DATADIR%%/ipptool/get-completed-jobs.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-devices.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-job-attributes.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-job-attributes2.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-job-template-attributes.test
%%IPPTOOL%%%%DATADIR%%/ipptool/get-jobs.test
%%IPPTOOL%%%%DATADIR%%/ipptool/get-notifications.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppd-printer.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppd.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-drv-only.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-language.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-make-and-model.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-make.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-product.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds-psversion.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-ppds.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-printer-attributes-suite.test
%%IPPTOOL%%%%DATADIR%%/ipptool/get-printer-attributes.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-printer-description-attributes.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-printers-printer-id.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/get-printers.test
%%IPPTOOL%%%%DATADIR%%/ipptool/get-subscriptions.test
%%IPPTOOL%%%%DATADIR%%/ipptool/gray.jpg
+%%IPPTOOL%%%%DATADIR%%/ipptool/identify-printer-display.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/identify-printer-multiple.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/identify-printer.test
%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-1.1.test
%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-2.0.test
%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-2.1.test
%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-2.2.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-backend.test
%%IPPTOOL%%%%DATADIR%%/ipptool/ipp-everywhere.test
%%IPPTOOL%%%%DATADIR%%/ipptool/onepage-a4.pdf
%%IPPTOOL%%%%DATADIR%%/ipptool/onepage-a4.ps
%%IPPTOOL%%%%DATADIR%%/ipptool/onepage-letter.pdf
%%IPPTOOL%%%%DATADIR%%/ipptool/onepage-letter.ps
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-and-wait.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-deflate.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-gzip.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-hold.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-letter.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-manual.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-media-col.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-job-password.test
%%IPPTOOL%%%%DATADIR%%/ipptool/print-job.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/print-uri.test
+%%IPPTOOL%%%%DATADIR%%/ipptool/set-attrs-hold.test
%%IPPTOOL%%%%DATADIR%%/ipptool/testfile.jpg
%%IPPTOOL%%%%DATADIR%%/ipptool/testfile.pcl
%%IPPTOOL%%%%DATADIR%%/ipptool/testfile.pdf
@@ -203,7 +236,6 @@ sbin/reject
%%DATADIR%%/ppdc/raster.defs
%%DATADIR%%/templates/add-class.tmpl
%%DATADIR%%/templates/add-printer.tmpl
-%%DATADIR%%/templates/add-rss-subscription.tmpl
%%DATADIR%%/templates/admin.tmpl
%%DATADIR%%/templates/choose-device.tmpl
%%DATADIR%%/templates/choose-make.tmpl
@@ -221,7 +253,6 @@ sbin/reject
%%DATADIR%%/templates/command.tmpl
%%NLS%%%%DATADIR%%/templates/de/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/de/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/de/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/de/admin.tmpl
%%NLS%%%%DATADIR%%/templates/de/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/de/choose-make.tmpl
@@ -279,13 +310,9 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/de/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/de/printers.tmpl
%%NLS%%%%DATADIR%%/templates/de/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/de/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/de/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/de/search.tmpl
%%NLS%%%%DATADIR%%/templates/de/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/de/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/de/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/de/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/de/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/de/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/de/users.tmpl
@@ -294,7 +321,6 @@ sbin/reject
%%DATADIR%%/templates/error.tmpl
%%NLS%%%%DATADIR%%/templates/es/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/es/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/es/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/es/admin.tmpl
%%NLS%%%%DATADIR%%/templates/es/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/es/choose-make.tmpl
@@ -352,19 +378,14 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/es/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/es/printers.tmpl
%%NLS%%%%DATADIR%%/templates/es/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/es/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/es/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/es/search.tmpl
%%NLS%%%%DATADIR%%/templates/es/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/es/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/es/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/es/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/es/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/es/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/es/users.tmpl
%%NLS%%%%DATADIR%%/templates/fr/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/fr/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/fr/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/fr/admin.tmpl
%%NLS%%%%DATADIR%%/templates/fr/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/fr/choose-make.tmpl
@@ -422,13 +443,9 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/fr/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/fr/printers.tmpl
%%NLS%%%%DATADIR%%/templates/fr/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/fr/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/fr/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/fr/search.tmpl
%%NLS%%%%DATADIR%%/templates/fr/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/fr/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/fr/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/fr/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/fr/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/fr/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/fr/users.tmpl
@@ -438,7 +455,6 @@ sbin/reject
%%DATADIR%%/templates/help-trailer.tmpl
%%NLS%%%%DATADIR%%/templates/ja/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/ja/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/ja/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/ja/admin.tmpl
%%NLS%%%%DATADIR%%/templates/ja/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/ja/choose-make.tmpl
@@ -496,13 +512,9 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/ja/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/ja/printers.tmpl
%%NLS%%%%DATADIR%%/templates/ja/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/ja/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/ja/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/ja/search.tmpl
%%NLS%%%%DATADIR%%/templates/ja/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/ja/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/ja/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/ja/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/ja/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/ja/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/ja/users.tmpl
@@ -542,7 +554,6 @@ sbin/reject
%%DATADIR%%/templates/printers.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/pt_BR/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/admin.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/choose-make.tmpl
@@ -600,20 +611,15 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/pt_BR/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/printers.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/pt_BR/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/pt_BR/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/search.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/pt_BR/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/pt_BR/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/pt_BR/users.tmpl
%%DATADIR%%/templates/restart.tmpl
%%NLS%%%%DATADIR%%/templates/ru/add-class.tmpl
%%NLS%%%%DATADIR%%/templates/ru/add-printer.tmpl
-%%NLS%%%%DATADIR%%/templates/ru/add-rss-subscription.tmpl
%%NLS%%%%DATADIR%%/templates/ru/admin.tmpl
%%NLS%%%%DATADIR%%/templates/ru/choose-device.tmpl
%%NLS%%%%DATADIR%%/templates/ru/choose-make.tmpl
@@ -671,23 +677,15 @@ sbin/reject
%%NLS%%%%DATADIR%%/templates/ru/printers-header.tmpl
%%NLS%%%%DATADIR%%/templates/ru/printers.tmpl
%%NLS%%%%DATADIR%%/templates/ru/restart.tmpl
-%%NLS%%%%DATADIR%%/templates/ru/samba-export.tmpl
-%%NLS%%%%DATADIR%%/templates/ru/samba-exported.tmpl
%%NLS%%%%DATADIR%%/templates/ru/search.tmpl
%%NLS%%%%DATADIR%%/templates/ru/set-printer-options-header.tmpl
%%NLS%%%%DATADIR%%/templates/ru/set-printer-options-trailer.tmpl
-%%NLS%%%%DATADIR%%/templates/ru/subscription-added.tmpl
-%%NLS%%%%DATADIR%%/templates/ru/subscription-canceled.tmpl
%%NLS%%%%DATADIR%%/templates/ru/test-page.tmpl
%%NLS%%%%DATADIR%%/templates/ru/trailer.tmpl
%%NLS%%%%DATADIR%%/templates/ru/users.tmpl
-%%DATADIR%%/templates/samba-export.tmpl
-%%DATADIR%%/templates/samba-exported.tmpl
%%DATADIR%%/templates/search.tmpl
%%DATADIR%%/templates/set-printer-options-header.tmpl
%%DATADIR%%/templates/set-printer-options-trailer.tmpl
-%%DATADIR%%/templates/subscription-added.tmpl
-%%DATADIR%%/templates/subscription-canceled.tmpl
%%DATADIR%%/templates/test-page.tmpl
%%DATADIR%%/templates/trailer.tmpl
%%DATADIR%%/templates/users.tmpl
@@ -698,6 +696,7 @@ sbin/reject
%%NLS%%%%DOCSDIR%%/de/index.html
%%NLS%%%%DOCSDIR%%/es/index.html
%%PORTDOCS%%%%DOCSDIR%%/help/accounting.html
+%%PORTDOCS%%%%DOCSDIR%%/help/admin.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-admin.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-filter.html
%%PORTDOCS%%%%DOCSDIR%%/help/api-ppd.html
@@ -705,6 +704,7 @@ sbin/reject
%%PORTDOCS%%%%DOCSDIR%%/help/cgi.html
%%PORTDOCS%%%%DOCSDIR%%/help/cupspm.html
%%PORTDOCS%%%%DOCSDIR%%/help/encryption.html
+%%PORTDOCS%%%%DOCSDIR%%/help/firewalls.html
%%PORTDOCS%%%%DOCSDIR%%/help/glossary.html
%%PORTDOCS%%%%DOCSDIR%%/help/kerberos.html
%%PORTDOCS%%%%DOCSDIR%%/help/license.html
@@ -718,15 +718,16 @@ sbin/reject
%%PORTDOCS%%%%DOCSDIR%%/help/man-cups-snmp.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cups.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsaccept.html
-%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsaddsmb.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsd-helper.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsd-logs.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsd.conf.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsd.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupsenable.html
-%%PORTDOCS%%%%DOCSDIR%%/help/man-cupstestdsc.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-cupstestppd.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-filter.html
+%%PORTDOCS%%%%DOCSDIR%%/help/man-ippevepcl.html
+%%PORTDOCS%%%%DOCSDIR%%/help/man-ippeveprinter.html
+%%PORTDOCS%%%%DOCSDIR%%/help/man-ippfind.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-ipptool.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-ipptoolfile.html
%%PORTDOCS%%%%DOCSDIR%%/help/man-lp.html
@@ -763,8 +764,6 @@ sbin/reject
%%PORTDOCS%%%%DOCSDIR%%/help/spec-command.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-design.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-ipp.html
-%%PORTDOCS%%%%DOCSDIR%%/help/spec-pdf.html
-%%PORTDOCS%%%%DOCSDIR%%/help/spec-postscript.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-ppd.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-raster.html
%%PORTDOCS%%%%DOCSDIR%%/help/spec-stp.html
@@ -798,6 +797,7 @@ sbin/reject
%%NLS%%share/locale/ca/cups_ca.po
%%NLS%%share/locale/cs/cups_cs.po
%%NLS%%share/locale/de/cups_de.po
+%%NLS%%share/locale/en/cups_en.po
%%NLS%%share/locale/es/cups_es.po
%%NLS%%share/locale/fr/cups_fr.po
%%NLS%%share/locale/it/cups_it.po