aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-06-08 04:41:31 +0000
commit5fb9edd6bda35148388cbd149c7fa48f4749f514 (patch)
treefd3fa9b642407455ac306d9a4732b8ea68fd8c43 /print
parent3ca9aed4201adba81415517e7e132bd8f99b03f7 (diff)
downloadports-5fb9edd6bda35148388cbd149c7fa48f4749f514.tar.gz
ports-5fb9edd6bda35148388cbd149c7fa48f4749f514.zip
Multiple ports: improve regex compliance
These changes largely fall into just two categories: 1. Need textproc/gsed for GNU extensions 2. Extraneous escapes that can go away For #1, there's a further subdivision into those that require autoconf magic and those that can get away with BINARY_ALIAS=sed=${LOCALBASE}/bin/gsed. -CURRENT will soon gain GNU extensions, but these will take longer to get to all supported releases; we must switch them to gsed to ensure we're actually properly building them as intended. For #2, I've fixed these as I can and we should upstream these fixes. PORTREVISION is bumped for all of the above, because we will almost certainly build these differently when the replacements actually start working. These were all detected by the below-referenced exp-run [1]. The patch included forbids many ordinary characters from being escaped, since we'll later imbue those with special meanings. This has had the nice side effect of picking up various things that we didn't handle properly, e.g. \t and \r for tab and carriage return. PR: 229925 [1] Approved by: koobs (mentor) Approved by: portmgr (blanket: trivial build fixes) MFH: no (invasive risk) Differential Revision: https://reviews.freebsd.org/D25185
Notes
Notes: svn path=/head/; revision=538197
Diffstat (limited to 'print')
-rw-r--r--print/pdflib/Makefile5
-rw-r--r--print/pdflib/files/patch-configure4
2 files changed, 6 insertions, 3 deletions
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index d566e22e0283..684b27b1ea0b 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pdflib
PORTVERSION= 7.0.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print perl5 java
MASTER_SITES= LOCAL/ale
DISTNAME= PDFlib-Lite-${PORTVERSION}p3
@@ -11,6 +11,8 @@ DISTNAME= PDFlib-Lite-${PORTVERSION}p3
MAINTAINER= ale@FreeBSD.org
COMMENT= C library for dynamically generating PDF
+BUILD_DEPENDS= gsed:textproc/gsed
+
RESTRICTED= Many odd restrictions on usage and distribution
OPTIONS_DEFINE= PERL JAVA DOCS
@@ -20,6 +22,7 @@ JAVA_DESC= Build Java bindings
USES= gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-py=no --with-ruby=no --with-tcl=no
PORTDOCS= *
diff --git a/print/pdflib/files/patch-configure b/print/pdflib/files/patch-configure
index 33c29667c63e..0ba3413ff302 100644
--- a/print/pdflib/files/patch-configure
+++ b/print/pdflib/files/patch-configure
@@ -13,8 +13,8 @@
aix*|AIX*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
osf1*|OSF1*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
darwin|Darwin*) PERLLINK="-L$PERLINCLUDE -lperl $PERLLINK";;
-+ dragonfly|DragonFly*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*=\'\(.*\)\';|\1|"`;;
-+ freebsd|FreeBSD*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*=\'\(.*\)\';|\1|"`;;
++ dragonfly|DragonFly*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*='\(.*\)';|\1|"`;;
++ freebsd|FreeBSD*) PERLLINK=`perl -V:lddlflags|sed -e "s|.*='\(.*\)';|\1|"`;;
*) ;;
esac