aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2014-11-02 14:24:07 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2014-11-02 14:24:07 +0000
commit51f8d8562ab97d7b35420167a569ba0d20fbcb6b (patch)
treee05322daf62c39843eab12c9396011b7b8f9d7be /print
parent5d0682fe2b15b91c5867c96d039036f6890ceca1 (diff)
downloadports-51f8d8562ab97d7b35420167a569ba0d20fbcb6b.tar.gz
ports-51f8d8562ab97d7b35420167a569ba0d20fbcb6b.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/hp2xx/Makefile29
-rw-r--r--print/hp2xx/files/patch-Makefile6
-rw-r--r--print/hp2xx/files/patch-doc_hp2xxinf.tex13
3 files changed, 27 insertions, 21 deletions
diff --git a/print/hp2xx/Makefile b/print/hp2xx/Makefile
index aa4fc266b1bb..983f34bbe8ba 100644
--- a/print/hp2xx/Makefile
+++ b/print/hp2xx/Makefile
@@ -3,39 +3,36 @@
PORTNAME= hp2xx
PORTVERSION= 3.4.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print x11
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= HPGL to vector and raster formats converter and previewer for X11
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-WRKSRC= ${WRKDIR}/${DISTNAME}/sources
+WRKSRC_SUBDIR= sources
USES= makeinfo
MAKE_ENV= DEFINES="${CPPFLAGS}" ALL_LIBS="${LDFLAGS}"
-PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
-INFO= hp2xx
-
CPPFLAGS+= -DUNIX -I${LOCALBASE}/include
LDFLAGS+= -lm -L${LOCALBASE}/lib -ltiff -lpng -lz
-OPTIONS_DEFINE= X11
-OPTIONS_DEFAULT=X11
+INFO= hp2xx
+PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
-X11_USE= XORG=x11
-X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
-X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
+
+X11_USE= XORG=x11
X11_MAKE_ENV= PREVIEWER=to_x11
X11_MAKE_ENV_OFF= PREVIEWER=no_prev
-
-post-patch:
- @${REINPLACE_CMD} -E 's,(bin|info|man1)dir),DESTDIR)$$(&,' \
- ${WRKSRC}/Makefile
+X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
+X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
.include <bsd.port.mk>
diff --git a/print/hp2xx/files/patch-Makefile b/print/hp2xx/files/patch-Makefile
index f2d6427d90f7..247d98273af5 100644
--- a/print/hp2xx/files/patch-Makefile
+++ b/print/hp2xx/files/patch-Makefile
@@ -86,15 +86,15 @@
- -$(STRIP) $(PROGRAM)
- -$(CP) $(PROGRAM) $(bindir)
- -$(CHMOD) 755 $(bindir)/$(PROGRAM)
-+ ${BSD_INSTALL_PROGRAM} $(PROGRAM) $(bindir)
++ ${BSD_INSTALL_PROGRAM} $(PROGRAM) $(DESTDIR)$(bindir)
install-info: hp2xx.info
- -$(CP) hp2xx.info $(infodir)
- -$(CHMOD) 644 $(infodir)/hp2xx.info
-+ ${BSD_INSTALL_DATA} hp2xx.info $(infodir)
++ ${BSD_INSTALL_DATA} hp2xx.info $(DESTDIR)$(infodir)
install-man: ../doc/hp2xx.1
- -$(CP) ../doc/hp2xx.1 $(man1dir)
- -$(CHMOD) 644 $(man1dir)/hp2xx.1
-+ ${BSD_INSTALL_MAN} ../doc/hp2xx.1 $(man1dir)
++ ${BSD_INSTALL_MAN} ../doc/hp2xx.1 $(DESTDIR)$(man1dir)
diff --git a/print/hp2xx/files/patch-doc_hp2xxinf.tex b/print/hp2xx/files/patch-doc_hp2xxinf.tex
index cb74921ef427..6752c61b6042 100644
--- a/print/hp2xx/files/patch-doc_hp2xxinf.tex
+++ b/print/hp2xx/files/patch-doc_hp2xxinf.tex
@@ -12,8 +12,8 @@
@c @smallbook
@c @cropmarks
@c %**end of header
-@@ -35,14 +40,6 @@
- @c 00/09/20 V 1.2 MK fixed INFO-DIR-ENTRY, updates for 3.4.0
+@@ -36,14 +41,6 @@
+ @c 03/06/21 V 1.4 MK updates and fixes for 3.4.4
@c THIS MANUAL REQUIRES TEXINFO-2 macros and info-makers to format properly.
-@ifinfo
@@ -27,3 +27,12 @@
@c
@ifinfo
This file documents the HP-GL converter HP2XX
+@@ -92,7 +89,7 @@
+ @page
+ @tex
+ {\parskip=0pt
+-\hfill mk\@daveg.com\par
++\hfill mk@@daveg.com\par
+ \hfill {\it Using HP2XX}, \manvers\par
+ \hfill \TeX{}info \texinfoversion\par
+ }