aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-09-12 19:44:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-09-12 19:44:38 +0000
commit5900c6b14dd05fdc51cc669f07e53db26f273515 (patch)
tree0621407e4e6c4ba56bba4dcb5f5376082e487cbf /print
parentebfb4876eb5b64edc98935fa0b5e8aad6a821d29 (diff)
downloadports-5900c6b14dd05fdc51cc669f07e53db26f273515.tar.gz
ports-5900c6b14dd05fdc51cc669f07e53db26f273515.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/system-config-printer/Makefile48
-rw-r--r--print/system-config-printer/distinfo4
-rw-r--r--print/system-config-printer/files/patch-applet.py21
-rw-r--r--print/system-config-printer/files/patch-cupshelpers_cupshelpers.py15
-rw-r--r--print/system-config-printer/files/patch-my-default-printer6
-rw-r--r--print/system-config-printer/files/patch-newprinternotification.conf10
-rw-r--r--print/system-config-printer/files/patch-system-config-printer6
-rw-r--r--print/system-config-printer/files/patch-system-config-printer-applet6
-rw-r--r--print/system-config-printer/files/patch-system-config-printer.py43
-rw-r--r--print/system-config-printer/pkg-plist192
10 files changed, 141 insertions, 210 deletions
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 88f51024b0f2..4b301c25914f 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -1,51 +1,51 @@
-# New ports collection makefile for: system-config-printer
-# Date created: 2008-03-20
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/print/system-config-printer/Makefile,v 1.6 2009/12/29 16:03:58 ahze Exp $
-#
PORTNAME= system-config-printer
-PORTVERSION= 1.1.16
-PORTREVISION= 6
+PORTVERSION= 1.4.2
CATEGORIES= print gnome
MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= CUPS configuration Gtk+2.0 GUI
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
- ${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify \
- xmlproc_parse:${PORTSDIR}/textproc/py-xml \
- ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
- xmlto:${PORTSDIR}/textproc/xmlto \
- desktop-file-install:${PORTSDIR}/devel/desktop-file-utils \
+BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
${LOCALBASE}/share/xml/docbook/4.1.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-sk
+LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
- ${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify \
- xmlproc_parse:${PORTSDIR}/textproc/py-xml \
- ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${PYTHON_SITELIBDIR}/pycurl.so:${PORTSDIR}/ftp/py-curl \
${LOCALBASE}/libexec/cups-pk-helper-mechanism:${PORTSDIR}/print/cups-pk-helper
-USE_BZIP2= yes
-USE_PYTHON= 2.6+
+USE_XZ= yes
+USE_PYTHON= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= gettext
+USES= desktop-file-utils gettext gmake pathfix pkgconfig shebangfix
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GNOME= pygtk2
-MAN1= system-config-printer-applet.1 system-config-printer.1
+USE_GNOME= intlhack pygobject3
+
+CONFIGURE_ARGS= --without-udev-rules \
+ --without-systemdsystemunitdir
+
+MAN1= system-config-printer-applet.1 \
+ system-config-printer.1
PLIST_SUB= PYTHON_VER=${PYTHON_VERSION:S/python//}
+SHEBANG_FILES= *.py troubleshoot/*.py xml/validate.py
+
INSTALLS_EGGINFO= yes
PYDISTUTILS_PKGNAME= cupshelpers
PYDISTUTILS_PKGVERSION= 1.0
post-patch:
- @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e \
- 's|%%LOCALBASE%%|${LOCALBASE}|g; s|%%PREFIX%%|${PREFIX}|g'
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g; \
+ s|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/applet.py ${WRKSRC}/check-device-ids.py \
+ ${WRKSRC}/cupshelpers/cupshelpers.py \
+ ${WRKSRC}/cupshelpers/xmldriverprefs.py \
+ ${WRKSRC}/dbus/org.fedoraproject.Config.Printing.service \
+ ${WRKSRC}/newprinter.py ${WRKSRC}/probe_printer.py
@${REINPLACE_CMD} -e 's|setup.py install|setup.py install -c -O1|g' \
${WRKSRC}/Makefile.in
diff --git a/print/system-config-printer/distinfo b/print/system-config-printer/distinfo
index 930699013467..d6712533e03f 100644
--- a/print/system-config-printer/distinfo
+++ b/print/system-config-printer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (system-config-printer-1.1.16.tar.bz2) = 176b63ee6af2208313469192eb34eb12b41fe8b890a18c8a5ab693010a8e785d
-SIZE (system-config-printer-1.1.16.tar.bz2) = 1036604
+SHA256 (system-config-printer-1.4.2.tar.xz) = f0e464435532f73cf8c328ceb1220f02ab2acfc1dcdec729cf5a0acf4193dbea
+SIZE (system-config-printer-1.4.2.tar.xz) = 888848
diff --git a/print/system-config-printer/files/patch-applet.py b/print/system-config-printer/files/patch-applet.py
index d21bb2a2ec76..68a4af8a9690 100644
--- a/print/system-config-printer/files/patch-applet.py
+++ b/print/system-config-printer/files/patch-applet.py
@@ -1,20 +1,11 @@
---- applet.py.orig 2009-12-22 09:44:19.000000000 -0500
-+++ applet.py 2009-12-29 00:06:27.000000000 -0500
+--- applet.py.orig 2013-07-22 15:58:32.000000000 +0200
++++ applet.py 2013-08-29 11:06:43.000000000 +0200
@@ -43,7 +43,7 @@
- os.environ['LC_ALL'] = 'C'
- locale.setlocale (locale.LC_ALL, "")
+
+ from gi.repository import Notify
-APPDIR="/usr/share/system-config-printer"
+APPDIR="%%PREFIX%%/share/system-config-printer"
- DOMAIN="system-config-printer"
ICON="printer"
- SEARCHING_ICON="document-print-preview"
-@@ -234,7 +234,7 @@
- pid = os.fork ()
- if pid == 0:
- # Child.
-- cmd = "/usr/bin/system-config-printer"
-+ cmd = "%%PREFIX%%/bin/system-config-printer"
- argv.insert (0, cmd)
- os.execvp (cmd, argv)
- sys.exit (1)
+
+ # We need to call Notify.init before we can check the server for caps
diff --git a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
index 079c395adf40..8bc0cc75f23f 100644
--- a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
+++ b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
@@ -1,6 +1,6 @@
---- cupshelpers/cupshelpers.py.orig 2009-12-22 09:44:19.000000000 -0500
-+++ cupshelpers/cupshelpers.py 2009-12-29 00:08:26.000000000 -0500
-@@ -663,7 +663,7 @@
+--- cupshelpers/cupshelpers.py.orig 2013-07-22 15:58:32.000000000 +0200
++++ cupshelpers/cupshelpers.py 2013-08-29 11:18:44.000000000 +0200
+@@ -739,7 +739,7 @@
# First, a local function. How to check that something exists
# in a path:
@@ -9,12 +9,3 @@
if name == "-":
# A filter of "-" means that no filter is required,
# i.e. the device accepts the given format as-is.
-@@ -765,7 +765,7 @@
- continue
-
- exepath = pathcheck (exe,
-- "/usr/lib/cups/filter:"
-+ "%%LOCALBASE%%/libexec/cups/filter:"
- "/usr/lib64/cups/filter")
-
- if exe and not exepath:
diff --git a/print/system-config-printer/files/patch-my-default-printer b/print/system-config-printer/files/patch-my-default-printer
deleted file mode 100644
index d5678c0a9420..000000000000
--- a/print/system-config-printer/files/patch-my-default-printer
+++ /dev/null
@@ -1,6 +0,0 @@
---- my-default-printer.orig 2008-03-20 11:53:08.000000000 -0400
-+++ my-default-printer 2008-03-20 11:53:17.000000000 -0400
-@@ -1,2 +1,2 @@
- #!/bin/sh
--exec /usr/share/system-config-printer/my-default-printer.py "$@"
-+exec %%PREFIX%%/share/system-config-printer/my-default-printer.py "$@"
diff --git a/print/system-config-printer/files/patch-newprinternotification.conf b/print/system-config-printer/files/patch-newprinternotification.conf
deleted file mode 100644
index d447338e3b84..000000000000
--- a/print/system-config-printer/files/patch-newprinternotification.conf
+++ /dev/null
@@ -1,10 +0,0 @@
---- newprinternotification.conf.orig 2012-01-27 15:12:33.000000000 +0400
-+++ newprinternotification.conf 2012-01-27 15:12:53.000000000 +0400
-@@ -2,7 +2,7 @@
- "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
- <busconfig>
-- <policy at_console="true">
-+ <policy group="operator">
- <allow own="com.redhat.NewPrinterNotification"/>
- </policy>
diff --git a/print/system-config-printer/files/patch-system-config-printer b/print/system-config-printer/files/patch-system-config-printer
deleted file mode 100644
index 17f1bf5fbb6d..000000000000
--- a/print/system-config-printer/files/patch-system-config-printer
+++ /dev/null
@@ -1,6 +0,0 @@
---- system-config-printer.orig 2008-03-20 11:56:46.000000000 -0400
-+++ system-config-printer 2008-03-20 11:56:58.000000000 -0400
-@@ -1,2 +1,2 @@
- #!/bin/sh
--exec /usr/share/system-config-printer/system-config-printer.py "$@"
-+exec %%PREFIX%%/share/system-config-printer/system-config-printer.py "$@"
diff --git a/print/system-config-printer/files/patch-system-config-printer-applet b/print/system-config-printer/files/patch-system-config-printer-applet
deleted file mode 100644
index b9d8e3125f87..000000000000
--- a/print/system-config-printer/files/patch-system-config-printer-applet
+++ /dev/null
@@ -1,6 +0,0 @@
---- system-config-printer-applet.orig 2008-03-20 11:57:22.000000000 -0400
-+++ system-config-printer-applet 2008-03-20 11:57:32.000000000 -0400
-@@ -1,2 +1,2 @@
- #!/bin/sh
--exec /usr/share/system-config-printer/applet.py "$@"
-+exec %%PREFIX%%/share/system-config-printer/applet.py "$@"
diff --git a/print/system-config-printer/files/patch-system-config-printer.py b/print/system-config-printer/files/patch-system-config-printer.py
deleted file mode 100644
index c0129a32c5ae..000000000000
--- a/print/system-config-printer/files/patch-system-config-printer.py
+++ /dev/null
@@ -1,43 +0,0 @@
---- system-config-printer.py.orig 2009-12-22 09:44:19.000000000 -0500
-+++ system-config-printer.py 2009-12-29 00:35:54.000000000 -0500
-@@ -4344,7 +4344,7 @@
- if may_be_ps:
- debugprint ("Printer might support PostScript")
- try:
-- os.stat ("/usr/share/cups/model/foomatic-db-ppds")
-+ os.stat ("%%LOCALBASE%%/share/cups/model/foomatic-db-ppds")
- debugprint ("foomatic-db-ppds already installed")
- except OSError:
- debugprint ("foomatic-db-ppds not yet installed")
-@@ -4892,11 +4892,11 @@
- # Problem executing command.
- return True # assume plugin not required
- else:
-- if glob.glob("/usr/share/hplip/data/plugin/*%s*plugin*" %
-+ if glob.glob("%%LOCALBASE%%share/hplip/data/plugin/*%s*plugin*" %
- hplip_version):
- if hplip_version.startswith("2"):
- try:
-- f = open('/etc/hp/hplip.conf', 'r')
-+ f = open('%%LOCALBASE%%/etc/hp/hplip.conf', 'r')
- for line in f:
- if line.strip ().startswith("plugin") and \
- line.strip ().endswith("1"):
-@@ -5082,7 +5082,7 @@
- # Try to get make and model via SNMP
- if host:
- os.environ["HOST"] = host
-- cmd = '/usr/lib/cups/backend/snmp "${HOST}"'
-+ cmd = '%%LOCALBASE%%/libexec/cups/backend/snmp "${HOST}"'
- debugprint (host + ": " + cmd)
- stdout = None
- try:
-@@ -6621,7 +6621,7 @@
- try:
- # We want this to be in the current natural language,
- # so we intentionally don't set LC_ALL=C here.
-- p = subprocess.Popen (['/usr/bin/cupstestppd',
-+ p = subprocess.Popen (['%%LOCALBASE%%/bin/cupstestppd',
- '-rvv', filename],
- stdin=file("/dev/null"),
- stdout=subprocess.PIPE,
diff --git a/print/system-config-printer/pkg-plist b/print/system-config-printer/pkg-plist
index 0c47993d2531..445eb05c15b7 100644
--- a/print/system-config-printer/pkg-plist
+++ b/print/system-config-printer/pkg-plist
@@ -1,28 +1,41 @@
-bin/my-default-printer
+bin/install-printerdriver
+bin/scp-dbus-service
bin/system-config-printer
bin/system-config-printer-applet
-etc/dbus-1/system.d/newprinternotification.conf
+etc/cupshelpers/preferreddrivers.xml
+etc/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
+etc/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
etc/xdg/autostart/print-applet.desktop
%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.py
%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.pyo
+%%PYTHON_SITELIBDIR%%/cupshelpers/config.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/config.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/config.pyo
%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.py
%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.pyo
+%%PYTHON_SITELIBDIR%%/cupshelpers/installdriver.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/installdriver.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/installdriver.pyo
%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.py
%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.pyo
%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.py
%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.pyo
-share/applications/manage-print-jobs.desktop
-share/applications/my-default-printer.desktop
+%%PYTHON_SITELIBDIR%%/cupshelpers/xmldriverprefs.py
+%%PYTHON_SITELIBDIR%%/cupshelpers/xmldriverprefs.pyc
+%%PYTHON_SITELIBDIR%%/cupshelpers/xmldriverprefs.pyo
share/applications/system-config-printer.desktop
+share/dbus-1/interfaces/org.fedoraproject.Config.Printing.xml
+share/dbus-1/services/org.fedoraproject.Config.Printing.service
share/locale/ar/LC_MESSAGES/system-config-printer.mo
share/locale/as/LC_MESSAGES/system-config-printer.mo
share/locale/bg/LC_MESSAGES/system-config-printer.mo
share/locale/bn/LC_MESSAGES/system-config-printer.mo
share/locale/bn_IN/LC_MESSAGES/system-config-printer.mo
+share/locale/br/LC_MESSAGES/system-config-printer.mo
share/locale/bs/LC_MESSAGES/system-config-printer.mo
share/locale/ca/LC_MESSAGES/system-config-printer.mo
share/locale/cs/LC_MESSAGES/system-config-printer.mo
@@ -58,6 +71,7 @@ share/locale/mr/LC_MESSAGES/system-config-printer.mo
share/locale/ms/LC_MESSAGES/system-config-printer.mo
share/locale/my/LC_MESSAGES/system-config-printer.mo
share/locale/nb/LC_MESSAGES/system-config-printer.mo
+share/locale/nds/LC_MESSAGES/system-config-printer.mo
share/locale/nl/LC_MESSAGES/system-config-printer.mo
share/locale/nn/LC_MESSAGES/system-config-printer.mo
share/locale/or/LC_MESSAGES/system-config-printer.mo
@@ -81,88 +95,92 @@ share/locale/uk/LC_MESSAGES/system-config-printer.mo
share/locale/vi/LC_MESSAGES/system-config-printer.mo
share/locale/zh_CN/LC_MESSAGES/system-config-printer.mo
share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
-%%DATADIR%%/AdvancedServerSettings.py
-%%DATADIR%%/GroupsPane.py
-%%DATADIR%%/GroupsPaneModel.py
-%%DATADIR%%/HIG.py
-%%DATADIR%%/PhysicalDevice.py
-%%DATADIR%%/SearchCriterion.py
-%%DATADIR%%/ToolbarSearchEntry.py
-%%DATADIR%%/XmlHelper.py
-%%DATADIR%%/applet.py
-%%DATADIR%%/asyncconn.py
-%%DATADIR%%/asyncipp.py
-%%DATADIR%%/asyncpk0.py
-%%DATADIR%%/asyncpk1.py
-%%DATADIR%%/authconn.py
-%%DATADIR%%/config.py
-%%DATADIR%%/cupspk.py
-%%DATADIR%%/debug.py
-%%DATADIR%%/errordialogs.py
-%%DATADIR%%/firewall.py
-%%DATADIR%%/glade.py
-%%DATADIR%%/glade/AboutDialog.glade
-%%DATADIR%%/glade/ConnectDialog.glade
-%%DATADIR%%/glade/ConnectingDialog.glade
-%%DATADIR%%/glade/InstallDialog.glade
-%%DATADIR%%/glade/JobsWindow.glade
-%%DATADIR%%/glade/NewPrinterName.glade
-%%DATADIR%%/glade/NewPrinterWindow.glade
-%%DATADIR%%/glade/PrinterPropertiesDialog.glade
-%%DATADIR%%/glade/PrintersWindow.glade
-%%DATADIR%%/glade/SMBBrowseDialog.glade
-%%DATADIR%%/glade/ServerSettingsDialog.glade
-%%DATADIR%%/glade/WaitWindow.glade
-%%DATADIR%%/glade/statusicon_popupmenu.glade
-%%DATADIR%%/gtk_label_autowrap.py
-%%DATADIR%%/gtkinklevel.py
-%%DATADIR%%/gtkspinner.py
-%%DATADIR%%/icons/i-network-printer.png
-%%DATADIR%%/installpackage.py
-%%DATADIR%%/jobviewer.py
-%%DATADIR%%/monitor.py
-%%DATADIR%%/my-default-printer.py
-%%DATADIR%%/options.py
-%%DATADIR%%/optionwidgets.py
-%%DATADIR%%/ppdippstr.py
-%%DATADIR%%/probe_printer.py
-%%DATADIR%%/pysmb.py
-%%DATADIR%%/smburi.py
-%%DATADIR%%/statereason.py
-%%DATADIR%%/system-config-printer.py
-%%DATADIR%%/timedops.py
-%%DATADIR%%/troubleshoot/CheckLocalServerPublishing.py
-%%DATADIR%%/troubleshoot/CheckNetworkServerSanity.py
-%%DATADIR%%/troubleshoot/CheckPPDSanity.py
-%%DATADIR%%/troubleshoot/CheckPrinterSanity.py
-%%DATADIR%%/troubleshoot/CheckUSBPermissions.py
-%%DATADIR%%/troubleshoot/ChooseNetworkPrinter.py
-%%DATADIR%%/troubleshoot/ChoosePrinter.py
-%%DATADIR%%/troubleshoot/DeviceListed.py
-%%DATADIR%%/troubleshoot/ErrorLogCheckpoint.py
-%%DATADIR%%/troubleshoot/ErrorLogFetch.py
-%%DATADIR%%/troubleshoot/ErrorLogParse.py
-%%DATADIR%%/troubleshoot/LocalOrRemote.py
-%%DATADIR%%/troubleshoot/Locale.py
-%%DATADIR%%/troubleshoot/NetworkCUPSPrinterShared.py
-%%DATADIR%%/troubleshoot/PrintTestPage.py
-%%DATADIR%%/troubleshoot/PrinterStateReasons.py
-%%DATADIR%%/troubleshoot/QueueNotEnabled.py
-%%DATADIR%%/troubleshoot/QueueRejectingJobs.py
-%%DATADIR%%/troubleshoot/RemoteAddress.py
-%%DATADIR%%/troubleshoot/SchedulerNotRunning.py
-%%DATADIR%%/troubleshoot/ServerFirewalled.py
-%%DATADIR%%/troubleshoot/Shrug.py
-%%DATADIR%%/troubleshoot/Welcome.py
-%%DATADIR%%/troubleshoot/__init__.py
-%%DATADIR%%/troubleshoot/base.py
-%%DATADIR%%/userdefault.py
-@dirrm %%DATADIR%%/troubleshoot
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/glade
-@dirrm %%DATADIR%%
-@dirrmtry share/applications
-@dirrm %%PYTHON_SITELIBDIR%%/cupshelpers
+share/system-config-printer/HIG.py
+share/system-config-printer/PhysicalDevice.py
+share/system-config-printer/SearchCriterion.py
+share/system-config-printer/ToolbarSearchEntry.py
+share/system-config-printer/applet.py
+share/system-config-printer/asyncconn.py
+share/system-config-printer/asyncipp.py
+share/system-config-printer/asyncpk1.py
+share/system-config-printer/authconn.py
+share/system-config-printer/check-device-ids.py
+share/system-config-printer/config.py
+share/system-config-printer/cupspk.py
+share/system-config-printer/debug.py
+share/system-config-printer/dnssdresolve.py
+share/system-config-printer/errordialogs.py
+share/system-config-printer/firewallsettings.py
+share/system-config-printer/gtkinklevel.py
+share/system-config-printer/gui.py
+share/system-config-printer/icons/i-network-printer.png
+share/system-config-printer/install-printerdriver.py
+share/system-config-printer/installpackage.py
+share/system-config-printer/jobviewer.py
+share/system-config-printer/monitor.py
+share/system-config-printer/newprinter.py
+share/system-config-printer/options.py
+share/system-config-printer/optionwidgets.py
+share/system-config-printer/ppdcache.py
+share/system-config-printer/ppdippstr.py
+share/system-config-printer/ppdsloader.py
+share/system-config-printer/printerproperties.py
+share/system-config-printer/probe_printer.py
+share/system-config-printer/pysmb.py
+share/system-config-printer/scp-dbus-service.py
+share/system-config-printer/serversettings.py
+share/system-config-printer/smburi.py
+share/system-config-printer/statereason.py
+share/system-config-printer/system-config-printer.py
+share/system-config-printer/timedops.py
+share/system-config-printer/troubleshoot/CheckLocalServerPublishing.py
+share/system-config-printer/troubleshoot/CheckNetworkServerSanity.py
+share/system-config-printer/troubleshoot/CheckPPDSanity.py
+share/system-config-printer/troubleshoot/CheckPrinterSanity.py
+share/system-config-printer/troubleshoot/CheckSELinux.py
+share/system-config-printer/troubleshoot/CheckUSBPermissions.py
+share/system-config-printer/troubleshoot/ChooseNetworkPrinter.py
+share/system-config-printer/troubleshoot/ChoosePrinter.py
+share/system-config-printer/troubleshoot/DeviceListed.py
+share/system-config-printer/troubleshoot/ErrorLogCheckpoint.py
+share/system-config-printer/troubleshoot/ErrorLogFetch.py
+share/system-config-printer/troubleshoot/ErrorLogParse.py
+share/system-config-printer/troubleshoot/LocalOrRemote.py
+share/system-config-printer/troubleshoot/Locale.py
+share/system-config-printer/troubleshoot/NetworkCUPSPrinterShared.py
+share/system-config-printer/troubleshoot/PrintTestPage.py
+share/system-config-printer/troubleshoot/PrinterStateReasons.py
+share/system-config-printer/troubleshoot/QueueNotEnabled.py
+share/system-config-printer/troubleshoot/QueueRejectingJobs.py
+share/system-config-printer/troubleshoot/RemoteAddress.py
+share/system-config-printer/troubleshoot/SchedulerNotRunning.py
+share/system-config-printer/troubleshoot/ServerFirewalled.py
+share/system-config-printer/troubleshoot/Shrug.py
+share/system-config-printer/troubleshoot/VerifyPackages.py
+share/system-config-printer/troubleshoot/Welcome.py
+share/system-config-printer/troubleshoot/__init__.py
+share/system-config-printer/troubleshoot/base.py
+share/system-config-printer/ui/AboutDialog.ui
+share/system-config-printer/ui/ConnectDialog.ui
+share/system-config-printer/ui/ConnectingDialog.ui
+share/system-config-printer/ui/InstallDialog.ui
+share/system-config-printer/ui/JobsWindow.ui
+share/system-config-printer/ui/NewPrinterName.ui
+share/system-config-printer/ui/NewPrinterWindow.ui
+share/system-config-printer/ui/PrinterPropertiesDialog.ui
+share/system-config-printer/ui/PrintersWindow.ui
+share/system-config-printer/ui/SMBBrowseDialog.ui
+share/system-config-printer/ui/ServerSettingsDialog.ui
+share/system-config-printer/ui/WaitWindow.ui
+share/system-config-printer/ui/statusicon_popupmenu.ui
+share/system-config-printer/userdefault.py
+share/system-config-printer/xml/preferreddrivers.rng
+share/system-config-printer/xml/validate.py
+@dirrm share/system-config-printer/xml
+@dirrm share/system-config-printer/ui
+@dirrm share/system-config-printer/troubleshoot
+@dirrm share/system-config-printer/icons
+@dirrm share/system-config-printer
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@@ -183,3 +201,5 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
+@dirrm %%PYTHON_SITELIBDIR%%/cupshelpers
+@dirrm etc/cupshelpers