aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /print
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/freetype2/Makefile5
-rw-r--r--print/freetype2/distinfo6
-rw-r--r--print/freetype2/files/patch-src-cff_cffload.c47
-rw-r--r--print/freetype2/files/patch-src-lzw_ftzopen.c14
-rw-r--r--print/freetype2/files/patch-src-sfnt_ttcmap.c52
-rw-r--r--print/freetype2/files/patch-src-smooth_ftsmooth.c27
-rw-r--r--print/libspectre/Makefile5
-rw-r--r--print/libspectre/distinfo6
8 files changed, 10 insertions, 152 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index d3b69092e31c..6fb2273f60be 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -3,12 +3,11 @@
# Whom: jseger@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports/print/freetype2/Makefile,v 1.16 2009/04/09 03:24:09 mezz Exp $
+# $MCom: ports/print/freetype2/Makefile,v 1.19 2009/11/28 05:59:02 mezz Exp $
#
PORTNAME= freetype2
-PORTVERSION= 2.3.9
-PORTREVISION= 1
+PORTVERSION= 2.3.11
CATEGORIES= print
MASTER_SITES= SF/freetype/${PORTNAME}/${PORTVERSION} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/freetype2/ \
diff --git a/print/freetype2/distinfo b/print/freetype2/distinfo
index 90082855f2fd..cba91a34b1bd 100644
--- a/print/freetype2/distinfo
+++ b/print/freetype2/distinfo
@@ -1,3 +1,3 @@
-MD5 (freetype-2.3.9.tar.bz2) = d76233108aca9c9606cdbd341562ad9a
-SHA256 (freetype-2.3.9.tar.bz2) = 51a033bce9904d73e0821e8e2bba24bd319619d7d1b2e9eeccac611580242ab6
-SIZE (freetype-2.3.9.tar.bz2) = 1363190
+MD5 (freetype-2.3.11.tar.bz2) = 519c7cbf5cbd72ffa822c66844d3114c
+SHA256 (freetype-2.3.11.tar.bz2) = 8a033b1e6018a1e9ea381b09b2347b02c6686bdf7e4ee86a6714b6b90f1e2ec9
+SIZE (freetype-2.3.11.tar.bz2) = 1446474
diff --git a/print/freetype2/files/patch-src-cff_cffload.c b/print/freetype2/files/patch-src-cff_cffload.c
deleted file mode 100644
index 33d8a99d8800..000000000000
--- a/print/freetype2/files/patch-src-cff_cffload.c
+++ /dev/null
@@ -1,47 +0,0 @@
-diff --git a/src/cff/cffload.c b/src/cff/cffload.c
-index 22163fb..24b899d 100644
---- src/cff/cffload.c
-+++ src/cff/cffload.c
-@@ -842,7 +842,20 @@
- goto Exit;
-
- for ( j = 1; j < num_glyphs; j++ )
-- charset->sids[j] = FT_GET_USHORT();
-+ {
-+ FT_UShort sid = FT_GET_USHORT();
-+
-+
-+ /* this constant is given in the CFF specification */
-+ if ( sid < 65000 )
-+ charset->sids[j] = sid;
-+ else
-+ {
-+ FT_ERROR(( "cff_charset_load:"
-+ " invalid SID value %d set to zero\n", sid ));
-+ charset->sids[j] = 0;
-+ }
-+ }
-
- FT_FRAME_EXIT();
- }
-@@ -875,6 +888,20 @@
- goto Exit;
- }
-
-+ /* check whether the range contains at least one valid glyph; */
-+ /* the constant is given in the CFF specification */
-+ if ( glyph_sid >= 65000 ) {
-+ FT_ERROR(( "cff_charset_load: invalid SID range\n" ));
-+ error = CFF_Err_Invalid_File_Format;
-+ goto Exit;
-+ }
-+
-+ /* try to rescue some of the SIDs if `nleft' is too large */
-+ if ( nleft > 65000 - 1 || glyph_sid >= 65000 - nleft ) {
-+ FT_ERROR(( "cff_charset_load: invalid SID range trimmed\n" ));
-+ nleft = 65000 - 1 - glyph_sid;
-+ }
-+
- /* Fill in the range of sids -- `nleft + 1' glyphs. */
- for ( i = 0; j < num_glyphs && i <= nleft; i++, j++, glyph_sid++ )
- charset->sids[j] = glyph_sid;
diff --git a/print/freetype2/files/patch-src-lzw_ftzopen.c b/print/freetype2/files/patch-src-lzw_ftzopen.c
deleted file mode 100644
index 8f8de1f14622..000000000000
--- a/print/freetype2/files/patch-src-lzw_ftzopen.c
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/lzw/ftzopen.c b/src/lzw/ftzopen.c
-index fc78315..c0483de 100644
---- src/lzw/ftzopen.c
-+++ src/lzw/ftzopen.c
-@@ -332,6 +332,9 @@
-
- while ( code >= 256U )
- {
-+ if ( !state->prefix )
-+ goto Eof;
-+
- FTLZW_STACK_PUSH( state->suffix[code - 256] );
- code = state->prefix[code - 256];
- }
diff --git a/print/freetype2/files/patch-src-sfnt_ttcmap.c b/print/freetype2/files/patch-src-sfnt_ttcmap.c
deleted file mode 100644
index ce5c717eb915..000000000000
--- a/print/freetype2/files/patch-src-sfnt_ttcmap.c
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/src/sfnt/ttcmap.c b/src/sfnt/ttcmap.c
-index 6830391..1bd2ce7 100644
---- src/sfnt/ttcmap.c
-+++ src/sfnt/ttcmap.c
-@@ -1635,7 +1635,7 @@
- FT_INVALID_TOO_SHORT;
-
- length = TT_NEXT_ULONG( p );
-- if ( table + length > valid->limit || length < 8208 )
-+ if ( length > (FT_UInt32)( valid->limit - table ) || length < 8192 + 16 )
- FT_INVALID_TOO_SHORT;
-
- is32 = table + 12;
-@@ -1863,7 +1863,8 @@
- p = table + 16;
- count = TT_NEXT_ULONG( p );
-
-- if ( table + length > valid->limit || length < 20 + count * 2 )
-+ if ( length > (FT_ULong)( valid->limit - table ) ||
-+ length < 20 + count * 2 )
- FT_INVALID_TOO_SHORT;
-
- /* check glyph indices */
-@@ -2048,7 +2049,8 @@
- p = table + 12;
- num_groups = TT_NEXT_ULONG( p );
-
-- if ( table + length > valid->limit || length < 16 + 12 * num_groups )
-+ if ( length > (FT_ULong)( valid->limit - table ) ||
-+ length < 16 + 12 * num_groups )
- FT_INVALID_TOO_SHORT;
-
- /* check groups, they must be in increasing order */
-@@ -2429,7 +2431,8 @@
- FT_ULong num_selectors = TT_NEXT_ULONG( p );
-
-
-- if ( table + length > valid->limit || length < 10 + 11 * num_selectors )
-+ if ( length > (FT_ULong)( valid->limit - table ) ||
-+ length < 10 + 11 * num_selectors )
- FT_INVALID_TOO_SHORT;
-
- /* check selectors, they must be in increasing order */
-@@ -2491,7 +2494,7 @@
- FT_ULong i, lastUni = 0;
-
-
-- if ( ndp + numMappings * 4 > valid->limit )
-+ if ( numMappings * 4 > (FT_ULong)( valid->limit - ndp ) )
- FT_INVALID_TOO_SHORT;
-
- for ( i = 0; i < numMappings; ++i )
diff --git a/print/freetype2/files/patch-src-smooth_ftsmooth.c b/print/freetype2/files/patch-src-smooth_ftsmooth.c
deleted file mode 100644
index ce0f3622bb5a..000000000000
--- a/print/freetype2/files/patch-src-smooth_ftsmooth.c
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/src/smooth/ftsmooth.c b/src/smooth/ftsmooth.c
-index a6db504..cacc490 100644
---- src/smooth/ftsmooth.c
-+++ src/smooth/ftsmooth.c
-@@ -153,7 +153,7 @@
- slot->internal->flags &= ~FT_GLYPH_OWN_BITMAP;
- }
-
-- /* allocate new one, depends on pixel format */
-+ /* allocate new one */
- pitch = width;
- if ( hmul )
- {
-@@ -194,6 +194,13 @@
-
- #endif
-
-+ if ( pitch > 0xFFFF || height > 0xFFFF )
-+ {
-+ FT_ERROR(( "ft_smooth_render_generic: glyph too large: %d x %d\n",
-+ width, height ));
-+ return Smooth_Err_Raster_Overflow;
-+ }
-+
- bitmap->pixel_mode = FT_PIXEL_MODE_GRAY;
- bitmap->num_grays = 256;
- bitmap->width = width;
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
index 9303a5f869f0..6ceb7fd7759e 100644
--- a/print/libspectre/Makefile
+++ b/print/libspectre/Makefile
@@ -3,11 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/print/libspectre/Makefile,v 1.2 2008/03/13 16:30:50 ahze Exp $
+# $MCom: ports/print/libspectre/Makefile,v 1.4 2009/10/19 20:04:37 kwm Exp $
PORTNAME= libspectre
-PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTVERSION= 0.2.3
CATEGORIES= print
MASTER_SITES= http://libspectre.freedesktop.org/releases/
diff --git a/print/libspectre/distinfo b/print/libspectre/distinfo
index 5c446e70ffe2..a2603a21ee46 100644
--- a/print/libspectre/distinfo
+++ b/print/libspectre/distinfo
@@ -1,3 +1,3 @@
-MD5 (libspectre-0.2.2.tar.gz) = 0600653653d9313e3be135b2217ea7fd
-SHA256 (libspectre-0.2.2.tar.gz) = 94d4e7b5916f925f992380237bc6ac9227291531b4cd18a21df54caef147f704
-SIZE (libspectre-0.2.2.tar.gz) = 391727
+MD5 (libspectre-0.2.3.tar.gz) = 9c5867e970d1bad5f80809bfdb4306c1
+SHA256 (libspectre-0.2.3.tar.gz) = 0cc4e30b9379a383894e2559c5e2125dd90f814106b4628459d90db9b5ac8b41
+SIZE (libspectre-0.2.3.tar.gz) = 352308