aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /print
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile3
-rw-r--r--print/gnomephotoprinter/Makefile4
-rw-r--r--print/libijs/Makefile3
-rw-r--r--print/panda/Makefile2
4 files changed, 7 insertions, 5 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 85a22de8dba4..76178591974a 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -133,10 +133,9 @@ CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
.if ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
-CONFIGURE_ENV+= PKGCONFIG="${LOCALBASE}/bin/pkg-config"
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
.else
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
diff --git a/print/gnomephotoprinter/Makefile b/print/gnomephotoprinter/Makefile
index 52f28ec5b038..e39ccce492eb 100644
--- a/print/gnomephotoprinter/Makefile
+++ b/print/gnomephotoprinter/Makefile
@@ -23,4 +23,8 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+post-patch:
+ @${REINPLACE_CMD} -s "s/PKGCONFIG --version/PKGCONFIG --modversion pkg-config/g" \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/print/libijs/Makefile b/print/libijs/Makefile
index d4db4e62df65..f6583caa0467 100644
--- a/print/libijs/Makefile
+++ b/print/libijs/Makefile
@@ -16,13 +16,12 @@ DIST_SUBDIR= ghostscript
MAINTAINER= ports@FreeBSD.org
COMMENT= C library that supports plugin printer driver for Ghostscript
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_BZIP2= yes
USE_GNOME= lthack
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAN1= ijs-config.1
diff --git a/print/panda/Makefile b/print/panda/Makefile
index a6d438103b71..ca81fdb917c4 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -19,7 +19,6 @@ COMMENT= A PDF generation library
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
@@ -31,6 +30,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-berkeley-db
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}