aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-22 14:11:11 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-22 14:11:11 +0000
commit278f3e371b1c161f718ce024c91d6a14eba9c75c (patch)
tree77d24c08a9285b332b0a5e3bb1950ff3c7eaa297 /print
parent1a959291f67ac53bf9ce3f7d00366453e2344b97 (diff)
downloadports-278f3e371b1c161f718ce024c91d6a14eba9c75c.tar.gz
ports-278f3e371b1c161f718ce024c91d6a14eba9c75c.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/clibpdf/Makefile39
-rw-r--r--print/clibpdf/distinfo1
-rw-r--r--print/clibpdf/files/esecanna.sh39
-rw-r--r--print/clibpdf/files/patch-aa22
-rw-r--r--print/clibpdf/pkg-comment1
-rw-r--r--print/clibpdf/pkg-descr12
-rw-r--r--print/clibpdf/pkg-plist98
8 files changed, 213 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 3f09553259d3..9a8754761567 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -22,6 +22,7 @@
SUBDIR += c2ps-letter
SUBDIR += cdlabelgen
SUBDIR += cjk-lyx
+ SUBDIR += clibpdf
SUBDIR += cmpsfont
SUBDIR += detex
SUBDIR += dvi2tty
diff --git a/print/clibpdf/Makefile b/print/clibpdf/Makefile
new file mode 100644
index 000000000000..d0ca035c58ba
--- /dev/null
+++ b/print/clibpdf/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: ClibPDF
+# Date created: 22 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clibpdf
+PORTVERSION= 2.02.r1
+CATEGORIES= print
+MASTER_SITES= http://www.fastio.com/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+
+MAINTAINER= knu@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/ClibPDF/source
+
+INSTALLS_SHLIB= yes
+SHLIB_VER= 0
+
+MAKEFILE= Makefile.FreeBSD
+ALL_TARGET= lib shlib
+
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/cpdflib.h ${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/libcpdf.a ${PREFIX}/lib/
+ ${INSTALL_DATA} ${WRKSRC}/libcpdf.so ${PREFIX}/lib/libcpdf.so.${SHLIB_VER}
+ ${LN} -sf libcpdf.so.${SHLIB_VER} ${PREFIX}/lib/libcpdf.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/clibpdf
+ ${CP} -R ${WRKSRC}/../examples/ ${PREFIX}/share/examples/clibpdf/
+ ${MKDIR} ${PREFIX}/share/doc/clibpdf
+ ${CP} -R ${WRKSRC}/../doc/ ${PREFIX}/share/doc/clibpdf/
+ ${INSTALL_DATA} ${WRKSRC}/../*.pdf ${PREFIX}/share/doc/clibpdf/
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/clibpdf/distinfo b/print/clibpdf/distinfo
new file mode 100644
index 000000000000..95ce636ec8d8
--- /dev/null
+++ b/print/clibpdf/distinfo
@@ -0,0 +1 @@
+MD5 (clibpdf202r1.tar.gz) = 840d78e187ab46fc5700caba9fbb33e5
diff --git a/print/clibpdf/files/esecanna.sh b/print/clibpdf/files/esecanna.sh
new file mode 100644
index 000000000000..a8fc53c3f75a
--- /dev/null
+++ b/print/clibpdf/files/esecanna.sh
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/print/clibpdf/files/Attic/esecanna.sh,v 1.1 2000-08-22 14:11:10 knu Exp $
+
+esecannaserver="!!PREFIX!!/sbin/esecannaserver"
+
+case "$1" in
+start)
+ if [ -f !!PREFIX!!/vje30/.version ] \
+ && grep -qw 'FREE TRIAL VERSION' !!PREFIX!!/vje30/.version; then
+ echo ''
+ echo 'esecanna:'
+ echo ' Using VJE-Delta 3.0 trial, it is unable to connect to vjed on startup.'
+ echo ' Please execute $esecannaserver manually after once you run vje.'
+ exit 1
+ fi
+
+ if [ -x $esecannaserver ]; then
+ rm -f /tmp/.iroha_unix/IROHA
+ echo -n ' esecanna: '
+ $esecannaserver
+ fi
+ ;;
+stop)
+ pidfile="/var/run/esecanna.pid"
+ if [ -f $pidfile ]; then
+ kill `cat $pidfile` && echo -n ' esecanna'
+ rm $pidfile
+ else
+ echo ' esecanna: not running'
+ fi
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/print/clibpdf/files/patch-aa b/print/clibpdf/files/patch-aa
new file mode 100644
index 000000000000..2e3057048cb9
--- /dev/null
+++ b/print/clibpdf/files/patch-aa
@@ -0,0 +1,22 @@
+--- Makefile.FreeBSD.orig Sun Nov 21 14:54:44 1999
++++ Makefile.FreeBSD Tue Aug 22 22:23:03 2000
+@@ -1,8 +1,8 @@
+ # Makefile for ClibPDF library - FreeBSD/gcc
+ # make lib; make install OR make shlib; make shinstall
+
+-LIB_FILE=libcpdfm.a
+-SHLIB_FILE=libcpdfm.sl
++LIB_FILE=libcpdf.a
++SHLIB_FILE=libcpdf.so
+ # LIB_FILE=libcpdfpm.a
+ # SHLIB_FILE=libcpdfpm.sl
+
+@@ -75,7 +75,7 @@
+
+ $(SHLIB_FILE): $(OBJS) $(POBJS) $(ZOBJS) Makefile
+ rm -f $(SHLIB_FILE)
+- ld -b -o $(SHLIB_FILE) $(OBJS) $(POBJS) $(ZOBJS)
++ ld -shared -o $(SHLIB_FILE) $(OBJS) $(POBJS) $(ZOBJS)
+
+ install: lib
+ # mkdir -p $(LIB_DIR)
diff --git a/print/clibpdf/pkg-comment b/print/clibpdf/pkg-comment
new file mode 100644
index 000000000000..2d3abc0a7fda
--- /dev/null
+++ b/print/clibpdf/pkg-comment
@@ -0,0 +1 @@
+A library for creating PDF (Acrobat) files directly via C language programs
diff --git a/print/clibpdf/pkg-descr b/print/clibpdf/pkg-descr
new file mode 100644
index 000000000000..f54296159bb5
--- /dev/null
+++ b/print/clibpdf/pkg-descr
@@ -0,0 +1,12 @@
+ClibPDF is a library of ANSI C functions, distributed as source code,
+for creating PDF (Acrobat) files directly via C language programs
+without relying on any Adobe Acrobat tools and related products. It
+is free for private, non-profit use, but a commercial license is
+required for for-profit applications (Please see FastIO ClibPDF
+License included in this package for details).
+
+Licence summaries:
+ http://www.fastio.com/licensePlain.html (in English)
+ http://www.fastio.com/licensePlainJ.html (in Japanese)
+
+WWW: http://www.fastio.com/
diff --git a/print/clibpdf/pkg-plist b/print/clibpdf/pkg-plist
new file mode 100644
index 000000000000..0d36d0ab7adb
--- /dev/null
+++ b/print/clibpdf/pkg-plist
@@ -0,0 +1,98 @@
+include/cpdflib.h
+lib/libcpdf.a
+lib/libcpdf.so
+lib/libcpdf.so.%%SHLIB_VER%%
+share/examples/clibpdf/CJK/Chinese/cn-test.c
+share/examples/clibpdf/CJK/Chinese/monkey.txt
+share/examples/clibpdf/CJK/Japanese/jpntest.c
+share/examples/clibpdf/CJK/Korean/kr-test.c
+share/examples/clibpdf/Makefile.Cygwin
+share/examples/clibpdf/Makefile.irix62gcc
+share/examples/clibpdf/arc/Arcs.c
+share/examples/clibpdf/barcode/README.barcode
+share/examples/clibpdf/barcode/barcode.c
+share/examples/clibpdf/barcode/fontmap.lst
+share/examples/clibpdf/bezier/beziertest.c
+share/examples/clibpdf/blank/blank.c
+share/examples/clibpdf/charwidth/charwidth.c
+share/examples/clibpdf/cover/cover.c
+share/examples/clibpdf/cover/page2.txt
+share/examples/clibpdf/dash/dashtest.c
+share/examples/clibpdf/domain/DomainDemo.c
+share/examples/clibpdf/filltest/filltest.c
+share/examples/clibpdf/fontlist/fontlist.c
+share/examples/clibpdf/hello/helloworld.c
+share/examples/clibpdf/landscape/landscape.c
+share/examples/clibpdf/landscape/landscape2.c
+share/examples/clibpdf/linkpdfpage/linkembed.html
+share/examples/clibpdf/linkpdfpage/linkpdfpage.c
+share/examples/clibpdf/marker/MarkerTest.c
+share/examples/clibpdf/minimal/Minimal.c
+share/examples/clibpdf/outline/domain.pdf
+share/examples/clibpdf/outline/outline.c
+share/examples/clibpdf/pdfclock/pdfclock.c
+share/examples/clibpdf/shiplabel/image1.jpg
+share/examples/clibpdf/shiplabel/shiplabel.c
+share/examples/clibpdf/shiplabel/shiplabel.html
+share/examples/clibpdf/text/textalign.c
+share/examples/clibpdf/text2pdf/text2pdf.c
+share/examples/clibpdf/textbox/textMac.txt
+share/examples/clibpdf/textbox/textUnix.txt
+share/examples/clibpdf/textbox/textWindows.txt
+share/examples/clibpdf/textbox/textbox.c
+share/examples/clibpdf/textboxfit/textboxfit.c
+share/examples/clibpdf/timeaxis/timeaxis.c
+share/examples/clibpdf/unicode/annotcr.txt
+share/examples/clibpdf/unicode/annotcr.u16
+share/examples/clibpdf/unicode/content1.txt
+share/examples/clibpdf/unicode/content1.u16
+share/examples/clibpdf/unicode/hex.c
+share/examples/clibpdf/unicode/shiori1.txt
+share/examples/clibpdf/unicode/shiori1.u16
+share/examples/clibpdf/unicode/shiori2.txt
+share/examples/clibpdf/unicode/shiori2.u16
+share/examples/clibpdf/unicode/title.txt
+share/examples/clibpdf/unicode/title.u16
+share/examples/clibpdf/unicode/unicode.c
+share/examples/clibpdf/weather/OAK.wdat
+share/examples/clibpdf/weather/weather.c
+share/examples/clibpdf/weather/weatherj.c
+@dirrm share/examples/clibpdf/CJK/Chinese
+@dirrm share/examples/clibpdf/CJK/Japanese
+@dirrm share/examples/clibpdf/CJK/Korean
+@dirrm share/examples/clibpdf/CJK
+@dirrm share/examples/clibpdf/arc
+@dirrm share/examples/clibpdf/barcode
+@dirrm share/examples/clibpdf/bezier
+@dirrm share/examples/clibpdf/blank
+@dirrm share/examples/clibpdf/charwidth
+@dirrm share/examples/clibpdf/cover
+@dirrm share/examples/clibpdf/dash
+@dirrm share/examples/clibpdf/domain
+@dirrm share/examples/clibpdf/filltest
+@dirrm share/examples/clibpdf/fontlist
+@dirrm share/examples/clibpdf/hello
+@dirrm share/examples/clibpdf/landscape
+@dirrm share/examples/clibpdf/linkpdfpage
+@dirrm share/examples/clibpdf/marker
+@dirrm share/examples/clibpdf/minimal
+@dirrm share/examples/clibpdf/outline
+@dirrm share/examples/clibpdf/pdfclock
+@dirrm share/examples/clibpdf/shiplabel
+@dirrm share/examples/clibpdf/text
+@dirrm share/examples/clibpdf/text2pdf
+@dirrm share/examples/clibpdf/textbox
+@dirrm share/examples/clibpdf/textboxfit
+@dirrm share/examples/clibpdf/timeaxis
+@dirrm share/examples/clibpdf/unicode
+@dirrm share/examples/clibpdf/weather
+@dirrm share/examples/clibpdf
+share/doc/clibpdf/BenchMarks.txt
+share/doc/clibpdf/ClibPDF-FAQ.txt
+share/doc/clibpdf/FormIssues.txt
+share/doc/clibpdf/cpdfAdd202.pdf
+share/doc/clibpdf/cpdfman200.pdf
+share/doc/clibpdf/usingMemStream.txt
+share/doc/clibpdf/LICENSE.pdf
+share/doc/clibpdf/LICENSEP.pdf
+@dirrm share/doc/clibpdf