aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-25 20:26:02 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-25 20:26:02 +0000
commit0efaad4f1b145cc2610e723b0b5bf7865c823592 (patch)
treee8d6586c6638fdde037d92ffa062afd730117772 /print
parent51916907064d95f0517c5986c4fe3b6661b22895 (diff)
downloadports-0efaad4f1b145cc2610e723b0b5bf7865c823592.tar.gz
ports-0efaad4f1b145cc2610e723b0b5bf7865c823592.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-layouts/Makefile61
-rw-r--r--print/latex-layouts/distinfo5
-rw-r--r--print/latex-layouts/pkg-descr7
-rw-r--r--print/latex-layouts/pkg-plist11
5 files changed, 85 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 01f436ffb3db..ae1c77086663 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -95,6 +95,7 @@
SUBDIR += latex-beamer
SUBDIR += latex-caption
SUBDIR += latex-keystroke
+ SUBDIR += latex-layouts
SUBDIR += latex-mathabx
SUBDIR += latex-pgf
SUBDIR += latex-subfig
diff --git a/print/latex-layouts/Makefile b/print/latex-layouts/Makefile
new file mode 100644
index 000000000000..b48037fe978e
--- /dev/null
+++ b/print/latex-layouts/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: latex-layouts
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-layouts
+PORTVERSION= 2.6.20031125
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/layouts
+DISTFILES= ${DOC_FILES} layouts.dtx layouts.ins
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for the display of layout elements
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+YES_CMD= /usr/bin/yes
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= layouts.dtx
+CLASS_FILES+= layouts.ins
+CLASS_FILES+= layouts.sty
+
+DOC_FILES= README
+DOC_FILES+= layman.pdf
+DOC_FILES+= layman.tex
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${YES_CMD} | ${TEX_BIN} layouts.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-layouts/distinfo b/print/latex-layouts/distinfo
new file mode 100644
index 000000000000..5e6cff9b8c5d
--- /dev/null
+++ b/print/latex-layouts/distinfo
@@ -0,0 +1,5 @@
+MD5 (latex-layouts/README) = 386f25d957df171f7d1cd1b6d4afe26f
+MD5 (latex-layouts/layman.pdf) = 1b13d3d258092441ba865a168b21e3a0
+MD5 (latex-layouts/layman.tex) = a20529fe4837374c51904c24eaeef444
+MD5 (latex-layouts/layouts.dtx) = 00b5eea722bb98f8d4bf1ab1188e1de8
+MD5 (latex-layouts/layouts.ins) = 220403737b09750424796c7da4863d57
diff --git a/print/latex-layouts/pkg-descr b/print/latex-layouts/pkg-descr
new file mode 100644
index 000000000000..9ad50403b2e3
--- /dev/null
+++ b/print/latex-layouts/pkg-descr
@@ -0,0 +1,7 @@
+The layouts package enables the display of various elements of a
+document's layout including: the general page layout; disposition
+of floats; layout of paragraphs, lists, footnotes, table of contents,
+and sectional headings; font boxes.
+
+Facilities are provided for a document designer to experiment with
+the layout parameters.
diff --git a/print/latex-layouts/pkg-plist b/print/latex-layouts/pkg-plist
new file mode 100644
index 000000000000..575f4341aa63
--- /dev/null
+++ b/print/latex-layouts/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/layman.pdf
+%%PORTDOCS%%%%DOCSDIR%%/layman.tex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/layouts.dtx
+%%CLASSDIR%%/layouts.ins
+%%CLASSDIR%%/layouts.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%