aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-26 13:41:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-26 13:41:31 +0000
commit6326fea8b068441704561c8c810421e5ae06a66c (patch)
tree3218b14b53d3819e97bf45b4c2ae3af111c466a9 /print
parent7e97eccf0e28bdf7d6a91ba823c7c9b676638d70 (diff)
downloadports-6326fea8b068441704561c8c810421e5ae06a66c.tar.gz
ports-6326fea8b068441704561c8c810421e5ae06a66c.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-bibunits/Makefile56
-rw-r--r--print/latex-bibunits/distinfo3
-rw-r--r--print/latex-bibunits/pkg-descr5
-rw-r--r--print/latex-bibunits/pkg-plist9
5 files changed, 74 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 96c4cb8c9e29..5eac682a685d 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -94,6 +94,7 @@
SUBDIR += latex
SUBDIR += latex-beamer
SUBDIR += latex-bibtopic
+ SUBDIR += latex-bibunits
SUBDIR += latex-caption
SUBDIR += latex-feynmf
SUBDIR += latex-keystroke
diff --git a/print/latex-bibunits/Makefile b/print/latex-bibunits/Makefile
new file mode 100644
index 000000000000..c7ee6ac7505f
--- /dev/null
+++ b/print/latex-bibunits/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: latex-bibunits
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-bibunits
+PORTVERSION= 2.2.20001010
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/bibunits
+DISTFILES= ${DOC_FILES} bibunits.dtx bibunits.ins
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package allows separate bibliographies
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+BUILD_DEPENDS+= ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+
+DOC_FILES= README
+
+CLASS_FILES= bibunits.sty
+CLASS_FILES+= bibunits.ins bibunits.dtx
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${TEX_BIN} bibunits.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-bibunits/distinfo b/print/latex-bibunits/distinfo
new file mode 100644
index 000000000000..1e04899f23e6
--- /dev/null
+++ b/print/latex-bibunits/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex-bibunits/README) = 5b9f02e77894ebb53d59ebada4574433
+MD5 (latex-bibunits/bibunits.dtx) = 7bc7b08deb38b1b677b5194ab5bb5da4
+MD5 (latex-bibunits/bibunits.ins) = 22df95bab16d206cf3ca38e2078e8e37
diff --git a/print/latex-bibunits/pkg-descr b/print/latex-bibunits/pkg-descr
new file mode 100644
index 000000000000..d466071e2ce5
--- /dev/null
+++ b/print/latex-bibunits/pkg-descr
@@ -0,0 +1,5 @@
+The `bibunits' package allows separate bibliographies for different
+units or parts of the text. The units can be chapters, sections or
+bibunit environments. The package is compatible with a wide variety of
+packages, including, but not limited to, natbib, overcite and
+KOMA-SCRIPT classes.
diff --git a/print/latex-bibunits/pkg-plist b/print/latex-bibunits/pkg-plist
new file mode 100644
index 000000000000..a7a470243001
--- /dev/null
+++ b/print/latex-bibunits/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/bibunits.dtx
+%%CLASSDIR%%/bibunits.ins
+%%CLASSDIR%%/bibunits.sty
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%