aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-08-25 05:19:58 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-08-25 05:19:58 +0000
commitbede5fa3aa9a8dcdfb8525a05d33cc0d8e9364f8 (patch)
tree374b49d6a038cff990035c88eb126c1496471b73 /print
parent2f2dff0b11a80f098ceccce0b28851a104cfc882 (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile8
-rw-r--r--print/cups-base/distinfo4
-rw-r--r--print/cups-base/files/patch-configure28
-rw-r--r--print/cups-base/files/patch-str391435
4 files changed, 55 insertions, 20 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 794868abc265..018d71835d27 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cups
-PORTVERSION= 1.4.6
+PORTVERSION= 1.4.8
DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
@@ -41,7 +41,7 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-pam-module="unix" \
--enable-ssl
-OPTIONS?= GNUTLS "Build with GNUTLS library" on \
+OPTIONS?= GNUTLS "Build with GNUTLS library" off \
PHP "Build PHP support" off \
PYTHON "Build PYTHON support" off \
LIBPAPER "Build with libpaper support" off \
@@ -76,7 +76,7 @@ CUPS_SUFFIX= -client
CUPS_SUFFIX= -image
LICENSE= LGPL21
.else
-PORTREVISION= 5
+PORTREVISION= 0
CUPS_SUFFIX= -base
CONFLICTS+= cupsddk-*
.endif
@@ -123,7 +123,7 @@ PLIST_SUB+= OVERWRITE="@comment "
CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
.endif
-.if !defined(WITHOUT_GNUTLS)
+.if defined(WITH_GNUTLS)
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
CONFIGURE_ENV+= PKGCONFIG="${LOCALBASE}/bin/pkg-config"
LIB_DEPENDS+= gnutls-openssl.27:${PORTSDIR}/security/gnutls
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
index 5d9ec492e120..d83e4247a852 100644
--- a/print/cups-base/distinfo
+++ b/print/cups-base/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-1.4.6-source.tar.bz2) = f08711702a77b52c7150f96fe1f45482f6151cb95ef601268c528607fe6ad514
-SIZE (cups-1.4.6-source.tar.bz2) = 4517061
+SHA256 (cups-1.4.8-source.tar.bz2) = 6bd27e1213c139ed0bbadc5c29f97cf1e8f7f8f5b0bb29b227ecaff32aafa9a6
+SIZE (cups-1.4.8-source.tar.bz2) = 4547162
diff --git a/print/cups-base/files/patch-configure b/print/cups-base/files/patch-configure
index 81f5d483cfde..fe4ac611c482 100644
--- a/print/cups-base/files/patch-configure
+++ b/print/cups-base/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2009-04-16 22:02:06.000000000 +0200
-+++ configure 2009-05-05 20:42:19.000000000 +0200
-@@ -6287,6 +6287,7 @@
+--- configure.orig 2011-07-25 22:19:20.000000000 +0200
++++ configure 2011-08-25 06:04:32.000000000 +0200
+@@ -6259,6 +6259,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -8,16 +8,16 @@
#include <sys/ucred.h>
_ACEOF
rm -f conftest.$ac_objext
-@@ -7643,7 +7644,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-ldbus-1 `$PKGCONFIG --libs dbus-1` $LIBS"
-+LIBS="-ldbus-1 `$PKGCONFIG --libs dbus-1` $LIBS -pthread"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -11782,6 +11783,7 @@
+@@ -8689,7 +8690,7 @@
+ CFLAGS="$CFLAGS `$PKGCONFIG --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
+ CUPSDLIBS="$CUPSDLIBS `$PKGCONFIG --libs dbus-1`"
+ DBUS_NOTIFIER="dbus"
+- DBUS_NOTIFIERLIBS="`$PKGCONFIG --libs dbus-1`"
++ DBUS_NOTIFIERLIBS="`$PKGCONFIG --libs dbus-1` -pthread"
+ SAVELIBS="$LIBS"
+ LIBS="$LIBS $DBUS_NOTIFIERLIBS"
+ { echo "$as_me:$LINENO: checking for dbus_message_iter_init_append" >&5
+@@ -13524,6 +13525,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -25,7 +25,7 @@
#include <resolv.h>
_ACEOF
rm -f conftest.$ac_objext
-@@ -16791,7 +16793,7 @@
+@@ -17447,7 +17449,7 @@
if test x$ac_cv_header_pthread_h = xyes; then
diff --git a/print/cups-base/files/patch-str3914 b/print/cups-base/files/patch-str3914
new file mode 100644
index 000000000000..998b57283a5a
--- /dev/null
+++ b/print/cups-base/files/patch-str3914
@@ -0,0 +1,35 @@
+Index: filter/image-gif.c
+===================================================================
+--- filter/image-gif.c (revision 9862)
++++ filter/image-gif.c (working copy)
+@@ -648,11 +648,13 @@
+
+ if (code == max_code)
+ {
+- *sp++ = firstcode;
+- code = oldcode;
++ if (sp < (stack + 8192))
++ *sp++ = firstcode;
++
++ code = oldcode;
+ }
+
+- while (code >= clear_code)
++ while (code >= clear_code && sp < (stack + 8192))
+ {
+ *sp++ = table[1][code];
+ if (code == table[0][code])
+@@ -661,9 +663,11 @@
+ code = table[0][code];
+ }
+
+- *sp++ = firstcode = table[1][code];
+- code = max_code;
++ if (sp < (stack + 8192))
++ *sp++ = firstcode = table[1][code];
+
++ code = max_code;
++
+ if (code < 4096)
+ {
+ table[0][code] = oldcode;