aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-06-08 00:41:59 +0000
committerSteve Wills <swills@FreeBSD.org>2019-06-08 00:41:59 +0000
commit006e32299a5d83505cbcf950a3534c6ff0effd31 (patch)
treebdd5da4b68e27d55960d63128a5683de0b46f349 /print
parentf82b57de27376c7acc0891e1f2a1736573023659 (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/splix/Makefile37
-rw-r--r--print/splix/distinfo5
-rw-r--r--print/splix/files/patch-src_ppdfile.cpp11
-rw-r--r--print/splix/pkg-plist30
4 files changed, 57 insertions, 26 deletions
diff --git a/print/splix/Makefile b/print/splix/Makefile
index 030d4f39406d..8167f4a6a8c7 100644
--- a/print/splix/Makefile
+++ b/print/splix/Makefile
@@ -2,26 +2,39 @@
PORTNAME= splix
PORTVERSION= 2.0.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES?= print
-MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= CUPS printer drivers for Samsung Printer Language printers
+LICENSE= GPLv2
+
LIB_DEPENDS= libcupsimage.so:print/cups
-USES= gmake tar:bzip2
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= erpel
+GH_TAGNAME= 6752e71281f1289a3b76357d84b65b0d893615b3
+
+WRKSRC_SUBDIR= ${PORTNAME}
-MODELS= DELL SAMSUNG XEROX
+MODELS= DELL LEXMARK SAMSUNG TOSHIBA XEROX
PPD_DELL= 1100 1110
-PPD_SAMSUNG= clp500 clp510 clp550 clp610 \
- ml1510 ml1520 ml1610 ml1630 ml1640 ml1710 ml1740 ml1750 \
- ml2010 ml2150 ml2250 ml2251 ml2510 ml2550 \
- ml3050 ml3560 \
- scx4200 scx4500
-PPD_XEROX= ph3115 ph3116 ph3117 ph3120 ph3121 ph3122 ph3130 ph3150 \
- ph3420 ph3425 ph5500 ph6100 wc3119 ph3160
+PPD_LEXMARK= x215mfp
+PPD_SAMSUNG= clp310 clp315 clp500 clp510 clp550 \
+ ml1510 ml1520 ml1610 ml1630 ml1640 ml1660 ml1710 ml1740 ml1750 \
+ ml1910 ml1915 ml2010 ml2015 ml2150 ml2240 ml2525 ml2250 ml2251 \
+ ml2510 ml2550 ml2580 \
+ ml3050 ml3051 ml3471nd ml3560 \
+ sf565p \
+ scx3200 scx4100 scx4200 scx4300 scx4216f scx4500 scx4521f scx4600 \
+ scx5330n scx5530fn
+PPD_TOSHIBA= es180s
+PPD_XEROX= ph3115 ph3116 ph3117 ph3120 ph3121 ph3122 ph3124 ph3130 ph3140 \
+ ph3150 ph3155 \
+ ph3420 ph3425 ph5500 ph6100 wc3119 ph3160 \
+ wcpe16 wcpe114e
PPD_SAMSUNG_JBIG= clp200 clp300 clp600 clx216x clx2170 clx3160
PPD_XEROX_JBIG= ph6110
@@ -32,6 +45,8 @@ BIN_DEST_DIR= `${CUPS_CONFIG} --serverbin | ${SED} \
CUPS_DATA_DIR= `${CUPS_CONFIG} --datadir | ${SED} \
's|${LOCALBASE}|${PREFIX}|'`
DEST_DIR_DELL= ${CUPS_DATA_DIR}/model/dell
+DEST_DIR_LEXMARK= ${CUPS_DATA_DIR}/model/lexmark
+DEST_DIR_TOSHIBA= ${CUPS_DATA_DIR}/model/toshiba
DEST_DIR_SAMSUNG= ${CUPS_DATA_DIR}/model/samsung
DEST_DIR_XEROX= ${CUPS_DATA_DIR}/model/xerox
diff --git a/print/splix/distinfo b/print/splix/distinfo
index 0848e53bc2c7..510fa643df8b 100644
--- a/print/splix/distinfo
+++ b/print/splix/distinfo
@@ -1,2 +1,3 @@
-SHA256 (splix-2.0.0.tar.bz2) = 97f703fc73a2940e63da43130615f3ef2a06d4d1f85fe6edfed0c0cd79de912f
-SIZE (splix-2.0.0.tar.bz2) = 101197
+TIMESTAMP = 1550607991
+SHA256 (erpel-splix-2.0.0-6752e71281f1289a3b76357d84b65b0d893615b3_GH0.tar.gz) = 44f79da55c0da5fa7065c125877588f0a0097807081ef1712ebfbddfa73f64d9
+SIZE (erpel-splix-2.0.0-6752e71281f1289a3b76357d84b65b0d893615b3_GH0.tar.gz) = 1070002
diff --git a/print/splix/files/patch-src_ppdfile.cpp b/print/splix/files/patch-src_ppdfile.cpp
deleted file mode 100644
index beb08b146901..000000000000
--- a/print/splix/files/patch-src_ppdfile.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ppdfile.cpp.orig 2009-02-06 11:49:10.000000000 +0000
-+++ src/ppdfile.cpp
-@@ -282,7 +282,7 @@ bool PPDFile::Value::operator != (const
- * Opérateur d'assignation
- * Assignment operator
- */
--void PPDFile::Value::operator = (const PPDFile::Value::Value &val)
-+void PPDFile::Value::operator = (const PPDFile::Value &val)
- {
- if (_preformatted)
- delete[] _preformatted;
diff --git a/print/splix/pkg-plist b/print/splix/pkg-plist
index 0a562fa0fff2..83248c437819 100644
--- a/print/splix/pkg-plist
+++ b/print/splix/pkg-plist
@@ -1,14 +1,16 @@
-libexec/cups/filter/rastertoqpdl
libexec/cups/filter/pstoqpdl
+libexec/cups/filter/rastertoqpdl
share/cups/model/dell/1100.ppd
share/cups/model/dell/1110.ppd
+share/cups/model/lexmark/x215mfp.ppd
share/cups/model/samsung/clp200.ppd
share/cups/model/samsung/clp300.ppd
+share/cups/model/samsung/clp310.ppd
+share/cups/model/samsung/clp315.ppd
share/cups/model/samsung/clp500.ppd
share/cups/model/samsung/clp510.ppd
share/cups/model/samsung/clp550.ppd
share/cups/model/samsung/clp600.ppd
-share/cups/model/samsung/clp610.ppd
share/cups/model/samsung/clx216x.ppd
share/cups/model/samsung/clx2170.ppd
share/cups/model/samsung/clx3160.ppd
@@ -17,27 +19,49 @@ share/cups/model/samsung/ml1520.ppd
share/cups/model/samsung/ml1610.ppd
share/cups/model/samsung/ml1630.ppd
share/cups/model/samsung/ml1640.ppd
+share/cups/model/samsung/ml1660.ppd
share/cups/model/samsung/ml1710.ppd
share/cups/model/samsung/ml1740.ppd
share/cups/model/samsung/ml1750.ppd
+share/cups/model/samsung/ml1910.ppd
+share/cups/model/samsung/ml1915.ppd
share/cups/model/samsung/ml2010.ppd
+share/cups/model/samsung/ml2015.ppd
share/cups/model/samsung/ml2150.ppd
+share/cups/model/samsung/ml2240.ppd
share/cups/model/samsung/ml2250.ppd
share/cups/model/samsung/ml2251.ppd
share/cups/model/samsung/ml2510.ppd
+share/cups/model/samsung/ml2525.ppd
share/cups/model/samsung/ml2550.ppd
+share/cups/model/samsung/ml2580.ppd
share/cups/model/samsung/ml3050.ppd
+share/cups/model/samsung/ml3051.ppd
+share/cups/model/samsung/ml3471nd.ppd
share/cups/model/samsung/ml3560.ppd
+share/cups/model/samsung/scx3200.ppd
+share/cups/model/samsung/scx4100.ppd
share/cups/model/samsung/scx4200.ppd
+share/cups/model/samsung/scx4216f.ppd
+share/cups/model/samsung/scx4300.ppd
share/cups/model/samsung/scx4500.ppd
+share/cups/model/samsung/scx4521f.ppd
+share/cups/model/samsung/scx4600.ppd
+share/cups/model/samsung/scx5330n.ppd
+share/cups/model/samsung/scx5530fn.ppd
+share/cups/model/samsung/sf565p.ppd
+share/cups/model/toshiba/es180s.ppd
share/cups/model/xerox/ph3115.ppd
share/cups/model/xerox/ph3116.ppd
share/cups/model/xerox/ph3117.ppd
share/cups/model/xerox/ph3120.ppd
share/cups/model/xerox/ph3121.ppd
share/cups/model/xerox/ph3122.ppd
+share/cups/model/xerox/ph3124.ppd
share/cups/model/xerox/ph3130.ppd
+share/cups/model/xerox/ph3140.ppd
share/cups/model/xerox/ph3150.ppd
+share/cups/model/xerox/ph3155.ppd
share/cups/model/xerox/ph3160.ppd
share/cups/model/xerox/ph3420.ppd
share/cups/model/xerox/ph3425.ppd
@@ -45,3 +69,5 @@ share/cups/model/xerox/ph5500.ppd
share/cups/model/xerox/ph6100.ppd
share/cups/model/xerox/ph6110.ppd
share/cups/model/xerox/wc3119.ppd
+share/cups/model/xerox/wcpe114e.ppd
+share/cups/model/xerox/wcpe16.ppd