aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-09-13 05:53:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-09-13 05:53:16 +0000
commit7fc60db60a558650dfbeaeeda5344047e27f3540 (patch)
tree76ab0d9b68c00165637d69d2ddc15145fc2d1c20 /print
parent807b617aad2b3ea65889e58e1c623cb11d0e76c6 (diff)
downloadports-7fc60db60a558650dfbeaeeda5344047e27f3540.tar.gz
ports-7fc60db60a558650dfbeaeeda5344047e27f3540.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/lyx-devel/Makefile56
-rw-r--r--print/lyx-devel/distinfo4
-rw-r--r--print/lyx-devel/pkg-plist28
-rw-r--r--print/lyx/Makefile56
-rw-r--r--print/lyx/distinfo4
-rw-r--r--print/lyx/pkg-plist28
-rw-r--r--print/lyx14/Makefile56
-rw-r--r--print/lyx14/distinfo4
-rw-r--r--print/lyx14/pkg-plist28
-rw-r--r--print/lyx15/Makefile56
-rw-r--r--print/lyx15/distinfo4
-rw-r--r--print/lyx15/pkg-plist28
-rw-r--r--print/lyx16/Makefile56
-rw-r--r--print/lyx16/distinfo4
-rw-r--r--print/lyx16/pkg-plist28
15 files changed, 190 insertions, 250 deletions
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index c0fc58011529..4c0c8e134f99 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= lyx
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-MAINTAINER= thompsa@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
@@ -25,32 +24,43 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= cjk-lyx-*
+OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
+ ASPELL "Utilize ASPELL library" on \
+ ISPELL "Depend on ISPELL as well" off
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+USE_REINPLACE= yes
+
+post-configure:
+ # Removing explicit linking with -lc
+ ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+
+.include <bsd.port.pre.mk>
.if defined(WITH_QT)
-USE_QT_VER= 3
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
CONFIGURE_ARGS+= --with-frontend=qt
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
.else
-LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
.endif
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
@@ -60,32 +70,14 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libqt-mt.prl)
+QT_PRESENT= on
+.else
+QT_PRESENT= off
+.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
-pre-everything::
-.if !defined(WITH_QT)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ASPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Ispell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/lyx-devel/distinfo b/print/lyx-devel/distinfo
index ee3cb95ae9d9..f490601bb5e8 100644
--- a/print/lyx-devel/distinfo
+++ b/print/lyx-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (lyx-1.3.5.tar.bz2) = f4c70d2565ba9c974b1f94fc1dfd63bf
-SIZE (lyx-1.3.5.tar.bz2) = 5459049
+MD5 (lyx-1.3.6.tar.bz2) = 26d745b98bdc32e9edfc28e581583f80
+SIZE (lyx-1.3.6.tar.bz2) = 5745377
diff --git a/print/lyx-devel/pkg-plist b/print/lyx-devel/pkg-plist
index f71884459749..58d89acc9eca 100644
--- a/print/lyx-devel/pkg-plist
+++ b/print/lyx-devel/pkg-plist
@@ -37,7 +37,6 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/chkconfig.ltx
%%DATADIR%%/clipart/platypus.eps
%%DATADIR%%/configure
-%%DATADIR%%/configure.cmd
%%DATADIR%%/doc/Customization.lyx
%%DATADIR%%/doc/DocStyle.lyx
%%DATADIR%%/doc/Extended.lyx
@@ -842,22 +841,19 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/layouts/svjog.layout
%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svprobth.layout
-%%DATADIR%%/lyx2lyx/error.py
-%%DATADIR%%/lyx2lyx/error.pyc
%%DATADIR%%/lyx2lyx/lyx2lyx
-%%DATADIR%%/lyx2lyx/lyxconvert_210.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_216.py
-%%DATADIR%%/lyx2lyx/lyxconvert_216.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_217.py
-%%DATADIR%%/lyx2lyx/lyxconvert_217.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_218.py
-%%DATADIR%%/lyx2lyx/lyxconvert_218.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_220.py
-%%DATADIR%%/lyx2lyx/lyxconvert_220.pyc
-%%DATADIR%%/lyx2lyx/parser_tools.py
-%%DATADIR%%/lyx2lyx/parser_tools.pyc
+%%DATADIR%%/lyx2lyx/LyX.py
+%%DATADIR%%/lyx2lyx/lyx_0_12.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_0.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_1.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_4.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_5.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6fix3.py
+%%DATADIR%%/lyx2lyx/lyx_1_2.py
+%%DATADIR%%/lyx2lyx/lyx_1_3.py
+%%DATADIR%%/lyx2lyx/lyx_1_4.py
+%%DATADIR%%/lyx2lyx/profiling.py
%%DATADIR%%/lyxrc.defaults
%%DATADIR%%/lyxrc.example
%%DATADIR%%/packages.lst
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index c0fc58011529..4c0c8e134f99 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= lyx
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-MAINTAINER= thompsa@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
@@ -25,32 +24,43 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= cjk-lyx-*
+OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
+ ASPELL "Utilize ASPELL library" on \
+ ISPELL "Depend on ISPELL as well" off
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+USE_REINPLACE= yes
+
+post-configure:
+ # Removing explicit linking with -lc
+ ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+
+.include <bsd.port.pre.mk>
.if defined(WITH_QT)
-USE_QT_VER= 3
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
CONFIGURE_ARGS+= --with-frontend=qt
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
.else
-LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
.endif
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
@@ -60,32 +70,14 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libqt-mt.prl)
+QT_PRESENT= on
+.else
+QT_PRESENT= off
+.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
-pre-everything::
-.if !defined(WITH_QT)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ASPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Ispell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/lyx/distinfo b/print/lyx/distinfo
index ee3cb95ae9d9..f490601bb5e8 100644
--- a/print/lyx/distinfo
+++ b/print/lyx/distinfo
@@ -1,2 +1,2 @@
-MD5 (lyx-1.3.5.tar.bz2) = f4c70d2565ba9c974b1f94fc1dfd63bf
-SIZE (lyx-1.3.5.tar.bz2) = 5459049
+MD5 (lyx-1.3.6.tar.bz2) = 26d745b98bdc32e9edfc28e581583f80
+SIZE (lyx-1.3.6.tar.bz2) = 5745377
diff --git a/print/lyx/pkg-plist b/print/lyx/pkg-plist
index f71884459749..58d89acc9eca 100644
--- a/print/lyx/pkg-plist
+++ b/print/lyx/pkg-plist
@@ -37,7 +37,6 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/chkconfig.ltx
%%DATADIR%%/clipart/platypus.eps
%%DATADIR%%/configure
-%%DATADIR%%/configure.cmd
%%DATADIR%%/doc/Customization.lyx
%%DATADIR%%/doc/DocStyle.lyx
%%DATADIR%%/doc/Extended.lyx
@@ -842,22 +841,19 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/layouts/svjog.layout
%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svprobth.layout
-%%DATADIR%%/lyx2lyx/error.py
-%%DATADIR%%/lyx2lyx/error.pyc
%%DATADIR%%/lyx2lyx/lyx2lyx
-%%DATADIR%%/lyx2lyx/lyxconvert_210.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_216.py
-%%DATADIR%%/lyx2lyx/lyxconvert_216.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_217.py
-%%DATADIR%%/lyx2lyx/lyxconvert_217.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_218.py
-%%DATADIR%%/lyx2lyx/lyxconvert_218.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_220.py
-%%DATADIR%%/lyx2lyx/lyxconvert_220.pyc
-%%DATADIR%%/lyx2lyx/parser_tools.py
-%%DATADIR%%/lyx2lyx/parser_tools.pyc
+%%DATADIR%%/lyx2lyx/LyX.py
+%%DATADIR%%/lyx2lyx/lyx_0_12.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_0.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_1.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_4.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_5.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6fix3.py
+%%DATADIR%%/lyx2lyx/lyx_1_2.py
+%%DATADIR%%/lyx2lyx/lyx_1_3.py
+%%DATADIR%%/lyx2lyx/lyx_1_4.py
+%%DATADIR%%/lyx2lyx/profiling.py
%%DATADIR%%/lyxrc.defaults
%%DATADIR%%/lyxrc.example
%%DATADIR%%/packages.lst
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index c0fc58011529..4c0c8e134f99 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= lyx
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-MAINTAINER= thompsa@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
@@ -25,32 +24,43 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= cjk-lyx-*
+OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
+ ASPELL "Utilize ASPELL library" on \
+ ISPELL "Depend on ISPELL as well" off
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+USE_REINPLACE= yes
+
+post-configure:
+ # Removing explicit linking with -lc
+ ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+
+.include <bsd.port.pre.mk>
.if defined(WITH_QT)
-USE_QT_VER= 3
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
CONFIGURE_ARGS+= --with-frontend=qt
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
.else
-LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
.endif
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
@@ -60,32 +70,14 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libqt-mt.prl)
+QT_PRESENT= on
+.else
+QT_PRESENT= off
+.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
-pre-everything::
-.if !defined(WITH_QT)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ASPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Ispell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/lyx14/distinfo b/print/lyx14/distinfo
index ee3cb95ae9d9..f490601bb5e8 100644
--- a/print/lyx14/distinfo
+++ b/print/lyx14/distinfo
@@ -1,2 +1,2 @@
-MD5 (lyx-1.3.5.tar.bz2) = f4c70d2565ba9c974b1f94fc1dfd63bf
-SIZE (lyx-1.3.5.tar.bz2) = 5459049
+MD5 (lyx-1.3.6.tar.bz2) = 26d745b98bdc32e9edfc28e581583f80
+SIZE (lyx-1.3.6.tar.bz2) = 5745377
diff --git a/print/lyx14/pkg-plist b/print/lyx14/pkg-plist
index f71884459749..58d89acc9eca 100644
--- a/print/lyx14/pkg-plist
+++ b/print/lyx14/pkg-plist
@@ -37,7 +37,6 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/chkconfig.ltx
%%DATADIR%%/clipart/platypus.eps
%%DATADIR%%/configure
-%%DATADIR%%/configure.cmd
%%DATADIR%%/doc/Customization.lyx
%%DATADIR%%/doc/DocStyle.lyx
%%DATADIR%%/doc/Extended.lyx
@@ -842,22 +841,19 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/layouts/svjog.layout
%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svprobth.layout
-%%DATADIR%%/lyx2lyx/error.py
-%%DATADIR%%/lyx2lyx/error.pyc
%%DATADIR%%/lyx2lyx/lyx2lyx
-%%DATADIR%%/lyx2lyx/lyxconvert_210.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_216.py
-%%DATADIR%%/lyx2lyx/lyxconvert_216.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_217.py
-%%DATADIR%%/lyx2lyx/lyxconvert_217.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_218.py
-%%DATADIR%%/lyx2lyx/lyxconvert_218.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_220.py
-%%DATADIR%%/lyx2lyx/lyxconvert_220.pyc
-%%DATADIR%%/lyx2lyx/parser_tools.py
-%%DATADIR%%/lyx2lyx/parser_tools.pyc
+%%DATADIR%%/lyx2lyx/LyX.py
+%%DATADIR%%/lyx2lyx/lyx_0_12.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_0.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_1.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_4.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_5.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6fix3.py
+%%DATADIR%%/lyx2lyx/lyx_1_2.py
+%%DATADIR%%/lyx2lyx/lyx_1_3.py
+%%DATADIR%%/lyx2lyx/lyx_1_4.py
+%%DATADIR%%/lyx2lyx/profiling.py
%%DATADIR%%/lyxrc.defaults
%%DATADIR%%/lyxrc.example
%%DATADIR%%/packages.lst
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index c0fc58011529..4c0c8e134f99 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= lyx
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-MAINTAINER= thompsa@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
@@ -25,32 +24,43 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= cjk-lyx-*
+OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
+ ASPELL "Utilize ASPELL library" on \
+ ISPELL "Depend on ISPELL as well" off
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+USE_REINPLACE= yes
+
+post-configure:
+ # Removing explicit linking with -lc
+ ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+
+.include <bsd.port.pre.mk>
.if defined(WITH_QT)
-USE_QT_VER= 3
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
CONFIGURE_ARGS+= --with-frontend=qt
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
.else
-LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
.endif
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
@@ -60,32 +70,14 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libqt-mt.prl)
+QT_PRESENT= on
+.else
+QT_PRESENT= off
+.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
-pre-everything::
-.if !defined(WITH_QT)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ASPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Ispell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/lyx15/distinfo b/print/lyx15/distinfo
index ee3cb95ae9d9..f490601bb5e8 100644
--- a/print/lyx15/distinfo
+++ b/print/lyx15/distinfo
@@ -1,2 +1,2 @@
-MD5 (lyx-1.3.5.tar.bz2) = f4c70d2565ba9c974b1f94fc1dfd63bf
-SIZE (lyx-1.3.5.tar.bz2) = 5459049
+MD5 (lyx-1.3.6.tar.bz2) = 26d745b98bdc32e9edfc28e581583f80
+SIZE (lyx-1.3.6.tar.bz2) = 5745377
diff --git a/print/lyx15/pkg-plist b/print/lyx15/pkg-plist
index f71884459749..58d89acc9eca 100644
--- a/print/lyx15/pkg-plist
+++ b/print/lyx15/pkg-plist
@@ -37,7 +37,6 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/chkconfig.ltx
%%DATADIR%%/clipart/platypus.eps
%%DATADIR%%/configure
-%%DATADIR%%/configure.cmd
%%DATADIR%%/doc/Customization.lyx
%%DATADIR%%/doc/DocStyle.lyx
%%DATADIR%%/doc/Extended.lyx
@@ -842,22 +841,19 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/layouts/svjog.layout
%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svprobth.layout
-%%DATADIR%%/lyx2lyx/error.py
-%%DATADIR%%/lyx2lyx/error.pyc
%%DATADIR%%/lyx2lyx/lyx2lyx
-%%DATADIR%%/lyx2lyx/lyxconvert_210.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_216.py
-%%DATADIR%%/lyx2lyx/lyxconvert_216.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_217.py
-%%DATADIR%%/lyx2lyx/lyxconvert_217.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_218.py
-%%DATADIR%%/lyx2lyx/lyxconvert_218.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_220.py
-%%DATADIR%%/lyx2lyx/lyxconvert_220.pyc
-%%DATADIR%%/lyx2lyx/parser_tools.py
-%%DATADIR%%/lyx2lyx/parser_tools.pyc
+%%DATADIR%%/lyx2lyx/LyX.py
+%%DATADIR%%/lyx2lyx/lyx_0_12.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_0.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_1.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_4.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_5.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6fix3.py
+%%DATADIR%%/lyx2lyx/lyx_1_2.py
+%%DATADIR%%/lyx2lyx/lyx_1_3.py
+%%DATADIR%%/lyx2lyx/lyx_1_4.py
+%%DATADIR%%/lyx2lyx/profiling.py
%%DATADIR%%/lyxrc.defaults
%%DATADIR%%/lyxrc.example
%%DATADIR%%/packages.lst
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index c0fc58011529..4c0c8e134f99 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= lyx
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.3.6
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://planetmirror.com/pub/lyx/stable/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/
-MAINTAINER= thompsa@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
@@ -25,32 +24,43 @@ RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
CONFLICTS= cjk-lyx-*
+OPTIONS= QT "Use Qt (instead of XForms)" ${QT_PRESENT} \
+ ASPELL "Utilize ASPELL library" on \
+ ISPELL "Depend on ISPELL as well" off
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 reLyX.1
+USE_REINPLACE= yes
+
+post-configure:
+ # Removing explicit linking with -lc
+ ${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+
+.include <bsd.port.pre.mk>
.if defined(WITH_QT)
-USE_QT_VER= 3
+LIB_DEPENDS+= qt-mt:${PORTSDIR}/x11-toolkits/qt33
CONFIGURE_ARGS+= --with-frontend=qt
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
.else
-LIB_DEPENDS+= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS+= forms:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
.endif
.if defined(WITH_ASPELL)
-LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
@@ -60,32 +70,14 @@ CONFIGURE_ARGS+= --with-pspell \
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libqt-mt.prl)
+QT_PRESENT= on
+.else
+QT_PRESENT= off
+.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
.endif
-pre-everything::
-.if !defined(WITH_QT)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to build with the Qt3 frontend,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_QT=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ASPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Aspell/Pspell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ASPELL=yes\""
- @${ECHO_MSG}
-.endif
-
-.if !defined(WITH_ISPELL)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Ispell support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_ISPELL=yes\""
- @${ECHO_MSG}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/print/lyx16/distinfo b/print/lyx16/distinfo
index ee3cb95ae9d9..f490601bb5e8 100644
--- a/print/lyx16/distinfo
+++ b/print/lyx16/distinfo
@@ -1,2 +1,2 @@
-MD5 (lyx-1.3.5.tar.bz2) = f4c70d2565ba9c974b1f94fc1dfd63bf
-SIZE (lyx-1.3.5.tar.bz2) = 5459049
+MD5 (lyx-1.3.6.tar.bz2) = 26d745b98bdc32e9edfc28e581583f80
+SIZE (lyx-1.3.6.tar.bz2) = 5745377
diff --git a/print/lyx16/pkg-plist b/print/lyx16/pkg-plist
index f71884459749..58d89acc9eca 100644
--- a/print/lyx16/pkg-plist
+++ b/print/lyx16/pkg-plist
@@ -37,7 +37,6 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/chkconfig.ltx
%%DATADIR%%/clipart/platypus.eps
%%DATADIR%%/configure
-%%DATADIR%%/configure.cmd
%%DATADIR%%/doc/Customization.lyx
%%DATADIR%%/doc/DocStyle.lyx
%%DATADIR%%/doc/Extended.lyx
@@ -842,22 +841,19 @@ share/locale/sl/LC_MESSAGES/lyx.mo
%%DATADIR%%/layouts/svjog.layout
%%DATADIR%%/layouts/svjour.inc
%%DATADIR%%/layouts/svprobth.layout
-%%DATADIR%%/lyx2lyx/error.py
-%%DATADIR%%/lyx2lyx/error.pyc
%%DATADIR%%/lyx2lyx/lyx2lyx
-%%DATADIR%%/lyx2lyx/lyxconvert_210.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.py
-%%DATADIR%%/lyx2lyx/lyxconvert_215.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_216.py
-%%DATADIR%%/lyx2lyx/lyxconvert_216.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_217.py
-%%DATADIR%%/lyx2lyx/lyxconvert_217.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_218.py
-%%DATADIR%%/lyx2lyx/lyxconvert_218.pyc
-%%DATADIR%%/lyx2lyx/lyxconvert_220.py
-%%DATADIR%%/lyx2lyx/lyxconvert_220.pyc
-%%DATADIR%%/lyx2lyx/parser_tools.py
-%%DATADIR%%/lyx2lyx/parser_tools.pyc
+%%DATADIR%%/lyx2lyx/LyX.py
+%%DATADIR%%/lyx2lyx/lyx_0_12.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_0.py
+%%DATADIR%%/lyx2lyx/lyx_1_0_1.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_4.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_5.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6.py
+%%DATADIR%%/lyx2lyx/lyx_1_1_6fix3.py
+%%DATADIR%%/lyx2lyx/lyx_1_2.py
+%%DATADIR%%/lyx2lyx/lyx_1_3.py
+%%DATADIR%%/lyx2lyx/lyx_1_4.py
+%%DATADIR%%/lyx2lyx/profiling.py
%%DATADIR%%/lyxrc.defaults
%%DATADIR%%/lyxrc.example
%%DATADIR%%/packages.lst