aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-01-24 18:54:29 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-01-24 18:54:29 +0000
commitb6ac0605aa1fdc0feaaba66a5d2b9bb358834039 (patch)
treec64be38d30cc328404a5552e35313e24c63485b1 /print
parent7f3c04b11593ddc66d649ae121f33f92bdfed86b (diff)
downloadports-b6ac0605aa1fdc0feaaba66a5d2b9bb358834039.tar.gz
ports-b6ac0605aa1fdc0feaaba66a5d2b9bb358834039.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/lilypond/Makefile6
-rw-r--r--print/lilypond/files/patch-mf:GNUMakefile2
-rw-r--r--print/lilypond/scripts/post-configure4
-rw-r--r--print/lilypond/scripts/post-patch4
4 files changed, 6 insertions, 10 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index cc6ed035e3b2..872bdcce21e4 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -57,10 +57,6 @@ CFLAGS+= ${CPPFLAGS}
.include <bsd.port.pre.mk>
ALL_TARGET= all
-.if ${OSVERSION} >= 502120
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${OSVERSION} < 500000
USE_GCC= 3.4
.endif
@@ -83,7 +79,7 @@ pre-configure:
.if !defined(WITH_SELFBUILT_FONTS)
post-configure:
- cd ${WRKSRC} && ${GMAKE} -C mf get-pfa
+ cd ${WRKSRC} && ${GMAKE} -C mf get-pfa DISTDIR=${DISTDIR}
.endif
post-install:
diff --git a/print/lilypond/files/patch-mf:GNUMakefile b/print/lilypond/files/patch-mf:GNUMakefile
index be812ad1539d..0862b73e0345 100644
--- a/print/lilypond/files/patch-mf:GNUMakefile
+++ b/print/lilypond/files/patch-mf:GNUMakefile
@@ -10,7 +10,7 @@
@echo "For obtaining PFA fonts, either install mftrace "
@echo "(see http://www.xs4all.nl/~hanwen/mftrace/ ),"
- @echo "or try one of the following commands in this directory: "
-+ @echo "or try one of the following commands in /usr/ports/print/lilypond/work/lilypond-2.2.2"
++ @echo "or try one of the following commands in /usr/ports/print/lilypond/work/lilypond-$(TOPLEVEL_VERSION)"
@echo ""
- @echo " make get-pfa "
- @echo " make get-rpm-pfa "
diff --git a/print/lilypond/scripts/post-configure b/print/lilypond/scripts/post-configure
index 713c4d692b10..32ff6afe2fcf 100644
--- a/print/lilypond/scripts/post-configure
+++ b/print/lilypond/scripts/post-configure
@@ -7,8 +7,8 @@ cd ${WRKSRC} || exit 2
gmake conf=$CONF -C lily $outdir/lexer.cc || true
mv $file $file.orig
- sed -e 's/istream\*/std::istream*/g' \
- -e 's/ostream\*/std::ostream*/g' \
+ sed -e 's/[^:]istream\*/std::istream*/g' \
+ -e 's/[^:]ostream\*/std::ostream*/g' \
-e 's/class istream;/#include \<iostream\>/g' \
$file.orig > $file
echo "done"
diff --git a/print/lilypond/scripts/post-patch b/print/lilypond/scripts/post-patch
index aff5fb958c45..9b09186e2d60 100644
--- a/print/lilypond/scripts/post-patch
+++ b/print/lilypond/scripts/post-patch
@@ -13,8 +13,8 @@ echo -n "Copying and fixing $file... "
mkdir -p lily/$outdir
rm -f lily/$outdir/FlexLexer.h
sed \
- -e 's/istream/std::istream/' \
- -e 's/[^i]ostream/std::ostream/' \
+ -e 's/[^:]istream/std::istream/' \
+ -e 's/[^i:]ostream/std::ostream/' \
-e 's/iostream.h/iostream/' \
$file > lily/$outdir/FlexLexer.h
echo "done"