aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
commitf935a609c53c5c6031e6848db95c7debed127e27 (patch)
tree4c3cf6af6588247c0dd3f92f9601357c33c56217 /print
parent703b5eb18b542fec0e78704ada72142cd2b33175 (diff)
downloadports-f935a609c53c5c6031e6848db95c7debed127e27.tar.gz
ports-f935a609c53c5c6031e6848db95c7debed127e27.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/auctex/Makefile3
-rw-r--r--print/gtklp/Makefile1
-rw-r--r--print/gutenprint-base/Makefile4
-rw-r--r--print/gv/Makefile4
-rw-r--r--print/libpaper/Makefile2
-rw-r--r--print/lilypond/Makefile3
-rw-r--r--print/pslib/Makefile1
-rw-r--r--print/texinfo/Makefile1
-rw-r--r--print/typetools/Makefile2
9 files changed, 6 insertions, 15 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index 56b8b484e15d..39784bfe686c 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -22,8 +22,7 @@ USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
--with-auto-dir=${PREFIX}/${LISPDIR}/auctex/auto \
- --with-texmf-dir=${PREFIX}/${TEXMFDIR} \
- --infodir=${PREFIX}/info
+ --with-texmf-dir=${PREFIX}/${TEXMFDIR}
USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
diff --git a/print/gtklp/Makefile b/print/gtklp/Makefile
index 5cd9b49f83ce..8f14791c47db 100644
--- a/print/gtklp/Makefile
+++ b/print/gtklp/Makefile
@@ -26,7 +26,6 @@ CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= gtklp.1 gtklpq.1
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 5370a4234c12..fe617dc96b6f 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -26,8 +26,7 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS=--with-gimp=no --with-gimp2=no \
- --with-mandir=${PREFIX}/man
+CONFIGURE_ARGS=--with-gimp=no --with-gimp2=no
USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include -I${PREFIX}/include
@@ -107,7 +106,6 @@ post-patch:
${WRKSRC}/src/gimp2/Makefile.in
@${REINPLACE_CMD} -e 's|$$libdir/gimp/1.2/plug-ins||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e 's|= $$(pkglibdir)|= ${PREFIX}/libexec/cups|' \
${WRKSRC}/src/cups/Makefile.in
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 7348d6d1e0b5..f32bf3a05b26 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -25,9 +25,7 @@ USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --libdir=${PREFIX}/lib/X11 \
- --mandir=${MANPREFIX}/man \
- --infodir=${PREFIX}/${INFO_PATH}
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/X11
MAN1= gv.1
INFO= gv
diff --git a/print/libpaper/Makefile b/print/libpaper/Makefile
index d8bf8a4a061e..575992b6af8c 100644
--- a/print/libpaper/Makefile
+++ b/print/libpaper/Makefile
@@ -19,7 +19,7 @@ COMMENT= A library providing routines for paper size management
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --build=${CONFIGURE_TARGET} --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --build=${CONFIGURE_TARGET}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index db854a243e82..c1853a9b3d80 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -41,8 +41,7 @@ MAKEFILE= GNUmakefile
PKGINSTALL= ${WRKDIR}/pkg-install
CONFIGURE_ARGS+= --with-kpathsea-include=${LOCALBASE}/include \
- --with-kpathsea-lib=${LOCALBASE}/lib \
- --infodir=${PREFIX}/info
+ --with-kpathsea-lib=${LOCALBASE}/lib
CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
.if defined(WITH_SELFBUILT_FONTS)
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index d2a1ea1a3547..12ca6d4b42a4 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -24,7 +24,6 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
USE_LDCONFIG= yes
OPTIONS= EXAMPLES "Install additional examples" On \
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index d81d240b3724..55642c2f5ae3 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -25,7 +25,6 @@ PKGDEINSTALL= ${PKGINSTALL}
MAKE_ARGS= TEXMF=${PREFIX}/${TEXMFLOCAL}
CONFIGURE_ARGS= \
- --infodir=${PREFIX}/${INFO_PATH} \
--without-included-gettext
CONFIGURE_ENV= \
CPPFLAGS="-I${LOCALBASE}/lib" \
diff --git a/print/typetools/Makefile b/print/typetools/Makefile
index eb38213dbdb0..bb5c764c0735 100644
--- a/print/typetools/Makefile
+++ b/print/typetools/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libkpathsea.a:${PORTSDIR}/print/teTeX-base
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-kpathsea=${LOCALBASE} --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS= --with-kpathsea=${LOCALBASE}
MAN1= cfftot1.1 mmafm.1 mmpfb.1 otfinfo.1 otftotfm.1 t1dotlessj.1 \
t1lint.1 t1reencode.1 t1testpage.1 ttftotype42.1