aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-10-30 18:08:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-11 13:50:53 +0000
commit45526ecbeec33dbb87f0b678d4c04988aab9b657 (patch)
treeb77614b463af0ed929512fcc838ff5cb20c96275 /print
parenta148ebec4e0afe980f949de0dea5ef4931cb7e86 (diff)
downloadports-45526ecbeec33dbb87f0b678d4c04988aab9b657.tar.gz
ports-45526ecbeec33dbb87f0b678d4c04988aab9b657.zip
framework: Add new USES 'magick' for graphics/ImageMagick*
A new USES has been added to depend on ImageMagick. USES=magick adds a LIB_DEPENDS on graphics/ImageMagick${IMAGEMAGICK_DEFAULT}. If a specific version is required, use for example USES=magick:6 resp. USES=magick:7 If only a build, run or test is required, use for example USES=magick:build resp. USES=magick:6,build,test If a dependency on the nox11 flavor is required, use for example USES=magick:nox11 resp. USES=magick:7,nox11,run,test See magick.mk for more details on the available flags. The tree has been completely converted to make use of this. Approved by: bapt Differential Revision: https://reviews.freebsd.org/D32754
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile4
-rw-r--r--print/html2ps/Makefile5
-rw-r--r--print/latex2rtf/Makefile2
-rw-r--r--print/lilypond-devel/Makefile3
-rw-r--r--print/lilypond/Makefile3
-rw-r--r--print/muttprint/Makefile4
-rw-r--r--print/pdf-redact-tools/Makefile5
-rw-r--r--print/pdf-tools/Makefile5
-rw-r--r--print/texvc/Makefile3
9 files changed, 14 insertions, 20 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index b680a662265c..97cbbb0b593b 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -56,11 +56,11 @@ OPTIONS_SUB= yes
BRAILLE_CONFIGURE_ENABLE= braille
BRAILLE_DESC= Braille embosser support
+BRAILLE_USES= magick:run
BRAILLE_BUILD_DEPENDS= bash:shells/bash
BRAILLE_LIB_DEPENDS= liblouis.so:devel/liblouis \
# liblouisutdml.so:devel/liblouisutdml
-BRAILLE_RUN_DEPENDS= convert:graphics/ImageMagick${IMAGEMAGICK_DEFAULT} \
- pdftotext:graphics/poppler-utils \
+BRAILLE_RUN_DEPENDS= pdftotext:graphics/poppler-utils \
bash:shells/bash
COLORD_CONFIGURE_ENABLE= dbus
diff --git a/print/html2ps/Makefile b/print/html2ps/Makefile
index ade49fadc83e..d03fe002ecfa 100644
--- a/print/html2ps/Makefile
+++ b/print/html2ps/Makefile
@@ -13,13 +13,12 @@ COMMENT= HTML to PostScript converter
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= mogrify:graphics/ImageMagick6 \
- p5-libwww>=0:www/p5-libwww \
+RUN_DEPENDS= p5-libwww>=0:www/p5-libwww \
weblint++:www/weblint++ \
paperconf:print/libpaper
NO_BUILD= yes
-USES= ghostscript:run perl5
+USES= ghostscript:run magick:6,run perl5
SUB_FILES= html2psrc
diff --git a/print/latex2rtf/Makefile b/print/latex2rtf/Makefile
index 6c0b64c77885..d1a151303efe 100644
--- a/print/latex2rtf/Makefile
+++ b/print/latex2rtf/Makefile
@@ -18,8 +18,8 @@ OPTIONS_DEFINE= LATEX2PNG
LATEX2PNG_DESC= Install latex2png utility
OPTIONS_SUB= yes
+LATEX2PNG_USES= magick:6,run
LATEX2PNG_USE= TEX=dvipsk,latex,xetex
-LATEX2PNG_RUN_DEPENDS= convert:graphics/ImageMagick6
MAKE_ARGS+= MANDIR=${PREFIX}/man/man1 CFGDIR=${DATADIR}/cfg \
BINDIR=${PREFIX}/bin
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index ea4400ce8749..fd4e13c0ba4c 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -12,7 +12,6 @@ COMMENT= GNU music typesetter
LICENSE= GPLv3
BUILD_DEPENDS= bash:shells/bash \
- convert:graphics/ImageMagick7 \
dblatex:textproc/dblatex \
fontforge:print/fontforge \
help2man:misc/help2man \
@@ -30,7 +29,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu \
mftrace:print/mftrace
-USES= bison:build compiler:c++11-lib cpe ghostscript gmake gnome perl5 \
+USES= bison:build compiler:c++11-lib cpe ghostscript gmake gnome magick:7,build perl5 \
pkgconfig python:3.5+
USE_CXXSTD= c++11
USE_GNOME= pango
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 4e67611c670c..8c32aa5f7a38 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -12,7 +12,6 @@ COMMENT= GNU music typesetter
LICENSE= GPLv3
BUILD_DEPENDS= bash:shells/bash \
- convert:graphics/ImageMagick7 \
dblatex:textproc/dblatex \
fontforge:print/fontforge \
help2man:misc/help2man \
@@ -30,7 +29,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejav
mftrace:print/mftrace
USES= bison:build compiler:c++11-lib cpe ghostscript gmake gnome \
- perl5 pkgconfig python:3.5+
+ magick:7,build perl5 pkgconfig python:3.5+
USE_CXXSTD= c++11
USE_GNOME= pango
USE_PERL5= build
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index d4dcc5171d31..6e63e0aca984 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -45,9 +45,9 @@ PRINT_COMMAND=lpr -P$$PRINTER
.endif
.if ${PORT_OPTIONS:MX11}
-RUN_DEPENDS+= convert:graphics/ImageMagick6
+USES+= magick:6,run
.else
-RUN_DEPENDS+= convert:graphics/ImageMagick6-nox11
+USES+= magick:6,run,nox11
.endif
pre-everything::
diff --git a/print/pdf-redact-tools/Makefile b/print/pdf-redact-tools/Makefile
index cbfdfe9f914f..8d1611745205 100644
--- a/print/pdf-redact-tools/Makefile
+++ b/print/pdf-redact-tools/Makefile
@@ -13,10 +13,9 @@ COMMENT= Securely redact and strip metadata from PDF files
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= exiftool:graphics/p5-Image-ExifTool \
- convert:graphics/ImageMagick6
+RUN_DEPENDS= exiftool:graphics/p5-Image-ExifTool
-USES= python:3.6+
+USES= magick:6,run python:3.6+
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils
diff --git a/print/pdf-tools/Makefile b/print/pdf-tools/Makefile
index 76e9d57ff593..5ee16d5c0ef7 100644
--- a/print/pdf-tools/Makefile
+++ b/print/pdf-tools/Makefile
@@ -15,13 +15,12 @@ BROKEN_FreeBSD_12_powerpc64= fails to configure on powerpc64 elfv1: cannot find
BUILD_DEPENDS= cask${EMACS_PKGNAMESUFFIX}>0:devel/cask@${EMACS_FLAVOR} \
tablist${EMACS_PKGNAMESUFFIX}>=0.70.4:devel/tablist@${EMACS_FLAVOR}
-LIB_DEPENDS= libMagickCore-7.so:graphics/ImageMagick7 \
- libpng.so:graphics/png \
+LIB_DEPENDS= libpng.so:graphics/png \
libpoppler-glib.so:graphics/poppler-glib \
libpoppler.so:graphics/poppler
RUN_DEPENDS= tablist${EMACS_PKGNAMESUFFIX}>=0.70:devel/tablist@${EMACS_FLAVOR}
-USES= autoreconf:build emacs gettext-runtime gmake gnome
+USES= autoreconf:build emacs gettext-runtime gmake gnome magick:7
USE_GITHUB= yes
GH_ACCOUNT= vedang
USE_GNOME= cairo glib20
diff --git a/print/texvc/Makefile b/print/texvc/Makefile
index 6c9c3228970e..f9a506ee804b 100644
--- a/print/texvc/Makefile
+++ b/print/texvc/Makefile
@@ -19,9 +19,8 @@ OPTIONS_DEFINE= RASTER
OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
RASTER_DESC= rasterization support
-RASTER_USES= ghostscript:run
+RASTER_USES= ghostscript:run magick:6,run
RASTER_USE= TEX=latex,dvipsk
-RASTER_RUN_DEPENDS= convert:graphics/ImageMagick6
MAKE_JOBS_UNSAFE= yes