aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
commit6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /print
parentb8355694f11dec2ab058a135acfc1a0f3c8967c0 (diff)
downloadports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.tar.gz
ports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile2
-rw-r--r--print/cups-filters/Makefile5
-rw-r--r--print/fontforge/Makefile3
-rw-r--r--print/ghostscript7/Makefile5
-rw-r--r--print/ghostscript8/Makefile3
-rw-r--r--print/ghostscript9-agpl/Makefile3
-rw-r--r--print/ghostscript9/Makefile3
-rw-r--r--print/hpijs/Makefile3
-rw-r--r--print/hplip/Makefile5
-rw-r--r--print/panda/Makefile5
-rw-r--r--print/photoprint/Makefile3
-rw-r--r--print/pslib/Makefile5
-rw-r--r--print/scribus/Makefile5
13 files changed, 19 insertions, 31 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 0fa56711c6b0..6f8ec53bdcb8 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -96,11 +96,11 @@ PKGMESSAGE= ${NONEXISTENT}
DESCR= ${MASTERDIR}/pkg-descr.client
.elif defined(CUPS_IMAGE)
LIB_DEPENDS+= libcups.so:${PORTSDIR}/${PKGCATEGORY}/cups-client \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
# force build if old cups is installed.
BUILD_DEPENDS+= cups-client${PKGNAMESUFFIX2}>=${PORTVERSION}:${PORTSDIR}/${PKGCATEGORY}/cups-client
+USES+= jpeg
COMMENT2= Library cupsimage
INSTALL_WRKSRC= ${WRKSRC}/filter
PLIST= ${MASTERDIR}/pkg-plist.image
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 081be392edeb..f74cc173c3a8 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -10,8 +10,7 @@ COMMENT= Backends, filters and other software (was part of the core CUPS)
BUILD_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
RUN_DEPENDS= pdftops:${PORTSDIR}/graphics/poppler-utils
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libtiff.so:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libpng.so:${PORTSDIR}/graphics/png \
libijs.so:${PORTSDIR}/print/libijs \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
@@ -24,7 +23,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpoppler.so:${PORTSDIR}/graphics/poppler
MAKE_JOBS_UNSAFE=YES
-USES= compiler:c++11-lib cpe libtool pathfix pkgconfig shebangfix tar:xz
+USES= compiler:c++11-lib cpe jpeg libtool pathfix pkgconfig shebangfix tar:xz
CPE_VENDOR= linuxfoundation
SHEBANG_FILES= filter/textonly
USE_GNOME= glib20
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index 03c1860ef591..e953202896ea 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -16,7 +16,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:${PORTSDIR}/devel/uthash \
${LOCALBASE}/bin/gnulib-tool:${PORTSDIR}/devel/gnulib
LIB_DEPENDS= libuninameslist.so:${PORTSDIR}/textproc/libuninameslist \
libtiff.so:${PORTSDIR}/graphics/tiff \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libgif.so:${PORTSDIR}/graphics/giflib \
libspiro.so:${PORTSDIR}/graphics/libspiro \
@@ -26,7 +25,7 @@ LIB_DEPENDS= libuninameslist.so:${PORTSDIR}/textproc/libuninameslist \
USE_GITHUB= yes
USES= autoreconf:build desktop-file-utils execinfo gettext gmake iconv \
- libtool pkgconfig python shared-mime-info
+ jpeg libtool pkgconfig python shared-mime-info
USE_XORG= x11 xi ice xkbui
USE_GNOME= glib20 gtk20 libxml2 pango
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 4faa29c3c65f..9d137c325d4b 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -18,8 +18,7 @@ COMMENT= Ghostscript 7.x PostScript interpreter
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
CONFLICTS_INSTALL= \
@@ -29,7 +28,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= tar:bzip2 gmake shebangfix
+USES= gmake jpeg shebangfix tar:bzip2
USE_LDCONFIG= yes
SHEBANG_FILES= lib/fixmswrd.pl
WANT_GNOME= yes
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index f7b79758ac6a..4554f87c07f0 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -23,7 +23,6 @@ LICENSE= GPLv3
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libjasper.so:${PORTSDIR}/graphics/jasper \
libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libpaper.so:${PORTSDIR}/print/libpaper \
libtiff.so:${PORTSDIR}/graphics/tiff
@@ -36,7 +35,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= gmake pkgconfig tar:xz shebangfix
+USES= gmake jpeg pkgconfig tar:xz shebangfix
SHEBANG_FILES= ${WRKSRC}/lib/fixmswrd.pl
WANT_GNOME= yes
USE_LDCONFIG= yes
diff --git a/print/ghostscript9-agpl/Makefile b/print/ghostscript9-agpl/Makefile
index 31cd9df0b04e..de2b4d31a709 100644
--- a/print/ghostscript9-agpl/Makefile
+++ b/print/ghostscript9-agpl/Makefile
@@ -22,7 +22,6 @@ LICENSE= AGPLv3
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libidn.so:${PORTSDIR}/dns/libidn \
libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
@@ -34,7 +33,7 @@ CONFLICTS_INSTALL= \
ghostscript[789]-[0-9]* \
ghostscript[789]-nox11-[0-9]*
-USES= gmake pkgconfig:build tar:bzip2
+USES= gmake jpeg pkgconfig:build tar:bzip2
WANT_GNOME= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf
diff --git a/print/ghostscript9/Makefile b/print/ghostscript9/Makefile
index a051395bd726..88d4db4b6113 100644
--- a/print/ghostscript9/Makefile
+++ b/print/ghostscript9/Makefile
@@ -22,7 +22,6 @@ LICENSE= GPLv3
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
libidn.so:${PORTSDIR}/dns/libidn \
libjbig2dec.so:${PORTSDIR}/graphics/jbig2dec \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
@@ -36,7 +35,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= gmake pkgconfig:build tar:bzip2
+USES= gmake jpeg pkgconfig:build tar:bzip2
WANT_GNOME= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= autoconf
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index f5f0ad4df9ff..eed870e93813 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -9,12 +9,11 @@ MASTER_SITES= SF/hpinkjet/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Drivers and support resources for HP Inkjet Printers
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
-
CONFLICTS= hplip-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking
+USES= jpeg
USE_GHOSTSCRIPT_RUN= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 31e2940d7224..80efd33160bc 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
COMMENT= Drivers and utilities for HP Printers and All-in-One devices
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libcupsmime.so:${PORTSDIR}/print/cups-base \
+LIB_DEPENDS= libcupsmime.so:${PORTSDIR}/print/cups-base \
libcups.so:${PORTSDIR}/print/cups-client \
libcupsimage.so:${PORTSDIR}/print/cups-image \
libdbus-1.so:${PORTSDIR}/devel/dbus
@@ -22,7 +21,7 @@ RUN_DEPENDS= espgs:${PORTSDIR}/print/cups-pstoraster \
CONFLICTS_INSTALL= hpijs-[0-9]*
INSTALL_TARGET= install-strip
-USES= dos2unix libtool pkgconfig python shebangfix
+USES= dos2unix jpeg libtool pkgconfig python shebangfix
USE_GHOSTSCRIPT_RUN= yes
USE_GNOME= pygobject
USE_LDCONFIG= yes
diff --git a/print/panda/Makefile b/print/panda/Makefile
index a334faad967a..fd078b2b35df 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -15,8 +15,7 @@ COMMENT= PDF generation library
LICENSE= GPLv2 LGPL21
LICENSE_COMB= dual
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
@@ -24,7 +23,7 @@ CONFIGURE_ARGS= --enable-berkeley-db
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LIBS+= -L${BDB_LIB_DIR} -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-USES= autoreconf gmake libtool pathfix pkgconfig tar:bzip2
+USES= autoreconf gmake jpeg libtool pathfix pkgconfig tar:bzip2
PATHFIX_MAKEFILEIN= Makefile.am
USE_BDB= yes
USE_LDCONFIG= yes
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index addd8e740681..c4126f2a258d 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -13,14 +13,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
libgutenprint.so:${PORTSDIR}/print/gutenprint-base \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
liblcms.so:${PORTSDIR}/graphics/lcms \
libnetpbm.so:${PORTSDIR}/graphics/netpbm \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext libtool pkgconfig
+USES= desktop-file-utils gettext jpeg libtool pkgconfig
USE_GNOME= gdkpixbuf2 gtk20
USE_XORG= x11
INSTALLS_ICONS= yes
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 7354410443f9..6e81a1c26781 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -12,11 +12,10 @@ COMMENT= C-library for generating multi page PostScript documents
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake jpeg libtool pathfix pkgconfig
USE_GNOME= intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 389951a8232f..c910b96c8264 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= SF \
MAINTAINER= bsam@FreeBSD.org
COMMENT= Comprehensive desktop publishing program
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms.so:${PORTSDIR}/graphics/lcms \
+LIB_DEPENDS= liblcms.so:${PORTSDIR}/graphics/lcms \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff \
libcups.so:${PORTSDIR}/print/cups-client \
@@ -29,7 +28,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinte
USE_QT4= gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= libartlgpl2 libxml2
USE_GHOSTSCRIPT_RUN= yes
-USES= cmake desktop-file-utils pkgconfig python shared-mime-info tar:xz
+USES= cmake desktop-file-utils jpeg pkgconfig python shared-mime-info tar:xz
USE_LDCONFIG= yes
CMAKE_ARGS+= -DWANT_HUNSPELL=YES -Wno-ferror-limit