aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-05-24 16:40:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-05-24 16:40:40 +0000
commit098684c9fc670abbaa3496460a5ebbca0878a0e2 (patch)
tree702f527ad954ec95bb72edc3540b51c832688422 /print
parentf4c797be18ff8e3d10998a9b73e5caafb2fb4e39 (diff)
downloadports-098684c9fc670abbaa3496460a5ebbca0878a0e2.tar.gz
ports-098684c9fc670abbaa3496460a5ebbca0878a0e2.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-ucs/Makefile62
-rw-r--r--print/latex-ucs/distinfo2
-rw-r--r--print/latex-ucs/pkg-descr4
-rw-r--r--print/latex-ucs/pkg-plist188
5 files changed, 257 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 8fdc445834e9..855a396910e0 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -117,6 +117,7 @@
SUBDIR += latex-subfig
SUBDIR += latex-subfloat
SUBDIR += latex-timing
+ SUBDIR += latex-ucs
SUBDIR += latex-xcolor
SUBDIR += latex2rtf
SUBDIR += latex2slides
diff --git a/print/latex-ucs/Makefile b/print/latex-ucs/Makefile
new file mode 100644
index 000000000000..586d2987ee0b
--- /dev/null
+++ b/print/latex-ucs/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: latex-ucs
+# Date created: 23 May 2004
+# Whom: thierry@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-ucs
+PORTVERSION= 20040307
+CATEGORIES= print
+MASTER_SITES= http://www.unruh.de/DniQ/latex/unicode/
+DISTNAME= unicode
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A LaTeX package for using UTF-8 as input encoding
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
+.if !defined(WITHOUT_CJK)
+PLIST_SUB+= CJK=""
+.else
+PLIST_SUB+= CJK="@comment "
+.endif
+
+TEXMF?= share/texmf
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMF}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= ucs.sty utf8.def ucsencs.def
+CJK_FILES= c00enc.def c10enc.def c40enc.def c42enc.def c61enc.def
+PLSCRIPTS= discovermacro.pl latexout.pl makeunidef.pl
+PORTDOCS= FAQ INSTALL LICENSE README VERSION
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you don't need CJK characters, please define WITHOUT_CJK."
+ @${ECHO_MSG} ""
+
+do-install:
+ ${INSTALL_SCRIPT} ${PLSCRIPTS:S@^@${WRKSRC}/@} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(WITHOUT_CJK)
+ ${INSTALL_DATA} ${CJK_FILES:S@^@${WRKSRC}/contrib/@} ${PREFIX}/${CLASSDIR}
+.endif
+ ${CP} -R ${WRKSRC}/data ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-ucs/distinfo b/print/latex-ucs/distinfo
new file mode 100644
index 000000000000..98c98d6b4d3f
--- /dev/null
+++ b/print/latex-ucs/distinfo
@@ -0,0 +1,2 @@
+MD5 (latex-ucs-20040307/unicode.tgz) = f7d283d3c8a07f1031e27f63b6d3a64b
+SIZE (latex-ucs-20040307/unicode.tgz) = 1067654
diff --git a/print/latex-ucs/pkg-descr b/print/latex-ucs/pkg-descr
new file mode 100644
index 000000000000..541da31b7199
--- /dev/null
+++ b/print/latex-ucs/pkg-descr
@@ -0,0 +1,4 @@
+This package contains support for using UTF-8 as input encoding in
+LaTeX documents.
+
+WWW: http://www.unruh.de/DniQ/latex/unicode/
diff --git a/print/latex-ucs/pkg-plist b/print/latex-ucs/pkg-plist
new file mode 100644
index 000000000000..faed16c79cc0
--- /dev/null
+++ b/print/latex-ucs/pkg-plist
@@ -0,0 +1,188 @@
+bin/discovermacro.pl
+bin/latexout.pl
+bin/makeunidef.pl
+%%CLASSDIR%%/ucs.sty
+%%CLASSDIR%%/ucsencs.def
+%%CLASSDIR%%/utf8.def
+%%CJK%%%%CLASSDIR%%/c00enc.def
+%%CJK%%%%CLASSDIR%%/c10enc.def
+%%CJK%%%%CLASSDIR%%/c40enc.def
+%%CJK%%%%CLASSDIR%%/c42enc.def
+%%CJK%%%%CLASSDIR%%/c61enc.def
+%%CLASSDIR%%/data/uni-0.def
+%%CLASSDIR%%/data/uni-1.def
+%%CLASSDIR%%/data/uni-100.def
+%%CLASSDIR%%/data/uni-101.def
+%%CLASSDIR%%/data/uni-102.def
+%%CLASSDIR%%/data/uni-103.def
+%%CLASSDIR%%/data/uni-104.def
+%%CLASSDIR%%/data/uni-105.def
+%%CLASSDIR%%/data/uni-106.def
+%%CLASSDIR%%/data/uni-107.def
+%%CLASSDIR%%/data/uni-108.def
+%%CLASSDIR%%/data/uni-109.def
+%%CLASSDIR%%/data/uni-110.def
+%%CLASSDIR%%/data/uni-111.def
+%%CLASSDIR%%/data/uni-112.def
+%%CLASSDIR%%/data/uni-113.def
+%%CLASSDIR%%/data/uni-114.def
+%%CLASSDIR%%/data/uni-115.def
+%%CLASSDIR%%/data/uni-116.def
+%%CLASSDIR%%/data/uni-117.def
+%%CLASSDIR%%/data/uni-118.def
+%%CLASSDIR%%/data/uni-119.def
+%%CLASSDIR%%/data/uni-12.def
+%%CLASSDIR%%/data/uni-120.def
+%%CLASSDIR%%/data/uni-121.def
+%%CLASSDIR%%/data/uni-122.def
+%%CLASSDIR%%/data/uni-123.def
+%%CLASSDIR%%/data/uni-124.def
+%%CLASSDIR%%/data/uni-125.def
+%%CLASSDIR%%/data/uni-126.def
+%%CLASSDIR%%/data/uni-127.def
+%%CLASSDIR%%/data/uni-128.def
+%%CLASSDIR%%/data/uni-129.def
+%%CLASSDIR%%/data/uni-130.def
+%%CLASSDIR%%/data/uni-131.def
+%%CLASSDIR%%/data/uni-132.def
+%%CLASSDIR%%/data/uni-133.def
+%%CLASSDIR%%/data/uni-134.def
+%%CLASSDIR%%/data/uni-135.def
+%%CLASSDIR%%/data/uni-136.def
+%%CLASSDIR%%/data/uni-137.def
+%%CLASSDIR%%/data/uni-138.def
+%%CLASSDIR%%/data/uni-139.def
+%%CLASSDIR%%/data/uni-14.def
+%%CLASSDIR%%/data/uni-140.def
+%%CLASSDIR%%/data/uni-141.def
+%%CLASSDIR%%/data/uni-142.def
+%%CLASSDIR%%/data/uni-143.def
+%%CLASSDIR%%/data/uni-144.def
+%%CLASSDIR%%/data/uni-145.def
+%%CLASSDIR%%/data/uni-146.def
+%%CLASSDIR%%/data/uni-147.def
+%%CLASSDIR%%/data/uni-148.def
+%%CLASSDIR%%/data/uni-149.def
+%%CLASSDIR%%/data/uni-150.def
+%%CLASSDIR%%/data/uni-151.def
+%%CLASSDIR%%/data/uni-152.def
+%%CLASSDIR%%/data/uni-153.def
+%%CLASSDIR%%/data/uni-154.def
+%%CLASSDIR%%/data/uni-155.def
+%%CLASSDIR%%/data/uni-156.def
+%%CLASSDIR%%/data/uni-157.def
+%%CLASSDIR%%/data/uni-158.def
+%%CLASSDIR%%/data/uni-159.def
+%%CLASSDIR%%/data/uni-172.def
+%%CLASSDIR%%/data/uni-173.def
+%%CLASSDIR%%/data/uni-174.def
+%%CLASSDIR%%/data/uni-175.def
+%%CLASSDIR%%/data/uni-176.def
+%%CLASSDIR%%/data/uni-177.def
+%%CLASSDIR%%/data/uni-178.def
+%%CLASSDIR%%/data/uni-179.def
+%%CLASSDIR%%/data/uni-18.def
+%%CLASSDIR%%/data/uni-180.def
+%%CLASSDIR%%/data/uni-181.def
+%%CLASSDIR%%/data/uni-182.def
+%%CLASSDIR%%/data/uni-183.def
+%%CLASSDIR%%/data/uni-184.def
+%%CLASSDIR%%/data/uni-185.def
+%%CLASSDIR%%/data/uni-186.def
+%%CLASSDIR%%/data/uni-187.def
+%%CLASSDIR%%/data/uni-188.def
+%%CLASSDIR%%/data/uni-189.def
+%%CLASSDIR%%/data/uni-19.def
+%%CLASSDIR%%/data/uni-190.def
+%%CLASSDIR%%/data/uni-191.def
+%%CLASSDIR%%/data/uni-192.def
+%%CLASSDIR%%/data/uni-193.def
+%%CLASSDIR%%/data/uni-194.def
+%%CLASSDIR%%/data/uni-195.def
+%%CLASSDIR%%/data/uni-196.def
+%%CLASSDIR%%/data/uni-197.def
+%%CLASSDIR%%/data/uni-198.def
+%%CLASSDIR%%/data/uni-199.def
+%%CLASSDIR%%/data/uni-2.def
+%%CLASSDIR%%/data/uni-200.def
+%%CLASSDIR%%/data/uni-201.def
+%%CLASSDIR%%/data/uni-202.def
+%%CLASSDIR%%/data/uni-203.def
+%%CLASSDIR%%/data/uni-204.def
+%%CLASSDIR%%/data/uni-205.def
+%%CLASSDIR%%/data/uni-206.def
+%%CLASSDIR%%/data/uni-207.def
+%%CLASSDIR%%/data/uni-208.def
+%%CLASSDIR%%/data/uni-209.def
+%%CLASSDIR%%/data/uni-210.def
+%%CLASSDIR%%/data/uni-211.def
+%%CLASSDIR%%/data/uni-212.def
+%%CLASSDIR%%/data/uni-213.def
+%%CLASSDIR%%/data/uni-214.def
+%%CLASSDIR%%/data/uni-215.def
+%%CLASSDIR%%/data/uni-24.def
+%%CLASSDIR%%/data/uni-248.def
+%%CLASSDIR%%/data/uni-249.def
+%%CLASSDIR%%/data/uni-250.def
+%%CLASSDIR%%/data/uni-251.def
+%%CLASSDIR%%/data/uni-254.def
+%%CLASSDIR%%/data/uni-255.def
+%%CLASSDIR%%/data/uni-29.def
+%%CLASSDIR%%/data/uni-3.def
+%%CLASSDIR%%/data/uni-30.def
+%%CLASSDIR%%/data/uni-31.def
+%%CLASSDIR%%/data/uni-32.def
+%%CLASSDIR%%/data/uni-33.def
+%%CLASSDIR%%/data/uni-34.def
+%%CLASSDIR%%/data/uni-35.def
+%%CLASSDIR%%/data/uni-3584.def
+%%CLASSDIR%%/data/uni-36.def
+%%CLASSDIR%%/data/uni-37.def
+%%CLASSDIR%%/data/uni-38.def
+%%CLASSDIR%%/data/uni-39.def
+%%CLASSDIR%%/data/uni-4.def
+%%CLASSDIR%%/data/uni-40.def
+%%CLASSDIR%%/data/uni-42.def
+%%CLASSDIR%%/data/uni-46.def
+%%CLASSDIR%%/data/uni-468.def
+%%CLASSDIR%%/data/uni-469.def
+%%CLASSDIR%%/data/uni-47.def
+%%CLASSDIR%%/data/uni-470.def
+%%CLASSDIR%%/data/uni-471.def
+%%CLASSDIR%%/data/uni-48.def
+%%CLASSDIR%%/data/uni-49.def
+%%CLASSDIR%%/data/uni-5.def
+%%CLASSDIR%%/data/uni-50.def
+%%CLASSDIR%%/data/uni-51.def
+%%CLASSDIR%%/data/uni-760.def
+%%CLASSDIR%%/data/uni-761.def
+%%CLASSDIR%%/data/uni-762.def
+%%CLASSDIR%%/data/uni-78.def
+%%CLASSDIR%%/data/uni-79.def
+%%CLASSDIR%%/data/uni-80.def
+%%CLASSDIR%%/data/uni-81.def
+%%CLASSDIR%%/data/uni-82.def
+%%CLASSDIR%%/data/uni-83.def
+%%CLASSDIR%%/data/uni-84.def
+%%CLASSDIR%%/data/uni-85.def
+%%CLASSDIR%%/data/uni-86.def
+%%CLASSDIR%%/data/uni-87.def
+%%CLASSDIR%%/data/uni-88.def
+%%CLASSDIR%%/data/uni-89.def
+%%CLASSDIR%%/data/uni-9.def
+%%CLASSDIR%%/data/uni-90.def
+%%CLASSDIR%%/data/uni-91.def
+%%CLASSDIR%%/data/uni-92.def
+%%CLASSDIR%%/data/uni-93.def
+%%CLASSDIR%%/data/uni-94.def
+%%CLASSDIR%%/data/uni-95.def
+%%CLASSDIR%%/data/uni-96.def
+%%CLASSDIR%%/data/uni-97.def
+%%CLASSDIR%%/data/uni-98.def
+%%CLASSDIR%%/data/uni-99.def
+%%CLASSDIR%%/data/uni-global.def
+%%CLASSDIR%%/data/uninames.dat
+@dirrm %%CLASSDIR%%/data
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%