aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /print
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/cups-pk-helper/Makefile25
-rw-r--r--print/cups-pk-helper/distinfo3
-rw-r--r--print/cups-pk-helper/pkg-descr4
-rw-r--r--print/cups-pk-helper/pkg-plist4
-rw-r--r--print/freetype2/Makefile10
-rw-r--r--print/freetype2/distinfo6
-rw-r--r--print/freetype2/files/patch-builds::unix::freetype-config.in16
-rw-r--r--print/libgnomeprint/Makefile5
-rw-r--r--print/libgnomeprint/distinfo6
-rw-r--r--print/libgnomeprint/pkg-plist20
-rw-r--r--print/libspectre/Makefile17
-rw-r--r--print/libspectre/distinfo6
-rw-r--r--print/py-cups/Makefile4
-rw-r--r--print/py-cups/distinfo6
-rw-r--r--print/system-config-printer/Makefile13
-rw-r--r--print/system-config-printer/distinfo6
-rw-r--r--print/system-config-printer/files/patch-applet.py17
-rw-r--r--print/system-config-printer/files/patch-cupshelpers_cupshelpers.py16
-rw-r--r--print/system-config-printer/files/patch-pysmb.py19
-rw-r--r--print/system-config-printer/files/patch-system-config-printer.py40
-rw-r--r--print/system-config-printer/pkg-plist58
22 files changed, 184 insertions, 118 deletions
diff --git a/print/Makefile b/print/Makefile
index 11337c4534a9..94f7c94cf28a 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -52,6 +52,7 @@
SUBDIR += cups-image
SUBDIR += cups-magicolor
SUBDIR += cups-pdf
+ SUBDIR += cups-pk-helper
SUBDIR += cups-pstoraster
SUBDIR += cups-samba
SUBDIR += cups-smb-backend
diff --git a/print/cups-pk-helper/Makefile b/print/cups-pk-helper/Makefile
new file mode 100644
index 000000000000..566b879d8b73
--- /dev/null
+++ b/print/cups-pk-helper/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cups-pk-helper
+# Date created: 2009-12-29
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/print/cups-pk-helper/Makefile,v 1.1 2009/12/29 16:01:07 ahze Exp $
+
+PORTNAME= cups-pk-helper
+PORTVERSION= 0.0.4
+CATEGORIES= print
+MASTER_SITES= http://www.freedesktop.org/software/${PORTNAME}/
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= A helper that makes system-config-printer use PolicyKit
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ cups.2:${PORTSDIR}/print/cups-client \
+ polkit.2:${PORTSDIR}/sysutils/policykit
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/libs"
+
+.include <bsd.port.mk>
diff --git a/print/cups-pk-helper/distinfo b/print/cups-pk-helper/distinfo
new file mode 100644
index 000000000000..e2ed20a53acf
--- /dev/null
+++ b/print/cups-pk-helper/distinfo
@@ -0,0 +1,3 @@
+MD5 (cups-pk-helper-0.0.4.tar.bz2) = f01b83bbe35641b330efcff95bbaee7b
+SHA256 (cups-pk-helper-0.0.4.tar.bz2) = 85edaa3a931a167e519eaeb378bf52c5332879820989fff72310360ac23e7056
+SIZE (cups-pk-helper-0.0.4.tar.bz2) = 266120
diff --git a/print/cups-pk-helper/pkg-descr b/print/cups-pk-helper/pkg-descr
new file mode 100644
index 000000000000..7af6a7c456d8
--- /dev/null
+++ b/print/cups-pk-helper/pkg-descr
@@ -0,0 +1,4 @@
+Cups-pk-helper is an application which makes cups configuration interfaces
+available under control of PolicyKit.
+
+WWW: http://www.freedesktop.org/software/cups-pk-helper
diff --git a/print/cups-pk-helper/pkg-plist b/print/cups-pk-helper/pkg-plist
new file mode 100644
index 000000000000..d1d62a8cabb5
--- /dev/null
+++ b/print/cups-pk-helper/pkg-plist
@@ -0,0 +1,4 @@
+etc/dbus-1/system.d/org.opensuse.CupsPkHelper.Mechanism.conf
+libexec/cups-pk-helper-mechanism
+share/PolicyKit/policy/org.opensuse.cupspkhelper.mechanism.policy
+share/dbus-1/system-services/org.opensuse.CupsPkHelper.Mechanism.service
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index 6fb2273f60be..6059c3295951 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -3,11 +3,11 @@
# Whom: jseger@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports/print/freetype2/Makefile,v 1.19 2009/11/28 05:59:02 mezz Exp $
+# $MCom: ports/print/freetype2/Makefile,v 1.22 2010/03/16 19:33:10 mezz Exp $
#
PORTNAME= freetype2
-PORTVERSION= 2.3.11
+PORTVERSION= 2.3.12
CATEGORIES= print
MASTER_SITES= SF/freetype/${PORTNAME}/${PORTVERSION} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/freetype2/ \
@@ -27,7 +27,7 @@ MAKE_JOBS_SAFE= yes
MAKE_ENV= TOP=""
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnometarget pkgconfig
+USE_GNOME= gnometarget pkgconfig ltverhack:9
LIBTOOLFILES= builds/unix/configure
CONFIGURE_ARGS= --disable-nls
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
@@ -76,6 +76,10 @@ pre-patch:
${WRKSRC}/include/freetype/config/ftoption.h
.endif
+pre-configure:
+ @${REINPLACE_CMD} -e '/^LIBTOOL/s|LIBTOOL ?= $$(BUILD_DIR)/libtool|LIBTOOL := ${WRKDIR}/gnome-libtool|' \
+ ${WRKSRC}/builds/unix/unix-cc.in
+
post-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} setup)
diff --git a/print/freetype2/distinfo b/print/freetype2/distinfo
index cba91a34b1bd..717b22566daa 100644
--- a/print/freetype2/distinfo
+++ b/print/freetype2/distinfo
@@ -1,3 +1,3 @@
-MD5 (freetype-2.3.11.tar.bz2) = 519c7cbf5cbd72ffa822c66844d3114c
-SHA256 (freetype-2.3.11.tar.bz2) = 8a033b1e6018a1e9ea381b09b2347b02c6686bdf7e4ee86a6714b6b90f1e2ec9
-SIZE (freetype-2.3.11.tar.bz2) = 1446474
+MD5 (freetype-2.3.12.tar.bz2) = e974a82e5939be8e05ee65f07275d7c5
+SHA256 (freetype-2.3.12.tar.bz2) = 3b96438f016a62b676c1d2089c00ca777f710d19f6aefa66ccf068d360db3e92
+SIZE (freetype-2.3.12.tar.bz2) = 1453034
diff --git a/print/freetype2/files/patch-builds::unix::freetype-config.in b/print/freetype2/files/patch-builds::unix::freetype-config.in
index ca50202def2e..f45d886c84ac 100644
--- a/print/freetype2/files/patch-builds::unix::freetype-config.in
+++ b/print/freetype2/files/patch-builds::unix::freetype-config.in
@@ -1,17 +1,17 @@
---- builds/unix/freetype-config.in.orig Sun Jan 9 21:18:15 2005
-+++ builds/unix/freetype-config.in Sun Jan 9 21:18:57 2005
-@@ -105,12 +105,8 @@
+--- builds/unix/freetype-config.in.orig 2009-12-21 18:23:42.000000000 -0500
++++ builds/unix/freetype-config.in 2010-02-21 15:51:17.000000000 -0500
+@@ -131,12 +131,8 @@ if test "$echo_ft_version" = "yes" ; the
fi
if test "$echo_cflags" = "yes" ; then
-- cflags="-I$includedir/freetype2"
-- if test "$includedir" != "/usr/include" ; then
-- echo $cflags -I$includedir
+- cflags="-I${SYSROOT}$includedir/freetype2"
+- if test "${SYSROOT}$includedir" != "/usr/include" ; then
+- echo $cflags -I${SYSROOT}$includedir
- else
- echo $cflags
- fi
-+ cflags="-I@includedir@/freetype2 -I@includedir@"
-+ echo $cflags
++ cflags="-I@includedir@/freetype2 -I@includedir@"
++ echo $cflags
fi
if test "$echo_libs" = "yes" ; then
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index b5157f4a2a51..a1d2dabfc211 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -3,13 +3,12 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/print/libgnomeprint/Makefile,v 1.73 2008/09/22 13:55:39 kwm Exp $
+# $MCom: ports/print/libgnomeprint/Makefile,v 1.75 2010/04/01 15:19:59 kwm Exp $
#
# NOTE: Remind to update comms/gfax plist when PORTVERSION change.
PORTNAME= libgnomeprint
-PORTVERSION= 2.18.6
-PORTREVISION= 1
+PORTVERSION= 2.18.7
CATEGORIES= print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/print/libgnomeprint/distinfo b/print/libgnomeprint/distinfo
index 824ee26cb4a8..587a0187fade 100644
--- a/print/libgnomeprint/distinfo
+++ b/print/libgnomeprint/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libgnomeprint-2.18.6.tar.bz2) = a5aa248058a07de4b3cf444673cfc683
-SHA256 (gnome2/libgnomeprint-2.18.6.tar.bz2) = cf81909506a9fd943a5ee47465a52fdf98d6d2ebc37b8a60251df42a94078095
-SIZE (gnome2/libgnomeprint-2.18.6.tar.bz2) = 907502
+MD5 (gnome2/libgnomeprint-2.18.7.tar.bz2) = d66b81ee8aa3b3a33f5efc9a47ce07e3
+SHA256 (gnome2/libgnomeprint-2.18.7.tar.bz2) = 8b34f81599423ef3da9c43775495da602f83cbbee069c9e760ffeae6aa4768e6
+SIZE (gnome2/libgnomeprint-2.18.7.tar.bz2) = 858527
diff --git a/print/libgnomeprint/pkg-plist b/print/libgnomeprint/pkg-plist
index a7a55868e9b4..2b3d0ea1e026 100644
--- a/print/libgnomeprint/pkg-plist
+++ b/print/libgnomeprint/pkg-plist
@@ -94,20 +94,25 @@ libdata/pkgconfig/libgnomeprint-%%LIBVERSION%%.pc
%%DATADIR%%/%%VERSION%%/printers/uninstalled/META.xml
share/locale/am/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ar/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/as/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/ast/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/az/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/be/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/be@latin/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/bg/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/bn/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/bn_IN/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/br/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/bs/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ca/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/ca@valencia/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/cs/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/cy/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/da/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/de/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/dz/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/el/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/en@shaw/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/en_CA/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/en_GB/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/es/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@@ -128,16 +133,19 @@ share/locale/is/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/it/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ja/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ka/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/kn/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ko/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ky/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/lt/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/lv/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/mai/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/mk/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ml/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/mn/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/mr/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ms/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/nb/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
+share/locale/nds/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/ne/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/nl/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
share/locale/nn/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@@ -201,13 +209,25 @@ share/locale/zh_TW/LC_MESSAGES/libgnomeprint-%%LIBVERSION%%.mo
@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/ky/LC_MESSAGES
@dirrmtry share/locale/ky
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
index d6aaa98ded6a..51c702ab0b27 100644
--- a/print/libspectre/Makefile
+++ b/print/libspectre/Makefile
@@ -3,11 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/print/libspectre/Makefile,v 1.4 2009/10/19 20:04:37 kwm Exp $
+# $MCom: ports/print/libspectre/Makefile,v 1.7 2010/04/19 15:38:43 kwm Exp $
PORTNAME= libspectre
-PORTVERSION= 0.2.3
-PORTREVISION= 2
+PORTVERSION= 0.2.5
CATEGORIES= print
MASTER_SITES= http://libspectre.freedesktop.org/releases/
@@ -22,16 +21,4 @@ USE_GNOME= gnomehack gnomeprefix ltverhack
USE_GHOSTSCRIPT=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-.if defined(WITH_GHOSTSCRIPT_GNU)
-IGNORE= Port will not work with ghostscript-gnu, please do not define WITH_GHOSTSCRIPT_GNU
-.endif
-
-pre-configure:
- @if [ -n "`${PKG_INFO} -xI '^ghostscript-gnu-[0-9]*'`" ]; then \
- ${ECHO_CMD} "${PKGNAME}: ghostscript-gnu installed, please deinstall ghostscript-gnu"; \
- ${ECHO_CMD} "and use ghostscript-gpl. Make sure you don't have WITH_GHOSTSCRIPT_GNU"; \
- ${ECHO_CMD} "or GHOSTSCRIPT_PORT defined."; \
- ${FALSE}; \
- fi
-
.include <bsd.port.mk>
diff --git a/print/libspectre/distinfo b/print/libspectre/distinfo
index a2603a21ee46..49fab0e2a33a 100644
--- a/print/libspectre/distinfo
+++ b/print/libspectre/distinfo
@@ -1,3 +1,3 @@
-MD5 (libspectre-0.2.3.tar.gz) = 9c5867e970d1bad5f80809bfdb4306c1
-SHA256 (libspectre-0.2.3.tar.gz) = 0cc4e30b9379a383894e2559c5e2125dd90f814106b4628459d90db9b5ac8b41
-SIZE (libspectre-0.2.3.tar.gz) = 352308
+MD5 (libspectre-0.2.5.tar.gz) = 56ed626fdf430039f1285e869b8fb3b6
+SHA256 (libspectre-0.2.5.tar.gz) = 0cf52400d6a6f93daa31c8fad3fc37a33cea4198707678fbebca09df9afd69a4
+SIZE (libspectre-0.2.5.tar.gz) = 341454
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
index cb17e3f5a600..cc007b677c8e 100644
--- a/print/py-cups/Makefile
+++ b/print/py-cups/Makefile
@@ -3,10 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/print/py-cups/Makefile,v 1.1 2008/03/20 13:55:32 ahze Exp $
+# $MCom: ports/print/py-cups/Makefile,v 1.3 2009/12/29 16:01:46 ahze Exp $
PORTNAME= cups
-PORTVERSION= 1.9.46
+PORTVERSION= 1.9.47
CATEGORIES= print python
MASTER_SITES= http://cyberelk.net/tim/data/pycups/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/print/py-cups/distinfo b/print/py-cups/distinfo
index d59e1c9bc4b1..d41cd4ca74c9 100644
--- a/print/py-cups/distinfo
+++ b/print/py-cups/distinfo
@@ -1,3 +1,3 @@
-MD5 (pycups-1.9.46.tar.bz2) = 895d4170542ec80c74d41746a9474409
-SHA256 (pycups-1.9.46.tar.bz2) = 74abd1d6b1a5b8a22d2ccf3730000848fcef0b63c6105b178f73ff76e72bc8fe
-SIZE (pycups-1.9.46.tar.bz2) = 41626
+MD5 (pycups-1.9.47.tar.bz2) = b2c94db15c916e0776e320addb279ba8
+SHA256 (pycups-1.9.47.tar.bz2) = 1bb0cb75c1b8e0c4f0677b07546fcd0c9ec9ed04aa977ee9fc5466cbb6fe862b
+SIZE (pycups-1.9.47.tar.bz2) = 45175
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 713585d25764..af630ef232fc 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -3,14 +3,14 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/print/system-config-printer/Makefile,v 1.3 2008/03/23 16:10:55 ahze Exp $
+# $MCom: ports/print/system-config-printer/Makefile,v 1.6 2009/12/29 16:03:58 ahze Exp $
#
PORTNAME= system-config-printer
-PORTVERSION= 1.0.16
-PORTREVISION= 2
+PORTVERSION= 1.1.16
+PORTREVISION= 1
CATEGORIES= print gnome
-MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}.x/
+MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= CUPS configuration Gtk+2.0 GUI
@@ -24,10 +24,11 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cups.so:${PORTSDIR}/print/py-cups \
${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify \
xmlproc_parse:${PORTSDIR}/textproc/py-xml \
- ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus
+ ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${LOCALBASE}/libexec/cups-pk-helper-mechanism:${PORTSDIR}/print/cups-pk-helper
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.6+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
diff --git a/print/system-config-printer/distinfo b/print/system-config-printer/distinfo
index fb1d983f445e..166a1797f53c 100644
--- a/print/system-config-printer/distinfo
+++ b/print/system-config-printer/distinfo
@@ -1,3 +1,3 @@
-MD5 (system-config-printer-1.0.16.tar.bz2) = eab094411498de16a0c2cf2c2ab5428a
-SHA256 (system-config-printer-1.0.16.tar.bz2) = 721c66e0f02aba245db7625d63a141b2f5229a6ba9c1e4a0f300a2a21ce0bfaf
-SIZE (system-config-printer-1.0.16.tar.bz2) = 837271
+MD5 (system-config-printer-1.1.16.tar.bz2) = 22394a052fa730a890f6bfea1aec0aa2
+SHA256 (system-config-printer-1.1.16.tar.bz2) = 176b63ee6af2208313469192eb34eb12b41fe8b890a18c8a5ab693010a8e785d
+SIZE (system-config-printer-1.1.16.tar.bz2) = 1036604
diff --git a/print/system-config-printer/files/patch-applet.py b/print/system-config-printer/files/patch-applet.py
index 07e729441373..d21bb2a2ec76 100644
--- a/print/system-config-printer/files/patch-applet.py
+++ b/print/system-config-printer/files/patch-applet.py
@@ -1,5 +1,5 @@
---- applet.py.orig 2008-11-21 10:58:21.000000000 -0600
-+++ applet.py 2008-11-22 11:28:38.936928214 -0600
+--- applet.py.orig 2009-12-22 09:44:19.000000000 -0500
++++ applet.py 2009-12-29 00:06:27.000000000 -0500
@@ -43,7 +43,7 @@
os.environ['LC_ALL'] = 'C'
locale.setlocale (locale.LC_ALL, "")
@@ -7,18 +7,9 @@
-APPDIR="/usr/share/system-config-printer"
+APPDIR="%%PREFIX%%/share/system-config-printer"
DOMAIN="system-config-printer"
- GLADE="applet.glade"
ICON="printer"
-@@ -61,7 +61,7 @@
- STATUS_GENERIC_DRIVER = 2
- STATUS_NO_DRIVER = 3
-
-- INSTALL_PACKAGES_COMMAND="/usr/bin/gpk-install-package-name"
-+ INSTALL_PACKAGES_COMMAND="/usr/bin/true"
-
- def __init__ (self, bus):
- self.bus = bus
-@@ -173,7 +173,7 @@
+ SEARCHING_ICON="document-print-preview"
+@@ -234,7 +234,7 @@
pid = os.fork ()
if pid == 0:
# Child.
diff --git a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
index 6624df0adb63..079c395adf40 100644
--- a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
+++ b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
@@ -1,15 +1,15 @@
---- cupshelpers/cupshelpers.py.orig 2008-07-09 06:23:44.000000000 -0500
-+++ cupshelpers/cupshelpers.py 2008-07-26 13:33:50.596144479 -0500
-@@ -699,7 +699,7 @@
+--- cupshelpers/cupshelpers.py.orig 2009-12-22 09:44:19.000000000 -0500
++++ cupshelpers/cupshelpers.py 2009-12-29 00:08:26.000000000 -0500
+@@ -663,7 +663,7 @@
# First, a local function. How to check that something exists
# in a path:
- def pathcheck (name, path="/usr/bin:/bin"):
-+ def pathcheck (name, path="%%LOCALBASE%%/bin:/usr/bin:/bin:%%PREFIX%%/bin"):
- # Strip out foomatic '%'-style place-holders.
- p = name.find ('%')
- if p != -1:
-@@ -794,7 +794,7 @@
++ def pathcheck (name, path="%%LOCALBASE%%/bin:%%PREFIX%%/bin:/usr/bin:/bin"):
+ if name == "-":
+ # A filter of "-" means that no filter is required,
+ # i.e. the device accepts the given format as-is.
+@@ -765,7 +765,7 @@
continue
exepath = pathcheck (exe,
diff --git a/print/system-config-printer/files/patch-pysmb.py b/print/system-config-printer/files/patch-pysmb.py
deleted file mode 100644
index 648837de6d98..000000000000
--- a/print/system-config-printer/files/patch-pysmb.py
+++ /dev/null
@@ -1,19 +0,0 @@
---- pysmb.py.orig 2008-03-20 11:55:30.000000000 -0400
-+++ pysmb.py 2008-03-20 11:56:22.000000000 -0400
-@@ -24,13 +24,13 @@
- import sys
- import re
-
--nmblookup = "/usr/bin/nmblookup"
--smbclient = "/usr/bin/smbclient"
-+nmblookup = "%%LOCALBASE%%/bin/nmblookup"
-+smbclient = "%%LOCALBASE%%/bin/smbclient"
-
- wins = None
-
- def get_wins_server():
-- smbconf = "/etc/samba/smb.conf"
-+ smbconf = "%%LOCALBASE%%/etc/smb.conf"
- wsregex = re.compile("\s*wins\s*server.*",re.IGNORECASE)
-
- global wins
diff --git a/print/system-config-printer/files/patch-system-config-printer.py b/print/system-config-printer/files/patch-system-config-printer.py
index 784a0a8cea29..c0129a32c5ae 100644
--- a/print/system-config-printer/files/patch-system-config-printer.py
+++ b/print/system-config-printer/files/patch-system-config-printer.py
@@ -1,6 +1,29 @@
---- system-config-printer.py.orig 2008-11-21 11:19:25.000000000 -0600
-+++ system-config-printer.py 2008-11-22 11:30:37.732537129 -0600
-@@ -3668,7 +3668,7 @@
+--- system-config-printer.py.orig 2009-12-22 09:44:19.000000000 -0500
++++ system-config-printer.py 2009-12-29 00:35:54.000000000 -0500
+@@ -4344,7 +4344,7 @@
+ if may_be_ps:
+ debugprint ("Printer might support PostScript")
+ try:
+- os.stat ("/usr/share/cups/model/foomatic-db-ppds")
++ os.stat ("%%LOCALBASE%%/share/cups/model/foomatic-db-ppds")
+ debugprint ("foomatic-db-ppds already installed")
+ except OSError:
+ debugprint ("foomatic-db-ppds not yet installed")
+@@ -4892,11 +4892,11 @@
+ # Problem executing command.
+ return True # assume plugin not required
+ else:
+- if glob.glob("/usr/share/hplip/data/plugin/*%s*plugin*" %
++ if glob.glob("%%LOCALBASE%%share/hplip/data/plugin/*%s*plugin*" %
+ hplip_version):
+ if hplip_version.startswith("2"):
+ try:
+- f = open('/etc/hp/hplip.conf', 'r')
++ f = open('%%LOCALBASE%%/etc/hp/hplip.conf', 'r')
+ for line in f:
+ if line.strip ().startswith("plugin") and \
+ line.strip ().endswith("1"):
+@@ -5082,7 +5082,7 @@
# Try to get make and model via SNMP
if host:
os.environ["HOST"] = host
@@ -9,7 +32,7 @@
debugprint (host + ": " + cmd)
stdout = None
try:
-@@ -5140,7 +5140,7 @@
+@@ -6621,7 +6621,7 @@
try:
# We want this to be in the current natural language,
# so we intentionally don't set LC_ALL=C here.
@@ -18,12 +41,3 @@
'-rvv', filename],
stdin=file("/dev/null"),
stdout=subprocess.PIPE,
-@@ -5433,7 +5433,7 @@
- (pkgs, exes) = cupshelpers.missingPackagesAndExecutables (ppd)
- if len (pkgs) > 0 or len (exes) > 0:
- # We didn't find a necessary executable. Complain.
-- install = "/usr/bin/gpk-install-package-name"
-+ install = "/usr/bin/true"
- if len (pkgs) > 0 and os.access (install, os.X_OK):
- pkg = pkgs[0]
- install_text = ('<span weight="bold" size="larger">' +
diff --git a/print/system-config-printer/pkg-plist b/print/system-config-printer/pkg-plist
index b1408928a6a8..fea8725a0580 100644
--- a/print/system-config-printer/pkg-plist
+++ b/print/system-config-printer/pkg-plist
@@ -2,8 +2,8 @@ bin/my-default-printer
bin/system-config-printer
bin/system-config-printer-applet
etc/dbus-1/system.d/newprinternotification.conf
-etc/xdg/autostart/redhat-print-applet.desktop
-%%PYTHON_SITELIBDIR%%/cupshelpers-1.0-py%%PYTHON_VER%%.egg-info
+etc/xdg/autostart/print-applet.desktop
+%%PYTHON_SITELIBDIR%%/cupshelpers-1.0-py%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.py
%%PYTHON_SITELIBDIR%%/cupshelpers/__init__.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/cupshelpers.py
@@ -12,9 +12,9 @@ etc/xdg/autostart/redhat-print-applet.desktop
%%PYTHON_SITELIBDIR%%/cupshelpers/openprinting.pyc
%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.py
%%PYTHON_SITELIBDIR%%/cupshelpers/ppds.pyc
-share/applications/redhat-manage-print-jobs.desktop
-share/applications/redhat-my-default-printer.desktop
-share/applications/redhat-system-config-printer.desktop
+share/applications/manage-print-jobs.desktop
+share/applications/my-default-printer.desktop
+share/applications/system-config-printer.desktop
share/locale/ar/LC_MESSAGES/system-config-printer.mo
share/locale/as/LC_MESSAGES/system-config-printer.mo
share/locale/bg/LC_MESSAGES/system-config-printer.mo
@@ -48,6 +48,7 @@ share/locale/kn/LC_MESSAGES/system-config-printer.mo
share/locale/ko/LC_MESSAGES/system-config-printer.mo
share/locale/lo/LC_MESSAGES/system-config-printer.mo
share/locale/lv/LC_MESSAGES/system-config-printer.mo
+share/locale/mai/LC_MESSAGES/system-config-printer.mo
share/locale/mk/LC_MESSAGES/system-config-printer.mo
share/locale/ml/LC_MESSAGES/system-config-printer.mo
share/locale/mr/LC_MESSAGES/system-config-printer.mo
@@ -71,34 +72,62 @@ share/locale/sr@latin/LC_MESSAGES/system-config-printer.mo
share/locale/sv/LC_MESSAGES/system-config-printer.mo
share/locale/ta/LC_MESSAGES/system-config-printer.mo
share/locale/te/LC_MESSAGES/system-config-printer.mo
+share/locale/th/LC_MESSAGES/system-config-printer.mo
share/locale/tr/LC_MESSAGES/system-config-printer.mo
share/locale/uk/LC_MESSAGES/system-config-printer.mo
share/locale/vi/LC_MESSAGES/system-config-printer.mo
share/locale/zh_CN/LC_MESSAGES/system-config-printer.mo
share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/AdvancedServerSettings.py
+%%DATADIR%%/GroupsPane.py
+%%DATADIR%%/GroupsPaneModel.py
+%%DATADIR%%/HIG.py
%%DATADIR%%/PhysicalDevice.py
-%%DATADIR%%/applet.glade
+%%DATADIR%%/SearchCriterion.py
+%%DATADIR%%/ToolbarSearchEntry.py
+%%DATADIR%%/XmlHelper.py
%%DATADIR%%/applet.py
+%%DATADIR%%/asyncconn.py
+%%DATADIR%%/asyncipp.py
+%%DATADIR%%/asyncpk0.py
+%%DATADIR%%/asyncpk1.py
%%DATADIR%%/authconn.py
%%DATADIR%%/config.py
-%%DATADIR%%/contextmenu.py
+%%DATADIR%%/cupspk.py
%%DATADIR%%/debug.py
%%DATADIR%%/errordialogs.py
+%%DATADIR%%/firewall.py
+%%DATADIR%%/glade.py
+%%DATADIR%%/glade/AboutDialog.glade
+%%DATADIR%%/glade/ConnectDialog.glade
+%%DATADIR%%/glade/ConnectingDialog.glade
+%%DATADIR%%/glade/InstallDialog.glade
+%%DATADIR%%/glade/JobsWindow.glade
+%%DATADIR%%/glade/NewPrinterName.glade
+%%DATADIR%%/glade/NewPrinterWindow.glade
+%%DATADIR%%/glade/PrinterPropertiesDialog.glade
+%%DATADIR%%/glade/PrintersWindow.glade
+%%DATADIR%%/glade/SMBBrowseDialog.glade
+%%DATADIR%%/glade/ServerSettingsDialog.glade
+%%DATADIR%%/glade/WaitWindow.glade
+%%DATADIR%%/glade/statusicon_popupmenu.glade
%%DATADIR%%/gtk_label_autowrap.py
-%%DATADIR%%/gtk_treeviewtooltips.py
+%%DATADIR%%/gtkinklevel.py
+%%DATADIR%%/gtkspinner.py
%%DATADIR%%/icons/i-network-printer.png
+%%DATADIR%%/installpackage.py
%%DATADIR%%/jobviewer.py
%%DATADIR%%/monitor.py
%%DATADIR%%/my-default-printer.py
%%DATADIR%%/options.py
%%DATADIR%%/optionwidgets.py
+%%DATADIR%%/ppdippstr.py
%%DATADIR%%/probe_printer.py
%%DATADIR%%/pysmb.py
%%DATADIR%%/smburi.py
%%DATADIR%%/statereason.py
-%%DATADIR%%/system-config-printer.glade
%%DATADIR%%/system-config-printer.py
+%%DATADIR%%/timedops.py
%%DATADIR%%/troubleshoot/CheckLocalServerPublishing.py
%%DATADIR%%/troubleshoot/CheckNetworkServerSanity.py
%%DATADIR%%/troubleshoot/CheckPPDSanity.py
@@ -127,7 +156,12 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
%%DATADIR%%/userdefault.py
@dirrm %%DATADIR%%/troubleshoot
@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrm %%PYTHON_SITELIBDIR%%/cupshelpers
+@dirrmtry etc/xdg/autostart
+@dirrmtry etc/xdg
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@@ -138,6 +172,8 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
@dirrmtry share/locale/my
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/lo/LC_MESSAGES
@dirrmtry share/locale/lo
@dirrmtry share/locale/hy/LC_MESSAGES
@@ -146,7 +182,3 @@ share/locale/zh_TW/LC_MESSAGES/system-config-printer.mo
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
-@dirrmtry share/applications
-@dirrm %%PYTHON_SITELIBDIR%%/cupshelpers
-@dirrmtry etc/xdg/autostart
-@dirrmtry etc/xdg