aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-30 22:06:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-30 22:21:18 +0000
commit621f06846fd4c4c7227c9810336ec736dba87175 (patch)
tree231c97cf4a606eb73c7fbb4fc5d367ef301af353 /print
parent4159f784864cd6f3c1ec4f1f1db4f8797a827c43 (diff)
downloadports-621f06846fd4c4c7227c9810336ec736dba87175.tar.gz
ports-621f06846fd4c4c7227c9810336ec736dba87175.zip
print/py-uharfbuzz: Update to 0.23.0
Diffstat (limited to 'print')
-rw-r--r--print/py-uharfbuzz/Makefile2
-rw-r--r--print/py-uharfbuzz/distinfo6
-rw-r--r--print/py-uharfbuzz/files/patch-setup.py12
-rw-r--r--print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp7
4 files changed, 15 insertions, 12 deletions
diff --git a/print/py-uharfbuzz/Makefile b/print/py-uharfbuzz/Makefile
index 7684c3462656..32a949c25be3 100644
--- a/print/py-uharfbuzz/Makefile
+++ b/print/py-uharfbuzz/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= uharfbuzz
-PORTVERSION= 0.22.0
+PORTVERSION= 0.23.0
CATEGORIES= print python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/print/py-uharfbuzz/distinfo b/print/py-uharfbuzz/distinfo
index 94a7e6eb83df..8cfaecbd51f8 100644
--- a/print/py-uharfbuzz/distinfo
+++ b/print/py-uharfbuzz/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1647264654
-SHA256 (uharfbuzz-0.22.0.zip) = 82b68867fffd78d84e664ee872a193a897a35f398e40095ede7759456da4ebb6
-SIZE (uharfbuzz-0.22.0.zip) = 1205322
+TIMESTAMP = 1648248976
+SHA256 (uharfbuzz-0.23.0.zip) = 7761b761ad5589c76b7f2ed228dfcc43aa5b5f7e6139e9c5d09b9a4910087d18
+SIZE (uharfbuzz-0.23.0.zip) = 1216848
diff --git a/print/py-uharfbuzz/files/patch-setup.py b/print/py-uharfbuzz/files/patch-setup.py
index 64d0bf12ab2a..eae7ea11a653 100644
--- a/print/py-uharfbuzz/files/patch-setup.py
+++ b/print/py-uharfbuzz/files/patch-setup.py
@@ -1,13 +1,15 @@
---- setup.py.orig 2022-02-08 07:41:12 UTC
+--- setup.py.orig 2022-03-22 22:29:38 UTC
+++ setup.py
-@@ -39,8 +39,8 @@ if platform.system() == 'Darwin':
+@@ -39,11 +39,9 @@ if platform.system() == 'Darwin':
extension = Extension(
'uharfbuzz._harfbuzz',
define_macros=define_macros,
- include_dirs=['harfbuzz/src'],
-- sources=['src/uharfbuzz/_harfbuzz.pyx', 'harfbuzz/src/harfbuzz.cc'],
+ include_dirs=['%%LOCALBASE%%/include/harfbuzz'],
-+ sources=['src/uharfbuzz/_harfbuzz.pyx'],
+ sources=[
+ 'src/uharfbuzz/_harfbuzz.pyx',
+- 'harfbuzz/src/harfbuzz.cc',
+- 'harfbuzz/src/hb-subset-repacker.cc',
+ ],
language='c++',
libraries=libraries,
- extra_compile_args=extra_compile_args,
diff --git a/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp b/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
index 67e37280fd56..f486a2cf2b4f 100644
--- a/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
+++ b/print/py-uharfbuzz/files/patch-src-uharfbuzz-_harfbuzz.cpp
@@ -1,6 +1,6 @@
---- src/uharfbuzz/_harfbuzz.cpp.orig 2021-05-09 03:05:40 UTC
+--- src/uharfbuzz/_harfbuzz.cpp.orig 2022-03-22 22:30:14 UTC
+++ src/uharfbuzz/_harfbuzz.cpp
-@@ -18,13 +18,12 @@
+@@ -30,14 +30,12 @@
"-std=c++11"
],
"include_dirs": [
@@ -11,7 +11,8 @@
"name": "uharfbuzz._harfbuzz",
"sources": [
"src/uharfbuzz/_harfbuzz.pyx",
-- "harfbuzz/src/harfbuzz.cc"
+- "harfbuzz/src/harfbuzz.cc",
+- "harfbuzz/src/hb-subset-repacker.cc"
]
},
"module_name": "uharfbuzz._harfbuzz"