aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-02-25 12:04:28 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-02-25 12:04:28 +0000
commit78c049e83319924985bcf0f056f9fac7f92481b7 (patch)
treec5938bd802ea9d5944da84a914077ce901859cce /print
parent5f2482b87359007089432d1434598648f0e9ebfc (diff)
downloadports-78c049e83319924985bcf0f056f9fac7f92481b7.tar.gz
ports-78c049e83319924985bcf0f056f9fac7f92481b7.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/c2ps-letter/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/print/c2ps-letter/Makefile b/print/c2ps-letter/Makefile
index f7f35f090f43..56f5ebc24624 100644
--- a/print/c2ps-letter/Makefile
+++ b/print/c2ps-letter/Makefile
@@ -3,11 +3,11 @@
# Date created: 19 March 1997
# Whom: Matthew Hunt <mph@pobox.com>
#
-# $Id: Makefile,v 1.1.1.1 1997/03/24 19:36:55 obrien Exp $
+# $Id: Makefile,v 1.2 1998/02/25 00:25:41 steve Exp $
#
DISTNAME= c2ps-4.0
-PKGNAME= c2ps-${PAPERSIZE:S/A/a/:S/LETTER/letter/}-4.0
+PKGNAME= c2ps-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-4.0
CATEGORIES= print
MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
@@ -18,6 +18,10 @@ MAKE_ENV= DEFAULT_PAPER_TYPE=${PAPERSIZE}
.if !defined(PAPERSIZE)
PAPERSIZE=A4
+.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == Letter
+PAPERSIZE=LETTER
+.elif ${PAPERSIZE} == a4
+PAPERSIZE=A4
.elif ${PAPERSIZE} != A4 && ${PAPERSIZE} != LETTER
PAPERSIZE_INVALID=yes
.endif
@@ -25,7 +29,7 @@ PAPERSIZE_INVALID=yes
pre-fetch:
.if defined(PAPERSIZE_INVALID)
@${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and LETTER."
+ @${ECHO} "Possible values are: A4 (default), and Letter."
@${FALSE}
.endif