aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-07-07 13:28:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-07-07 13:28:13 +0000
commit2c67b137b0752d93f64b95df6c8724d456dc9e0f (patch)
tree4fcfe241cac98204194f058f37db0a336c4d5dfc /print
parent776a2caed63acd36dc3ae472b3ac18a3321436c7 (diff)
downloadports-2c67b137b0752d93f64b95df6c8724d456dc9e0f.tar.gz
ports-2c67b137b0752d93f64b95df6c8724d456dc9e0f.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/html2latex/Makefile5
-rw-r--r--print/html2latex/files/patch-Makefile (renamed from print/html2latex/files/patch-ab)19
-rw-r--r--print/html2latex/files/patch-aa16
3 files changed, 11 insertions, 29 deletions
diff --git a/print/html2latex/Makefile b/print/html2latex/Makefile
index dac971c9cace..433161b6f5fe 100644
--- a/print/html2latex/Makefile
+++ b/print/html2latex/Makefile
@@ -11,9 +11,6 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= joerg@FreeBSD.org
COMMENT= Convert HTML document into LaTeX
-MAN1= html2latex.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/html2latex
+PLIST_FILES= bin/html2latex man/man1/html2latex.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/print/html2latex/files/patch-ab b/print/html2latex/files/patch-Makefile
index f19b54f6c3ff..a252853d84ed 100644
--- a/print/html2latex/files/patch-ab
+++ b/print/html2latex/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Fri Mar 29 17:18:06 1996
-+++ Makefile Fri Mar 29 17:22:06 1996
+--- Makefile.orig 2014-07-07 21:24:49.187066431 +0800
++++ Makefile 2014-07-07 21:24:52.234066984 +0800
@@ -3,7 +3,7 @@
# ----------------------------------------------------------------------------
@@ -9,16 +9,17 @@
# For testing:
# CC = gcc
# For Sun's and other non-at-least-pseudo-ANSI-C platforms:
-@@ -12,7 +12,7 @@
+@@ -12,20 +12,21 @@ CC = cc
# ----------------------------------------------------------------------------
# For SGI's:
--CFLAGS = -g -cckr -DXMOSAIC -DNEED_GETOPT_H
+-CFLAGS = -g -cckr -DXMOSAIC
+# CFLAGS = -g -cckr -DXMOSAIC -DNEED_GETOPT_H
# For testing:
- # CFLAGS = -g -Wall -DXMOSAIC -DNEED_GETOPT_H
+-# CFLAGS = -g -Wall -DXMOSAIC
++# CFLAGS = -g -Wall -DXMOSAIC -DNEED_GETOPT_H
# For HP's:
-@@ -20,12 +20,13 @@
+ # CFLAGS = -g -DXMOSAIC -I/usr/include/Motif1.1 -I/usr/include/X11R4
# For everyone else:
# CFLAGS = -g -DXMOSAIC
# ----------------------------------------------------------------------------
@@ -34,7 +35,7 @@
# ----------------------------------------------------------------------------
# You shouldn't need to edit below here.
-@@ -55,3 +56,10 @@
+@@ -55,3 +56,10 @@ $(OBJS): HTMLparse.h
clean:
-rm $(EXETARGET) $(OBJS) $(LIBTARGET) $(DOCTARGET)
@@ -42,6 +43,6 @@
+PREFIX?= /usr/local
+
+install: all
-+ install -c -s $(EXETARGET) $(PREFIX)/bin
++ install -c -s $(EXETARGET) $(DESTDIR)$(PREFIX)/bin
+ gzip -c < html2latex.1 > html2latex.1.gz
-+ install -c html2latex.1.gz $(PREFIX)/man/man1
++ install -c html2latex.1.gz $(DESTDIR)$(PREFIX)/man/man1
diff --git a/print/html2latex/files/patch-aa b/print/html2latex/files/patch-aa
index ef88fa3360ac..e415b2d269f3 100644
--- a/print/html2latex/files/patch-aa
+++ b/print/html2latex/files/patch-aa
@@ -33,22 +33,6 @@ diff -u ../html2latex-0.9c.old/HTMLparse.h ./HTMLparse.h
} mark_t;
/* amperstand escapes */
-diff -u ../html2latex-0.9c.old/Makefile ./Makefile
---- ../html2latex-0.9c.old/Makefile Fri Mar 19 05:02:36 1993
-+++ ./Makefile Fri Mar 29 16:40:56 1996
-@@ -12,9 +12,9 @@
-
- # ----------------------------------------------------------------------------
- # For SGI's:
--CFLAGS = -g -cckr -DXMOSAIC
-+CFLAGS = -g -cckr -DXMOSAIC -DNEED_GETOPT_H
- # For testing:
--# CFLAGS = -g -Wall -DXMOSAIC
-+# CFLAGS = -g -Wall -DXMOSAIC -DNEED_GETOPT_H
- # For HP's:
- # CFLAGS = -g -DXMOSAIC -I/usr/include/Motif1.1 -I/usr/include/X11R4
- # For everyone else:
-Only in .: diff
diff -u ../html2latex-0.9c.old/html2latex.c ./html2latex.c
--- ../html2latex-0.9c.old/html2latex.c Wed Jun 16 05:55:10 1993
+++ ./html2latex.c Fri Mar 29 16:41:17 1996