aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-17 16:49:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-17 16:49:52 +0000
commitcfb4eb69830a62280069b9bf95d01163179b4ce3 (patch)
treef613dcf2b8ff5f2b328296e19cb39636b68b8f3c /print
parent386f84718de2013095422a583034f69530922dc2 (diff)
downloadports-cfb4eb69830a62280069b9bf95d01163179b4ce3.tar.gz
ports-cfb4eb69830a62280069b9bf95d01163179b4ce3.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/cups-smb-backend/Makefile28
-rw-r--r--print/cups-smb-backend/files/pkg-message.in17
-rw-r--r--print/cups-smb-backend/pkg-descr5
4 files changed, 51 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index e83bac6d52e3..067f5c45bdcb 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -48,6 +48,7 @@
SUBDIR += cups-pdf
SUBDIR += cups-pstoraster
SUBDIR += cups-samba
+ SUBDIR += cups-smb-backend
SUBDIR += detex
SUBDIR += dk-acroread
SUBDIR += dvi2tty
diff --git a/print/cups-smb-backend/Makefile b/print/cups-smb-backend/Makefile
new file mode 100644
index 000000000000..bdd5f580a832
--- /dev/null
+++ b/print/cups-smb-backend/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: cups-smb-backend
+# Date created: 12 November 2005
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups-smb-backend
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= # empty
+DISTFILES= # empty
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A CUPS backend for printing to Windows servers
+
+RUN_DEPENDS= smbspool:${PORTSDIR}/net/samba3 \
+ ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
+
+NO_BUILD= yes
+PLIST_FILES= libexec/cups/backend/smb
+SUB_FILES= pkg-message
+
+do-install:
+ ${LN} -fs ${PREFIX}/bin/smbspool ${PREFIX}/libexec/cups/backend/smb
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/cups-smb-backend/files/pkg-message.in b/print/cups-smb-backend/files/pkg-message.in
new file mode 100644
index 000000000000..02f336ddda79
--- /dev/null
+++ b/print/cups-smb-backend/files/pkg-message.in
@@ -0,0 +1,17 @@
+CUPS smb backend is now installed.
+
+Please configure your samba environment if
+you haven't already done so. To do so edit
+
+%%PREFIX%%/etc/smb.conf
+
+You can then add a new printer to CUPS.
+smbspool(8) manpage describes device URI
+format. In most cases (latest samba 2.x
+and samba 3.x), it's something like this:
+
+smb://username:password@server/printer
+smb://username:password@workgroup/server/printer
+
+But a CUPS article describes another syntax,
+so beware.
diff --git a/print/cups-smb-backend/pkg-descr b/print/cups-smb-backend/pkg-descr
new file mode 100644
index 000000000000..e86a36c61b8a
--- /dev/null
+++ b/print/cups-smb-backend/pkg-descr
@@ -0,0 +1,5 @@
+CUPS smb backend allows *nix users to print
+to Windows-attached printers via smbspool
+program, which comes with Samba.
+
+WWW: http://www.cups.org/articles.php?L294