aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-05-22 07:14:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-05-22 07:14:39 +0000
commit0872a68758d7ee2e9a9d83b9e15ec5221b416183 (patch)
tree05d9c7b4bd2efb7b2a219cc90b06295425afcfc1 /print
parent2929299e83ad2017335811349d8d87b7865a5197 (diff)
downloadports-0872a68758d7ee2e9a9d83b9e15ec5221b416183.tar.gz
ports-0872a68758d7ee2e9a9d83b9e15ec5221b416183.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/lilypond-devel/Makefile6
-rw-r--r--print/lilypond-devel/distinfo4
-rw-r--r--print/lilypond-devel/files/patch-flower-include_std-string.hh18
-rw-r--r--print/lilypond-devel/files/patch-flower-include_std-vector.hh10
4 files changed, 33 insertions, 5 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index d108a394c984..fa01b1c2d2a8 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lilypond
-PORTVERSION= 2.19.3
-PORTREVISION= 1
+PORTVERSION= 2.19.6
CATEGORIES= print audio
MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
PKGNAMESUFFIX= -devel
@@ -45,7 +44,8 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext gmake pkgconfig perl5
+USES= bison:build gettext gmake pkgconfig perl5 compiler:c++11-lib
+USE_CXXSTD= c++11
USE_GHOSTSCRIPT=9
USE_TEX= latex
USE_PYTHON= -3
diff --git a/print/lilypond-devel/distinfo b/print/lilypond-devel/distinfo
index d8b717560455..c3414915ec2c 100644
--- a/print/lilypond-devel/distinfo
+++ b/print/lilypond-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lilypond-2.19.3.tar.gz) = 08efddcd3b24675870c6891932205361a2f9d839c49760798d48d6df7b36053e
-SIZE (lilypond-2.19.3.tar.gz) = 16035346
+SHA256 (lilypond-2.19.6.tar.gz) = 19e24f19ef79a17c62ec2ce46b2f550209e27c3cd7df6f48789c43b99bb7a01e
+SIZE (lilypond-2.19.6.tar.gz) = 16043555
diff --git a/print/lilypond-devel/files/patch-flower-include_std-string.hh b/print/lilypond-devel/files/patch-flower-include_std-string.hh
new file mode 100644
index 000000000000..44f0d391c9ab
--- /dev/null
+++ b/print/lilypond-devel/files/patch-flower-include_std-string.hh
@@ -0,0 +1,18 @@
+--- flower/include/std-string.hh.orig 2014-04-07 10:27:23.000000000 +0200
++++ flower/include/std-string.hh 2014-04-07 10:27:33.000000000 +0200
+@@ -39,6 +39,7 @@
+ typedef size_t ssize;
+ #define NPOS string::npos
+
++#if _cplusplus <= 19971L
+ string to_string (const string&);
+ string to_string (char c, int n = 1);
+ string to_string (int i, char const *format = 0);
+@@ -50,6 +51,7 @@
+ string to_string (bool b);
+ string to_string (char const *format, ...)
+ __attribute__ ((format (printf, 1, 2)));
++#endif
+
+ string &replace_all (string *str, string const &find, string const &replace);
+ string &replace_all (string *str, char find, char replace);
diff --git a/print/lilypond-devel/files/patch-flower-include_std-vector.hh b/print/lilypond-devel/files/patch-flower-include_std-vector.hh
new file mode 100644
index 000000000000..75a8a4f2a751
--- /dev/null
+++ b/print/lilypond-devel/files/patch-flower-include_std-vector.hh
@@ -0,0 +1,10 @@
+--- flower/include/std-vector.hh.orig 2014-05-05 10:25:02.000000000 +0200
++++ flower/include/std-vector.hh 2014-05-05 10:28:54.000000000 +0200
+@@ -261,6 +261,6 @@
+ vector<string> string_split (string str, char c);
+ string string_join (vector<string> const &strs, const string &infix);
+
+-#define iterof(i,s) typeof((s).begin()) i((s).begin())
++#define iterof(i,s) auto i = ((s).begin())
+
+ #endif /* STD_VECTOR_HH */