aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-06-02 12:34:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-06-02 12:34:29 +0000
commit7c15c78ffacebb93b4045719e174534afc69856e (patch)
tree2b369f361be6b4e002f7edbdc71bc1dc24638eed /print
parent9264d8823cc44ffb283ea92d2a7eeefe893892d0 (diff)
downloadports-7c15c78ffacebb93b4045719e174534afc69856e.tar.gz
ports-7c15c78ffacebb93b4045719e174534afc69856e.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cupsddk/Makefile4
-rw-r--r--print/cupsddk/pkg-plist5
-rw-r--r--print/py-cups/Makefile5
3 files changed, 10 insertions, 4 deletions
diff --git a/print/cupsddk/Makefile b/print/cupsddk/Makefile
index d6c3a17bc038..54c2b4649025 100644
--- a/print/cupsddk/Makefile
+++ b/print/cupsddk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cupsddk
PORTVERSION= 1.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print devel
MASTER_SITES= EASYSW
MASTER_SITE_SUBDIR= ${PORTNAME}/${DISTVERSION}
@@ -17,7 +17,7 @@ MAINTAINER= ahze@FreeBSD.org
COMMENT= CUPS Driver Development Kit
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- cups.2:${PORTSDIR}/print/cups-base
+ cupsimage.2:${PORTSDIR}/print/cups-image
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
GNU_CONFIGURE= yes
diff --git a/print/cupsddk/pkg-plist b/print/cupsddk/pkg-plist
index ec557aa53509..970c44da5cbc 100644
--- a/print/cupsddk/pkg-plist
+++ b/print/cupsddk/pkg-plist
@@ -55,3 +55,8 @@ share/doc/cups/help/ref-ppdcfile.html
@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%
@dirrmtry share/cups/drv
+@dirrmtry share/cups
+@dirrmtry share/doc/cups/help
+@dirrmtry share/doc/cups
+@dirrmtry libexec/cups/driver
+@dirrmtry libexec/cups
diff --git a/print/py-cups/Makefile b/print/py-cups/Makefile
index f8184449c586..69c9a7bed464 100644
--- a/print/py-cups/Makefile
+++ b/print/py-cups/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cups
PORTVERSION= 1.9.45
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= http://cyberelk.net/tim/data/pycups/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= ahze@FreeBSD.org
COMMENT= CUPS bindings for Python
-LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-client
USE_PYTHON= yes
USE_ICONV= yes
@@ -24,7 +25,7 @@ USE_PYDISTUTILS= yes
CFLAGS+= -I${LOCALBASE}/include -DVERSION=\\\"${PORTVERSION}\\\"
LDFLAGS+= -L${LOCALBASE}/lib -liconv
MAKE_ENV= LDFLAGS="${LDFLAGS}"
-PYDISTUTILS_EGGINFO=${PORTNAME}-1.0-py2.5.egg-info
+PYDISTUTILS_EGGINFO=${PORTNAME}-1.0-py${PYTHON_VER}.egg-info
PLIST_FILES= %%PYTHON_SITELIBDIR%%/cups.so
.include <bsd.port.mk>