aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-06-02 12:14:24 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-06-02 12:14:24 +0000
commit8efafbce82f5cab7179dbf6ca2ed9c0465d8c954 (patch)
tree30bcbddba0f435cbdcc20d202bc519cbadc76b8d /print
parent0964e7868d8a781e8ab86e9010942fe69ab2ae80 (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile3
-rw-r--r--print/cups-base/files/patch-cups-request.c28
2 files changed, 29 insertions, 2 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 855c8f508566..65505ba501ea 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -69,7 +69,6 @@ OPTIONS_DEFINE= GNUTLS
.else
PORTREVISION= 1
CUPS_SUFFIX= -base
-CONFLICTS+= cupsddk-*
OPTIONS_DEFINE= GNUTLS LIBPAPER PHP PYTHON PAM LDAP DBUS LIBUSB XDG_OPEN GHOSTSCRIPT XPDF AVAHI MDNSRESPONDER
OPTIONS_DEFAULT= LIBPAPER GHOSTSCRIPT
NO_OPTIONS_SORT= yes
@@ -78,7 +77,7 @@ NO_OPTIONS_SORT= yes
LIBUSB_DESC= USB support
GHOSTSCRIPT_DESC= Build pdftops with GHOSTSCRIPT
XPDF_DESC= Build pdftops with XPDF
-XDG_OPEN= Build with XDG_OPEN as browser
+XDG_OPEN_DESC= Build with XDG_OPEN as browser
.include <bsd.port.options.mk>
diff --git a/print/cups-base/files/patch-cups-request.c b/print/cups-base/files/patch-cups-request.c
new file mode 100644
index 000000000000..9c7b0be2edef
--- /dev/null
+++ b/print/cups-base/files/patch-cups-request.c
@@ -0,0 +1,28 @@
+--- cups/request.c
++++ cups/request.c
+@@ -1004,6 +1004,25 @@
+ httpClose(cg->http);
+ cg->http = NULL;
+ }
++ else
++ {
++ /*
++ * Same server, see if the connection is still established...
++ */
++
++ char ch; /* Connection check byte */
++
++ if (recv(cg->http->fd, &ch, 1, MSG_PEEK | MSG_DONTWAIT) < 0 &&
++ errno != EWOULDBLOCK)
++ {
++ /*
++ * Nope, close the connection...
++ */
++
++ httpClose(cg->http);
++ cg->http = NULL;
++ }
++ }
+ }
+
+ /*