aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-08 09:07:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-08 09:07:12 +0000
commite15297181b799597283b9be67b03fc68910c497a (patch)
tree18f4b565f401fb620ad8070d0604df8bcae4a5d6 /print
parentf13d3ce710ca6c876e6f81463af774c211770d4d (diff)
downloadports-e15297181b799597283b9be67b03fc68910c497a.tar.gz
ports-e15297181b799597283b9be67b03fc68910c497a.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/lilypond-devel/Makefile38
-rw-r--r--print/lilypond-devel/distinfo4
-rw-r--r--print/lilypond-devel/pkg-plist23
3 files changed, 35 insertions, 30 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index ea4f52948e13..364fe74d0d0d 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lilypond
-PORTVERSION= 2.17.97
+PORTVERSION= 2.19.0
CATEGORIES= print audio
MASTER_SITES= http://download.linuxaudio.org/lilypond/sources/v${PORTVERSION:R}/
PKGNAMESUFFIX= -devel
@@ -15,38 +15,39 @@ LICENSE= GPLv3
BUILD_DEPENDS= pdftexi2dvi:${PORTSDIR}/print/texinfo \
t1ascii:${PORTSDIR}/print/t1utils \
bash:${PORTSDIR}/shells/bash \
- fontforge:${PORTSDIR}/print/fontforge \
+ convert:${PORTSDIR}/graphics/ImageMagick \
dblatex:${PORTSDIR}/textproc/dblatex \
+ fontforge:${PORTSDIR}/print/fontforge \
+ help2man:${PORTSDIR}/misc/help2man \
pngtopnm:${PORTSDIR}/graphics/netpbm \
rsync:${PORTSDIR}/net/rsync \
+ zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/share/ghostscript/fonts/c059033l.pfb:${PORTSDIR}/print/gsfonts
+RUN_DEPENDS= mftrace:${PORTSDIR}/print/mftrace \
+ ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
+
LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile \
libgmp.so:${PORTSDIR}/math/gmp \
libfreetype.so:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= mftrace:${PORTSDIR}/print/mftrace \
- convert:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf:${PORTSDIR}/x11-fonts/dejavu
-
-INFO= lilypond-notation \
- lilypond-usage \
- lilypond-internals \
- lilypond-learning \
+INFO= internals \
lilypond-changes \
lilypond-contributor \
lilypond-essay \
lilypond-extending \
- lilypond-snippets \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-usage \
lilypond-web \
- music-glossary \
- internals
+ music-glossary
-USES= bison gettext gmake pkgconfig perl5
+USES= bison:build gettext gmake pkgconfig perl5
USE_GHOSTSCRIPT=9
-USE_PYTHON= 2
-USE_PERL5= build
USE_TEX= latex
+USE_PYTHON= -3
+USE_PERL5= build
USE_GNOME= pango
MAKEFILE= GNUmakefile
@@ -54,13 +55,14 @@ GNU_MAKEFILE= yes
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts
+CONFIGURE_ARGS+=--with-ncsb-dir=${LOCALBASE}/share/ghostscript/fonts \
+ --with-python-include=${PYTHON_INCLUDEDIR}
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} YACC=${YACC}
ALL_TARGET= all
-NOCCACHE= yes
+NO_CCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/print/lilypond-devel/distinfo b/print/lilypond-devel/distinfo
index 85eb70546f61..65c94e0f4284 100644
--- a/print/lilypond-devel/distinfo
+++ b/print/lilypond-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lilypond-2.17.97.tar.gz) = ca8d1bc03f35399d40f768d773282e44c903a6315669d0cd385fb0c473d4aebf
-SIZE (lilypond-2.17.97.tar.gz) = 15982053
+SHA256 (lilypond-2.19.0.tar.gz) = 358da6b1b3bd1fc7649d4c2d883b7b2e185497f6c710cafe2985f33b77a3891b
+SIZE (lilypond-2.19.0.tar.gz) = 16022495
diff --git a/print/lilypond-devel/pkg-plist b/print/lilypond-devel/pkg-plist
index fbaa719c4b7f..f988a64f7e78 100644
--- a/print/lilypond-devel/pkg-plist
+++ b/print/lilypond-devel/pkg-plist
@@ -32,9 +32,12 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/otf/emmentaler-23.otf
%%DATADIR%%/%%PORTVERSION%%/fonts/otf/emmentaler-26.otf
%%DATADIR%%/%%PORTVERSION%%/fonts/otf/emmentaler-brace.otf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/common-modules-and-initialization.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/debugging-settings.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/declare-autometric-parameters.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-accidentals.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-accordion.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet11.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet13.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet14.mf
@@ -43,6 +46,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet20.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet23.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-alphabet26.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-arrow.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-arrowheads.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-autometric.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-a.mf
@@ -52,6 +56,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-e.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-f.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-g.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-h.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces-i.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-braces.mf
@@ -69,8 +74,9 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags20.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags23.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flags26.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-generic.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-flats.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-macros.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-naturals.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads11.mf
@@ -82,17 +88,13 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads23.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-noteheads26.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-numbers.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-other-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-params.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-parenthesis.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-pedals.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-rests.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-scripts.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test-generic.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test11.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test13.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test16.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test20.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test23.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-test26.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-sharps.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-ties.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-timesignatures.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/feta-trills.mf
@@ -109,7 +111,6 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-custodes.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-dots.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-flags.mf
-%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-macros.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads.mf
@@ -121,6 +122,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads20.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads23.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-noteheads26.mf
+%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-other-generic.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-rests.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-scripts.mf
%%DATADIR%%/%%PORTVERSION%%/fonts/source/parmesan-timesignatures.mf
@@ -191,6 +193,7 @@ lib/lilypond/%%PORTVERSION%%/python/midi.so
%%DATADIR%%/%%PORTVERSION%%/ly/predefined-mandolin-fretboards.ly
%%DATADIR%%/%%PORTVERSION%%/ly/predefined-ukulele-fretboards.ly
%%DATADIR%%/%%PORTVERSION%%/ly/property-init.ly
+%%DATADIR%%/%%PORTVERSION%%/ly/satb.ly
%%DATADIR%%/%%PORTVERSION%%/ly/scale-definitions-init.ly
%%DATADIR%%/%%PORTVERSION%%/ly/scheme-sandbox.ly
%%DATADIR%%/%%PORTVERSION%%/ly/script-init.ly