aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-11 14:16:31 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-11 14:16:31 +0000
commitf1533e225a0b126edc000443ec7e4840feabbb7d (patch)
treecb0df2020458df8afb06635c9a4fccea5b0ae6f1 /print
parent1242edb11dce6b327ea195253804fed0a2c2f580 (diff)
downloadports-f1533e225a0b126edc000443ec7e4840feabbb7d.tar.gz
ports-f1533e225a0b126edc000443ec7e4840feabbb7d.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latexdiff/Makefile40
-rw-r--r--print/latexdiff/distinfo3
-rw-r--r--print/latexdiff/files/patch-Makefile49
-rw-r--r--print/latexdiff/pkg-descr11
5 files changed, 104 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 5790edf5f661..78946b947df6 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -141,6 +141,7 @@
SUBDIR += latex-xcolor
SUBDIR += latex2rtf
SUBDIR += latex2slides
+ SUBDIR += latexdiff
SUBDIR += latexmk
SUBDIR += lgrind
SUBDIR += libgnomecups
diff --git a/print/latexdiff/Makefile b/print/latexdiff/Makefile
new file mode 100644
index 000000000000..582fbab8c0a9
--- /dev/null
+++ b/print/latexdiff/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: latexdiff
+# Date created: 01 Oct 2005
+# Whom: Maxim Loginov <Zeliboba@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= latexdiff
+PORTVERSION= 0.3
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= support
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= Zeliboba@mail.ru
+COMMENT= Determine and mark up significant differences between latex files
+
+USE_PERL5_RUN= yes
+
+USE_GMAKE= no
+USE_ZIP= yes
+
+MAN1= latexdiff.1 \
+ latexrevise.1
+
+PLIST_FILES= bin/latexdiff \
+ bin/latexdiff-cvs \
+ bin/latexdiff-so \
+ bin/latexrevise
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above. Please use the lang/perl port to install it
+.endif
+
+do-build:
+# empty
+
+.include <bsd.port.post.mk>
diff --git a/print/latexdiff/distinfo b/print/latexdiff/distinfo
new file mode 100644
index 000000000000..e0e3b50f4b13
--- /dev/null
+++ b/print/latexdiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (latexdiff.zip) = 955a9738995c874f31aaf6bc0fda6882
+SHA256 (latexdiff.zip) = 12d1265634bf609d2878cd6502e262e69dc18f6d907a979c4bb10af678290613
+SIZE (latexdiff.zip) = 291781
diff --git a/print/latexdiff/files/patch-Makefile b/print/latexdiff/files/patch-Makefile
new file mode 100644
index 000000000000..0859b3e150be
--- /dev/null
+++ b/print/latexdiff/files/patch-Makefile
@@ -0,0 +1,49 @@
+--- Makefile.orig Tue Oct 4 04:36:54 2005
++++ Makefile Fri Nov 11 15:00:19 2005
+@@ -2,7 +2,7 @@
+ # For the current setting you will need root permission but
+ # it is perfectly acceptable to choose user directories
+ #
+-INSTALLPATH = /usr/local
++INSTALLPATH = ${PREFIX}
+ INSTALLMANPATH = $(INSTALLPATH)/man
+ INSTALLEXECPATH = $(INSTALLPATH)/bin
+
+@@ -15,28 +15,31 @@
+ @echo "To install the version which uses the system Algorithm::Diff package type: make install-ext"
+ @echo " "
+
++dirs:
++ mkdir -p $(INSTALLMANPATH)/man1 $(INSTALLEXECPATH)
++
+ install: install-so
+
+ install-ext: install-latexdiff install-latexrevise install-latexdiff-cvs install-man
+
+-install-so: install-latexdiff-so install-latexrevise install-latexdiff-cvs install-man
++install-so: dirs install-latexdiff-so install-latexrevise install-latexdiff-cvs install-man
+
+ install-man:
+- install latexrevise.1 latexdiff.1 $(INSTALLMANPATH)/man1
++ ${BSD_INSTALL_MAN} latexrevise.1 latexdiff.1 $(INSTALLMANPATH)/man1
+
+ install-latexdiff:
+- install latexdiff $(INSTALLEXECPATH)
++ ${BSD_INSTALL_SCRIPT} latexdiff $(INSTALLEXECPATH)
+
+ install-latexdiff-so:
+ if [ -e $(INSTALLEXECPATH)/latexdiff ]; then rm $(INSTALLEXECPATH)/latexdiff; fi
+- install latexdiff-so $(INSTALLEXECPATH)
++ ${BSD_INSTALL_SCRIPT} latexdiff-so $(INSTALLEXECPATH)
+ cd $(INSTALLEXECPATH); ln -s latexdiff-so latexdiff
+
+ install-latexrevise:
+- install latexrevise $(INSTALLEXECPATH)
++ ${BSD_INSTALL_SCRIPT} latexrevise $(INSTALLEXECPATH)
+
+ install-latexdiff-cvs:
+- install latexdiff-cvs $(INSTALLEXECPATH)
++ ${BSD_INSTALL_SCRIPT} latexdiff-cvs $(INSTALLEXECPATH)
+
+ test: test-so
+
diff --git a/print/latexdiff/pkg-descr b/print/latexdiff/pkg-descr
new file mode 100644
index 000000000000..2e804580b86a
--- /dev/null
+++ b/print/latexdiff/pkg-descr
@@ -0,0 +1,11 @@
+latexdiff is a Perl script, which compares two latex files and marks
+up significant differences between them (i.e. a diff for latex files).
+ Various options are available for visual markup using standard latex
+packages such as "color.sty". Changes not directly affecting visible
+text, for example in formatting commands, are still marked in
+the latex source.
+
+A rudimentary revision facilility is provided by another Perl script,
+latexrevise, which accepts or rejects all changes. Manual
+editing of the difference file can be used to override this default
+behaviour and accept or reject selected changes only.