aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
commit065c026fe5e21a269bbaae0ce69307c7308acbea (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /print
parent6d6314e20da82ad66b7b278eee92373caa9ab746 (diff)
downloadports-065c026fe5e21a269bbaae0ce69307c7308acbea.tar.gz
ports-065c026fe5e21a269bbaae0ce69307c7308acbea.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/adobe-cmaps/Makefile4
-rw-r--r--print/enscriptfonts/Makefile8
-rw-r--r--print/ghostscript7-commfont/Makefile1
-rw-r--r--print/texlive-texmf/Makefile4
-rw-r--r--print/txtbdf2ps/Makefile2
5 files changed, 10 insertions, 9 deletions
diff --git a/print/adobe-cmaps/Makefile b/print/adobe-cmaps/Makefile
index 4420a2ca94fb..3ba92c0f7269 100644
--- a/print/adobe-cmaps/Makefile
+++ b/print/adobe-cmaps/Makefile
@@ -21,11 +21,11 @@ INSTDIRS= ac15 ag15 ai0 aj16 aj20 ak12 rksj-cmaps
FONTSDIR= ${PREFIX}/share/fonts/${PORTNAME}
post-extract:
- ${RM} -f ${WRKDIR}/ag15/.nfsFA55
+ ${RM} -f ${WRKSRC}/ag15/.nfsFA55
do-install:
${MKDIR} ${STAGEDIR}${FONTSDIR}
- cd ${WRKDIR} && \
+ cd ${WRKSRC} && \
${TAR} cf - ${INSTDIRS} | \
(cd ${STAGEDIR}${FONTSDIR} && ${TAR} xf - )
diff --git a/print/enscriptfonts/Makefile b/print/enscriptfonts/Makefile
index cb4e8d6a73ff..dd6e0e149b43 100644
--- a/print/enscriptfonts/Makefile
+++ b/print/enscriptfonts/Makefile
@@ -22,9 +22,9 @@ SUB_FILES+= pkg-message
do-install:
@${MKDIR} -p ${STAGEDIR}${PREFIX}/share/enscript/xenscript
- @${CP} -p ${WRKDIR}/README ${STAGEDIR}${PREFIX}/share/enscript/xenscript
- @${CP} -p ${WRKDIR}/font.map ${STAGEDIR}${PREFIX}/share/enscript/xenscript
- @${CP} -p ${WRKDIR}/*.afm ${STAGEDIR}${PREFIX}/share/enscript/xenscript
- @${CP} -p ${WRKDIR}/*.readme ${STAGEDIR}${PREFIX}/share/enscript/xenscript
+ @${CP} -p ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/enscript/xenscript
+ @${CP} -p ${WRKSRC}/font.map ${STAGEDIR}${PREFIX}/share/enscript/xenscript
+ @${CP} -p ${WRKSRC}/*.afm ${STAGEDIR}${PREFIX}/share/enscript/xenscript
+ @${CP} -p ${WRKSRC}/*.readme ${STAGEDIR}${PREFIX}/share/enscript/xenscript
.include <bsd.port.mk>
diff --git a/print/ghostscript7-commfont/Makefile b/print/ghostscript7-commfont/Makefile
index ce891fe229ef..3847c1cfbf76 100644
--- a/print/ghostscript7-commfont/Makefile
+++ b/print/ghostscript7-commfont/Makefile
@@ -34,5 +34,6 @@ CMAPDIR?= ${LOCALBASE}/share/fonts/adobe-cmaps
GS_RESDIR?= share/ghostscript/Resource
post-extract: apply-slist
+ @cd ${WRKDIR} && ${MV} Makefile template.* ${WRKSRC}
.include <bsd.port.mk>
diff --git a/print/texlive-texmf/Makefile b/print/texlive-texmf/Makefile
index afa7b8d833b3..f75fa0f5976d 100644
--- a/print/texlive-texmf/Makefile
+++ b/print/texlive-texmf/Makefile
@@ -255,7 +255,7 @@ EXCLUDE_FILES= \*/doc/man \
EXTRACT_AFTER_ARGS=| ${TAR} xf - ${EXCLUDE_FILES:S,^,--exclude ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}/,}
post-extract:
- cd ${WRKDIR}/latex-base-20150101.2 && \
+ cd ${WRKSRC}/latex-base-20150101.2 && \
${SETENV} TEXMF=. ${LOCALBASE}/bin/tex -ini unpack.ins && \
${RM} README *.log *.aux *.pdf *.dtx *.ins *.txt *.ist *.fdd *.err
@@ -264,7 +264,7 @@ do-install:
${EXTRACT_AFTER_ARGS} -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner
${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/tex/latex/base
- cd ${WRKDIR}/latex-base-20150101.2 && ${PAX} -rw . \
+ cd ${WRKSRC}/latex-base-20150101.2 && ${PAX} -rw . \
${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/tex/latex/base
${REINPLACE_CMD} -i '' 's/\\def\\magyar@sugg@ie@low#1#2#3/\\def\\magyar@sugg@ie@low\\protect #1#2#3/' ${STAGEDIR}${PREFIX}/share/texmf-dist/tex/generic/babel-hungarian/magyar.ldf
${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/doc
diff --git a/print/txtbdf2ps/Makefile b/print/txtbdf2ps/Makefile
index 6bf6582776bf..79f2dfd12434 100644
--- a/print/txtbdf2ps/Makefile
+++ b/print/txtbdf2ps/Makefile
@@ -16,7 +16,7 @@ PLIST_FILES= bin/txtbdf2ps
USES= perl5 shebangfix
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= ${WRKDIR}
+EXTRACT_AFTER_ARGS= ${WRKSRC}
SHEBANG_FILES= ${DISTNAME}.txt
NO_WRKSUBDIR= yes
NO_ARCH= yes