aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-05-03 20:54:49 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-05-03 20:54:49 +0000
commit0722bfbdea7df6f3f90765a32e3f8517d73a5cd9 (patch)
tree4bfc1d8a482ec6953c0ac90b787f1059439d43ad /print
parentc9b075b714c753d4dc26c047c771fb84ab23d3d9 (diff)
downloadports-0722bfbdea7df6f3f90765a32e3f8517d73a5cd9.tar.gz
ports-0722bfbdea7df6f3f90765a32e3f8517d73a5cd9.zip
Fix shebangs.
Notes
Notes: svn path=/head/; revision=440041
Diffstat (limited to 'print')
-rw-r--r--print/lyx/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index f98914cbb858..6b96f64d3972 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lyx
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
@@ -22,7 +22,7 @@ MAJOR_VERSION= 2.2
MINOR_VERSION= 2
USES= desktop-file-utils execinfo gmake iconv pkgconfig perl5 \
- python:2 tar:xz
+ python:2 shebangfix tar:xz
USE_QT5= core concurrent gui svg widgets buildtools_build qmake_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
@@ -31,6 +31,9 @@ CONFIGURE_ARGS= --without-included-boost \
--with-qt-dir=${LOCALBASE}/lib/qt5 \
${ICONV_CONFIGURE_ARG} \
--with-extra-prefix=${LOCALBASE}
+SHEBANG_FILES= lib/configure.py \
+ lib/lyx2lyx/lyx2lyx \
+ lib/scripts/listerrors
CPPFLAGS+= ${EXECINFO_CPPFLAGS}
LDFLAGS+= ${EXECINFO_LDFLAGS}